aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tofrodos/tofrodos
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tofrodos/tofrodos
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tofrodos/tofrodos')
-rw-r--r--recipes/tofrodos/tofrodos/cross.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/tofrodos/tofrodos/cross.patch b/recipes/tofrodos/tofrodos/cross.patch
new file mode 100644
index 0000000000..b8a94c7370
--- /dev/null
+++ b/recipes/tofrodos/tofrodos/cross.patch
@@ -0,0 +1,51 @@
+--- /tmp/Makefile 2008-12-08 11:02:39.000000000 +0100
++++ tofrodos/src/Makefile 2008-12-08 11:07:13.000000000 +0100
+@@ -23,13 +23,11 @@
+ endif
+
+ # programs
+-CC = gcc
+ CD = cd
+ CP = cp
+ GZIP = gzip
+ INSTALL = install
+ LN = ln
+-LD = gcc
+ MAKE = make
+ MKDIR = mkdir
+ MV = mv
+@@ -38,7 +36,7 @@
+ ZIP = zip
+
+ # flags
+-CFLAGS = $(DEFINES) $(TFLAG) $(CDEBUG) -c -Wall
++CCFLAGS = $(DEFINES) $(TFLAG) $(CDEBUG) -c -Wall
+ GZIPFLAGS = -9
+ INSTALLBINFLAGS = -m 755
+ INSTALLDATAFLAGS = -m 644
+@@ -96,7 +94,7 @@
+
+ # implicit rules
+ .c.o:
+- $(CC) $(CFLAGS) $<
++ $(CC) $(CCFLAGS) $(CFLAGS) $<
+
+ # user visible rules
+ all: $(FROMDOS) $(TODOS)
+@@ -119,12 +117,12 @@
+ $(RM) $(RMRECURFLAGS) $(DISTDIR)
+
+ install: installman
+- $(INSTALL) $(INSTALLBINFLAGS) $(FROMDOS) $(BINDIR)
+- ($(CD) $(BINDIR) ; $(LN) $(LNFLAGS) fromdos todos)
++ $(INSTALL) $(INSTALLBINFLAGS) $(FROMDOS) $(DESTDIR)$(BINDIR)
++ ($(CD) $(DESTDIR)$(BINDIR) ; $(LN) $(LNFLAGS) fromdos todos)
+
+ installman: $(FROMDOSMAN)
+- $(INSTALL) $(INSTALLDATAFLAGS) $(FROMDOSMAN) $(MANDIR)
+- ($(CD) $(MANDIR) ; $(LN) $(LNFLAGS) fromdos.1 todos.1)
++ $(INSTALL) $(INSTALLDATAFLAGS) $(FROMDOSMAN) $(DESTDIR)$(MANDIR)
++ ($(CD) $(DESTDIR)$(MANDIR) ; $(LN) $(LNFLAGS) fromdos.1 todos.1)
+
+ save:
+ $(ZIP) $(ZIPSRCFLAGS) $(ZIPSRCNAME) *