aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/totem
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-09 11:26:25 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-09 13:06:32 +0200
commitbf7567b7b58c45698ee5342ea3c630292c908ad9 (patch)
treecc8619cec7c21bebd8de1502bbd120e9e6a3d78e /recipes/totem
parent49a4f2e384f8b239648852de9b3dc1e01f345731 (diff)
downloadopenembedded-bf7567b7b58c45698ee5342ea3c630292c908ad9.tar.gz
totem: add 2.30.0
Diffstat (limited to 'recipes/totem')
-rw-r--r--recipes/totem/totem-2.30.0/gst-detect.diff46
-rw-r--r--recipes/totem/totem_2.30.0.bb90
2 files changed, 136 insertions, 0 deletions
diff --git a/recipes/totem/totem-2.30.0/gst-detect.diff b/recipes/totem/totem-2.30.0/gst-detect.diff
new file mode 100644
index 0000000000..6ac4455ad0
--- /dev/null
+++ b/recipes/totem/totem-2.30.0/gst-detect.diff
@@ -0,0 +1,46 @@
+--- /tmp/configure.in 2009-10-21 11:43:19.000000000 +0200
++++ totem-2.28.1/configure.in 2009-10-21 11:47:21.000000000 +0200
+@@ -110,10 +110,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 tool 'gst-inspect-0.10'.
+- It should be part of gstreamer-0_10-utils. Please install it.
+- ])
+ fi
+
+ dnl Check for elements from gst-plugins-base
+@@ -124,10 +120,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$base_element'.
+- It should be part of gst-plugins-base. Please install it.
+- ])
+ fi
+ done
+
+@@ -139,10 +131,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$good_element'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
+ fi
+ done
+
+@@ -570,10 +558,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin 'souphttpsrc'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
+ fi
+ ;;
+ esac
diff --git a/recipes/totem/totem_2.30.0.bb b/recipes/totem/totem_2.30.0.bb
new file mode 100644
index 0000000000..e6367b6490
--- /dev/null
+++ b/recipes/totem/totem_2.30.0.bb
@@ -0,0 +1,90 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = " nautilus tracker gnome-doc-utils libunique libgdata totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS_${PN} += "iso-codes"
+RRECOMMENDS_${PN} += "gst-plugin-playbin \
+ gst-plugin-gconfelements \
+ gst-plugin-decodebin \
+ gst-plugin-decodebin2 \
+ gst-ffmpeg \
+ gst-plugin-audioresample \
+ gst-plugin-ximagesink \
+ gst-plugin-xvimagesink \
+ gst-plugin-alsa \
+ gst-plugin-avi \
+ gst-plugin-ffmpegcolorspace \
+ gst-plugin-flv \
+ gst-plugin-nuvdemux \
+ gst-plugin-videoscale \
+ gst-plugin-a52dec \
+ gst-plugin-mpegaudioparse \
+ gst-plugin-ossaudio \
+ gst-plugin-pulse \
+ gst-plugin-autodetect \
+ totem-plugin-thumbnail totem-plugin-dbus "
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+SRC_URI[archive.md5sum] = "ecee18e876f6adf5845f71ace87549ca"
+SRC_URI[archive.sha256sum] = "9d8edd266bd2546e4c8034de1196b79855e24a3634d05cc4f8a07fd3edc7b1af"
+
+EXTRA_OECONF=" --enable-shared \
+ --disable-static \
+ --disable-schemas-install \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --disable-vala \
+ --enable-python \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+ sed -i \
+ -e s:'`$PKG_CONFIG --variable defsdir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=pygtkincludedir pygobject-2.0`':\"${STAGING_INCDIR}/pygtk-2.0\":g \
+ -e s:'`$PKG_CONFIG --variable=datadir pygobject-2.0`':\"${STAGING_DATADIR}\":g \
+ -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=codegendir pygtk-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
+ -e 's:PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION":PYTHON_CFLAGS="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g' \
+ ${S}/configure.in
+}
+
+PACKAGES_DYNAMIC += " totem-plugin-* "
+
+python populate_packages_prepend () {
+ totem_libdir = bb.data.expand('${libdir}/totem/plugins/', d)
+
+ do_split_packages(d, totem_libdir, '^(.*)', 'totem-plugin-%s', 'totem plugin for %s', allow_dirs=True, extra_depends='')
+}
+
+FILES_${PN} = "${bindir}/* ${sysconfdir} ${libdir}/lib*.so.* ${libexecdir} ${datadir}/icons ${datadir}/totem ${datadir}/applications \
+"
+
+RDEPENDS_totem-plugin-iplayer_append = "python-pygtk gst-plugin-flv"
+RDEPENDS_totem-plugin-youtube_append = "python-pygtk gnome-vfs-plugin-http gst-plugin-gnomevfs gst-plugin-flv"
+
+
+PACKAGES =+ "totem-nautilus-extension totem-browser-plugin-dbg totem-browser-plugin"
+
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_${PN}-dev += "${libdir}/totem/plugins/*/*a"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"
+
+FILES_totem-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so"
+
+
+