aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tracker
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tracker
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tracker')
-rwxr-xr-xrecipes/tracker/files/90tracker4
-rw-r--r--recipes/tracker/files/no-ioprio.patch22
-rw-r--r--recipes/tracker/tracker_0.5.4.bb25
3 files changed, 51 insertions, 0 deletions
diff --git a/recipes/tracker/files/90tracker b/recipes/tracker/files/90tracker
new file mode 100755
index 0000000000..9594b91689
--- /dev/null
+++ b/recipes/tracker/files/90tracker
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+/usr/bin/trackerd -m &
+
diff --git a/recipes/tracker/files/no-ioprio.patch b/recipes/tracker/files/no-ioprio.patch
new file mode 100644
index 0000000000..2ce4990bd4
--- /dev/null
+++ b/recipes/tracker/files/no-ioprio.patch
@@ -0,0 +1,22 @@
+--- /tmp/configure.ac 2007-04-30 13:34:39.000000000 +0200
++++ tracker-0.5.4/configure.ac 2007-04-30 13:37:48.405251000 +0200
+@@ -513,19 +513,6 @@
+
+ AC_MSG_CHECKING([[checking ioprio support]])
+ ioprio_support=no
+-AC_RUN_IFELSE([ AC_LANG_PROGRAM([[
+-#include <stdlib.h>
+-#include <errno.h>
+-#include <sys/syscall.h>
+-#include <unistd.h>
+-inline int ioprio_get (int which, int who)
+-{
+- return syscall (__NR_ioprio_get, which, who);
+-}
+- ]], [[
+-exit(ioprio_get(1,0));
+- ]]) ],
+- [ AC_DEFINE(IOPRIO_SUPPORT,[],[Define ioprio support]) ioprio_support=yes ])
+ AC_MSG_RESULT([$ioprio_support])
+
+ #####################################################
diff --git a/recipes/tracker/tracker_0.5.4.bb b/recipes/tracker/tracker_0.5.4.bb
new file mode 100644
index 0000000000..4753280190
--- /dev/null
+++ b/recipes/tracker/tracker_0.5.4.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Tracker is a tool designed to extract information and metadata about your personal data so that it can be searched easily and quickly."
+LICENSE = "GPLv2"
+DEPENDS = "file gtk+ gstreamer gamin libgmime dbus poppler libexif libgsf"
+
+PR = "r3"
+
+SRC_URI = "http://www.gnome.org/~jamiemcc/tracker/tracker-${PV}.tar.gz \
+ file://no-ioprio.patch;patch=1 \
+ file://90tracker "
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ cp -dPr ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true
+ install -d ${D}/${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/dbus-1/"
+CONFFILES_${PN} += "${sysconfdir}/X11/Xsession.d/90tracker"
+