aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tslib
diff options
context:
space:
mode:
authorEric BĂ©nard <eric@eukrea.com>2009-09-24 09:02:10 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-09-29 10:13:27 +0200
commitdfcc18bf49b37bea6d31162cc2eb5835a822bf83 (patch)
tree568a9d97ef7e9fc3e1741a77ec5e4d41337a6c42 /recipes/tslib
parentd017723ad88c3f9ace47da27795e855fff05cb72 (diff)
downloadopenembedded-dfcc18bf49b37bea6d31162cc2eb5835a822bf83.tar.gz
tslib_1.0: Apply patch from r56 to link plugins to libts
The patch sent to the list was integrated into tslib in november 2008: http://svn.berlios.de/viewcvs/tslib/trunk/tslib/plugins/Makefile.am?r1=51&r2=56 Please find attached a patch to add this patch to the tslib's recipe. http://patchwork.openembedded.org/patch/1078/ Signed-off-by: Eric Benard <eric@eukrea.com> Signed-off-by: Holger Hans Peter Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/tslib')
-rw-r--r--recipes/tslib/tslib/tslib-pluginsld.patch36
-rw-r--r--recipes/tslib/tslib_1.0.bb5
2 files changed, 39 insertions, 2 deletions
diff --git a/recipes/tslib/tslib/tslib-pluginsld.patch b/recipes/tslib/tslib/tslib-pluginsld.patch
new file mode 100644
index 0000000000..37ef80879e
--- /dev/null
+++ b/recipes/tslib/tslib/tslib-pluginsld.patch
@@ -0,0 +1,36 @@
+ plugins/Makefile.am | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 3b902c2..4c4ef8b 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -114,15 +114,19 @@ pluginexec_LTLIBRARIES = \
+
+ variance_la_SOURCES = variance.c
+ variance_la_LDFLAGS = -module $(LTVSN)
++variance_la_LIBADD = $(top_builddir)/src/libts.la
+
+ dejitter_la_SOURCES = dejitter.c
+ dejitter_la_LDFLAGS = -module $(LTVSN)
++dejitter_la_LIBADD = $(top_builddir)/src/libts.la
+
+ linear_la_SOURCES = linear.c
+ linear_la_LDFLAGS = -module $(LTVSN)
++linear_la_LIBADD = $(top_builddir)/src/libts.la
+
+ pthres_la_SOURCES = pthres.c
+ pthres_la_LDFLAGS = -module $(LTVSN)
++pthres_la_LIBADD = $(top_builddir)/src/libts.la
+
+ # hw access
+ corgi_la_SOURCES = corgi-raw.c
+@@ -148,6 +152,7 @@ tatung_la_LDFLAGS = -module $(LTVSN)
+
+ input_la_SOURCES = input-raw.c
+ input_la_LDFLAGS = -module $(LTVSN)
++input_la_LIBADD = $(top_builddir)/src/libts.la
+
+ linear_h2200_la_SOURCES = linear-h2200.c
+ linear_h2200_la_LDFLAGS = -module $(LTVSN)
+
diff --git a/recipes/tslib/tslib_1.0.bb b/recipes/tslib/tslib_1.0.bb
index 1929ee0557..58a0e35bd1 100644
--- a/recipes/tslib/tslib_1.0.bb
+++ b/recipes/tslib/tslib_1.0.bb
@@ -1,6 +1,7 @@
SRC_URI = "http://download.berlios.de/tslib/${BP}.tar.bz2 \
file://fix_version.patch;patch=1 \
- file://tslib-nopressure.patch;patch=1"
-PR = "${INC_PR}.2"
+ file://tslib-nopressure.patch;patch=1 \
+ file://tslib-pluginsld.patch;patch=1"
+PR = "${INC_PR}.3"
include tslib.inc