aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tunctl
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2009-04-17 01:30:24 +0000
committerKoen Kooi <koen@openembedded.org>2009-04-21 22:45:50 +0200
commit78d0562c92c7338e119a3b92e1a273073d6039ad (patch)
treeefea38d26a48bd3c06e6ed35b9ab7f54b95bcfc3 /recipes/tunctl
parent5a1d7e7a88c6ef8ac0ca4c7034e637f831a05faf (diff)
downloadopenembedded-78d0562c92c7338e119a3b92e1a273073d6039ad.tar.gz
tunctl: new recipe, version 1.5
Tool for controlling the TUN/TAP driver in Linux. Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/tunctl')
-rw-r--r--recipes/tunctl/tunctl.inc14
-rw-r--r--recipes/tunctl/tunctl_1.5.bb1
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes/tunctl/tunctl.inc b/recipes/tunctl/tunctl.inc
new file mode 100644
index 0000000000..c9c7e95664
--- /dev/null
+++ b/recipes/tunctl/tunctl.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "The tunctl tool for controlling the TUN/TAP driver in Linux."
+SECTION = "net"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tunctl/tunctl-${PV}.tar.gz"
+
+do_compile() {
+ oe_runmake tunctl
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 755 tunctl ${D}/${sbindir}
+}
diff --git a/recipes/tunctl/tunctl_1.5.bb b/recipes/tunctl/tunctl_1.5.bb
new file mode 100644
index 0000000000..8a988a84f3
--- /dev/null
+++ b/recipes/tunctl/tunctl_1.5.bb
@@ -0,0 +1 @@
+require tunctl.inc