aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/twin
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/twin
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/twin')
-rw-r--r--recipes/twin/twin-0.4.6/cross_compile.patch156
-rw-r--r--recipes/twin/twin_0.4.6.bb21
-rw-r--r--recipes/twin/twutils_0.2.bb18
3 files changed, 195 insertions, 0 deletions
diff --git a/recipes/twin/twin-0.4.6/cross_compile.patch b/recipes/twin/twin-0.4.6/cross_compile.patch
new file mode 100644
index 0000000000..7f8163a78a
--- /dev/null
+++ b/recipes/twin/twin-0.4.6/cross_compile.patch
@@ -0,0 +1,156 @@
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/Makefile.in twin-0.4.6/Makefile.in
+--- ../twin-0.4.6-r0/twin-0.4.6/Makefile.in 2003-03-27 08:29:47 +00:00
++++ twin-0.4.6/Makefile.in 2004-07-27 13:04:46 +01:00
+@@ -71,33 +71,33 @@
+ # to correctly generate include/autoconf.h
+ #
+
+-ADMIN_LIBTOOLS:=admin/ltmain.sh admin/config.guess admin/config.sub
++#ADMIN_LIBTOOLS:=admin/ltmain.sh admin/config.guess admin/config.sub
+
+-$(ADMIN_LIBTOOLS):
+- libtoolize -c
++#$(ADMIN_LIBTOOLS):
++# libtoolize -c
+
+-ADMIN_ACLOCAL:=admin/aclocal.m4
++#ADMIN_ACLOCAL:=admin/aclocal.m4
+
+-DISTCLEAN_EMPTY_FILES:=$(ADMIN_ACLOCAL) $(ADMIN_LIBTOOLS)
++#DISTCLEAN_EMPTY_FILES:=$(ADMIN_ACLOCAL) $(ADMIN_LIBTOOLS)
+
+-$(ADMIN_ACLOCAL):
+- @if [ -f /usr/share/aclocal/libtool.m4 ]; then \
+- echo $(LN) /usr/share/aclocal/libtool.m4 $@ ; \
+- $(LN) /usr/share/aclocal/libtool.m4 $@ ; \
+- else \
+- echo touch $@; \
+- touch $@; \
+- fi
++#$(ADMIN_ACLOCAL):
++# @if [ -f /usr/share/aclocal/libtool.m4 ]; then \
++# echo $(LN) /usr/share/aclocal/libtool.m4 $@ ; \
++# $(LN) /usr/share/aclocal/libtool.m4 $@ ; \
++# else \
++# echo touch $@; \
++# touch $@; \
++# fi
+
+-configure: configure.in $(ADMIN_LIBTOOLS) $(ADMIN_ACLOCAL) include/autoconf.h.in
+- rm -f $@ && autoconf --localdir=admin
++#configure: configure.in $(ADMIN_LIBTOOLS) $(ADMIN_ACLOCAL) include/autoconf.h.in
++# rm -f $@ && autoconf
+
+-include/autoconf.h.in: configure.in
+- rm -f $@ && autoheader
++#include/autoconf.h.in: configure.in
++# rm -f $@ && autoheader
+
+-config.status libtool: configure $(ADMIN_LIBTOOLS)
+- @echo Updating config.status libtool
+- ./configure --cache-file=config.cache --no-create
++#config.status libtool: configure $(ADMIN_LIBTOOLS)
++# @echo Updating config.status libtool
++# ./configure --host --cache-file=config.cache --no-create
+
+ #
+ # was:
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/configure twin-0.4.6/configure
+--- ../twin-0.4.6-r0/twin-0.4.6/configure 2003-03-27 08:29:47 +00:00
++++ twin-0.4.6/configure 2004-07-27 13:11:21 +01:00
+@@ -1235,7 +1235,7 @@
+
+ make_is_good=no
+ if test "${MAKE-make}"; then
+- ${MAKE-make} -v | head -1 | cut -d' ' -f1-4 | cut -d, -f1 | \
++ ${MAKE-make} -v | head -n 1 | cut -d' ' -f1-4 | cut -d, -f1 | \
+ while read make_GNU make_Make make_version make_numbers
+ do
+ if test "$make_GNU" = "GNU" -a "$make_Make" = "Make"; then
+@@ -2167,7 +2167,7 @@
+ lt_cv_file_magic_cmd='/usr/bin/file -L'
+ case "$host_os" in
+ rhapsody* | darwin1.[012])
+- lt_cv_file_magic_test_file=`echo /System/Library/Frameworks/System.framework/Versions/*/System | head -1`
++ lt_cv_file_magic_test_file=`echo /System/Library/Frameworks/System.framework/Versions/*/System | head -n 1`
+ ;;
+ *) # Darwin 1.3 on
+ lt_cv_file_magic_test_file='/usr/lib/libSystem.dylib'
+@@ -3670,7 +3670,7 @@
+ # If the export-symbols file already is a .def file (1st line
+ # is EXPORTS), use it as is.
+ # If DATA tags from a recent dlltool are present, honour them!
+- archive_expsym_cmds='if test "x`head -1 $export_symbols`" = xEXPORTS; then
++ archive_expsym_cmds='if test "x`head -n 1 $export_symbols`" = xEXPORTS; then
+ cp $export_symbols $output_objdir/$soname-def;
+ else
+ echo EXPORTS > $output_objdir/$soname-def;
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/configure.in twin-0.4.6/configure.in
+--- ../twin-0.4.6-r0/twin-0.4.6/configure.in 2003-03-27 08:29:47 +00:00
++++ twin-0.4.6/configure.in 2004-07-27 13:18:07 +01:00
+@@ -188,7 +188,7 @@
+
+ make_is_good=no
+ if test "${MAKE-make}"; then
+- ${MAKE-make} -v | head -1 | cut -d' ' -f1-4 | cut -d, -f1 | \
++ ${MAKE-make} -v | head -n 1 | cut -d' ' -f1-4 | cut -d, -f1 | \
+ while read make_GNU make_Make make_version make_numbers
+ do
+ if test "$make_GNU" = "GNU" -a "$make_Make" = "Make"; then
+@@ -378,7 +378,16 @@
+ select strdup strerror strspn strstr scandir alphasort uname \
+ vprintf vsprintf vsnprintf wait3 wait4 getpt grantpt unlockpt ptsname)
+
+-AC_CHECK_FILE(/dev/ptmx)
++AC_SEARCH_LIBS(openpty,util,
++ [
++ AC_DEFINE(HAVE_OPENPTY,1,[define if you have openpty function])
++ no_dev_ptmx=yes
++ ])
++AC_CHECK_FUNCS([_getpty])
++if test -z "$no_dev_ptmx" ; then
++ AC_CHECK_FILE(/dev/ptmx)
++fi
++
+ AC_CHECK_FUNC(crypt,,AC_CHECK_LIB(crypt,crypt))
+ AC_CHECK_FUNC(dlopen,,AC_CHECK_LIB(dl,dlopen))
+ AC_CHECK_LIB(ltdl,lt_dlopen)
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/makerules twin-0.4.6/makerules
+--- ../twin-0.4.6-r0/twin-0.4.6/makerules 2003-03-27 08:29:48 +00:00
++++ twin-0.4.6/makerules 2004-07-27 13:04:46 +01:00
+@@ -794,7 +794,7 @@
+ endif
+
+ $(TOPDIR)/scripts/Getsizes: $(TOPDIR)/scripts/getsizes.c $(TOPDIR)/include/Tw/datatypes.h $(TOPDIR)/include/autoconf.h
+- $(CC) $(CC_FLAGS) $(CC_FLAGS_script_getsizes.o) $(LD_FLAGS) $< -o $@
++ $(HOSTCC) $(CC_FLAGS) $(CC_FLAGS_script_getsizes.o) $(LD_FLAGS) $< -o $@
+ @echo "PREVIOUS_CONF__LONG_LONG=$(CONF__LONG_LONG)" > $(TOPDIR)/.long_long.conf
+
+ #
+@@ -802,10 +802,10 @@
+ # but this is the best place to force creating it
+ #
+ $(TOPDIR)/scripts/Mkdep: $(TOPDIR)/scripts/mkdep.c $(TOPDIR)/include/autoconf.h $(TOPDIR)/include/Tw/datasizes.h
+- $(CC) $(CC_FLAGS) $(LD_FLAGS) $< -o $@
++ $(HOSTCC) $(CC_FLAGS) $(LD_FLAGS) $< -o $@
+
+ $(TOPDIR)/scripts/Bitmap: $(TOPDIR)/scripts/bitmap.c
+- $(CC) $(CC_FLAGS) $(LD_FLAGS) $< -o $@
++ $(HOSTCC) $(CC_FLAGS) $(LD_FLAGS) $< -o $@
+
+
+ #
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/scripts/mkdep.c twin-0.4.6/scripts/mkdep.c
+--- ../twin-0.4.6-r0/twin-0.4.6/scripts/mkdep.c 2003-03-27 08:29:48 +00:00
++++ twin-0.4.6/scripts/mkdep.c 2004-07-27 13:04:46 +01:00
+@@ -172,8 +172,8 @@
+ putchar('\n');
+ }
+
+-static char str_path[3][512];
+-static int len_path[3];
++static char str_path[20][512];
++static int len_path[20];
+ static int max_path = 0;
+ static int limit_path = sizeof(len_path)/sizeof(len_path[0]);
+
diff --git a/recipes/twin/twin_0.4.6.bb b/recipes/twin/twin_0.4.6.bb
new file mode 100644
index 0000000000..fdb9c25e39
--- /dev/null
+++ b/recipes/twin/twin_0.4.6.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Twin is a text-mode windowing environment: it draws and manages text windows on a text-mode display, like X11 does for graphical windows. It has a built-in window manager and terminal emulator, and can be used as server for remote clients in the same style as X11. It can display on Linux console, on X11 and inside itself."
+SECTION = "console/utils"
+
+DEPENDS = "coreutils-native"
+LICENSE = "GPL LGPL"
+SRC_URI = "http://linuz.sns.it/~max/twin/twin-0.4.6.tar.gz \
+ file://cross_compile.patch;patch=1"
+
+EXTRA_OECONF = " --disable-tt-hw-x11 --disable-hw-x11 --disable-tt-hw-gtk"
+
+inherit autotools
+
+do_compile () {
+ oe_runmake 'HOSTCC=${BUILD_CC}'
+}
+
+do_stage () {
+ oe_soinstall libs/libTw/libTw.so.3.0.9 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/Tw
+ install -m 0644 include/Tw/*.h ${STAGING_INCDIR}/Tw/
+}
diff --git a/recipes/twin/twutils_0.2.bb b/recipes/twin/twutils_0.2.bb
new file mode 100644
index 0000000000..b50a080944
--- /dev/null
+++ b/recipes/twin/twutils_0.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Utilities for twin. Currently contains 'twkalc', a calculator derived from kcalc."
+DEPENDS = "twin"
+
+SECTION = "console/utils"
+LICENSE = "GPL LGPL"
+SRC_URI = "http://linuz.sns.it/~max/twin/twutils-0.2.tar.gz"
+
+inherit autotools
+
+CXXFLAGS_append = " -DHAVE_FUNC_ISINF"
+LDFLAGS_append = " -L${STAGING_LIBDIR}"
+
+do_compile() {
+ for i in admin twkalc
+ do
+ cd ${S}/$i && oe_runmake LDFLAGS="${LDFLAGS}"
+ done
+}