summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-2009.08
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-11 09:17:13 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-11 09:17:59 +0100
commitf5b48eb44a38a1e6fff28bd92de0591e2b00d073 (patch)
treec2fe94cb22fbb327506949c19e190f926cbf166e /recipes/u-boot/u-boot-2009.08
parentbc68929ceaa163e27d8e9860e2f816065c14d0fa (diff)
downloadopenembedded-f5b48eb44a38a1e6fff28bd92de0591e2b00d073.tar.gz
Revert "u-boot_git.bb: Do not apply u-boot-remove-inline-of-weak-functions.patch"
The weak inline patch is being applied to machines that already have that in their tree and it isn't boot tested Since bootloaders are critical or machines to work this patch needs to go and is only allowed back after being boot tested on affected machines. This reverts commit 6795b4bf1ed4074fd83703c19828f91492c6507f. This reverts commit 40914431d5c2426945fe5f206d86c99222ace54b.
Diffstat (limited to 'recipes/u-boot/u-boot-2009.08')
-rw-r--r--recipes/u-boot/u-boot-2009.08/u-boot-2009.08-remove-inline-of-weak-functions.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/recipes/u-boot/u-boot-2009.08/u-boot-2009.08-remove-inline-of-weak-functions.patch b/recipes/u-boot/u-boot-2009.08/u-boot-2009.08-remove-inline-of-weak-functions.patch
deleted file mode 100644
index 77c97ea6e6..0000000000
--- a/recipes/u-boot/u-boot-2009.08/u-boot-2009.08-remove-inline-of-weak-functions.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Remove 'inline' keyword of functions with weak attribution
-
-* gcc-4.4 complains about 'inline' functions with 'weak' attribution
-Index: u-boot-2009.08/lib_arm/board.c
-===================================================================
---- u-boot-2009.08.orig/lib_arm/board.c 2009-09-01 01:57:42.000000000 +0800
-+++ u-boot-2009.08/lib_arm/board.c 2010-02-03 18:45:50.000000000 +0800
-@@ -124,23 +124,23 @@
- * May be supplied by boards if desired
- */
- void inline __coloured_LED_init (void) {}
--void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
-+void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
- void inline __red_LED_on (void) {}
--void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
-+void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
- void inline __red_LED_off(void) {}
--void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
-+void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
- void inline __green_LED_on(void) {}
--void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
-+void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
- void inline __green_LED_off(void) {}
--void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
-+void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
- void inline __yellow_LED_on(void) {}
--void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
-+void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
- void inline __yellow_LED_off(void) {}
--void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
-+void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
- void inline __blue_LED_on(void) {}
--void inline blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
-+void blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
- void inline __blue_LED_off(void) {}
--void inline blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
-+void blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
-
- /************************************************************************
- * Init Utilities *