summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-bug_svn.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2009-05-05 11:49:34 +0200
committerMarcin Juszkiewicz <marcin@buglabs.net>2009-05-05 11:49:34 +0200
commit481398457bcc88395b07c4c724c4def42be36fd2 (patch)
treeafdf28fa4ea04d19c4d71dbc895f1c0719429608 /recipes/u-boot/u-boot-bug_svn.bb
parent4e1f552aac60bec78eb92ee7dc0a49c51e3fa5ca (diff)
downloadopenembedded-481398457bcc88395b07c4c724c4def42be36fd2.tar.gz
u-boot-bug: Added U-Boot for BUG (from BUG Labs SVN)
Diffstat (limited to 'recipes/u-boot/u-boot-bug_svn.bb')
-rw-r--r--recipes/u-boot/u-boot-bug_svn.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-bug_svn.bb b/recipes/u-boot/u-boot-bug_svn.bb
new file mode 100644
index 0000000000..c1930f4889
--- /dev/null
+++ b/recipes/u-boot/u-boot-bug_svn.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "U-boot bootloader w/ BUG support"
+LICENSE = "GPL"
+SECTION = "bootloader"
+PRIORITY = "optional"
+PV = "1.3.2+svnr${SRCREV}"
+SRCREV = "${AUTOREV}"
+PR = "r6"
+
+SRC_URI = "\
+ svn://svn.buglabs.net/bug/branches/R1.4/qa;module=u-boot;proto=svn \
+"
+S = "${WORKDIR}/u-boot"
+
+COMPATIBLE_MACHINE = "bug"
+PACKAGE_ARCH = "${MACHINE}"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
+
+do_compile () {
+ oe_runmake mx31_bug2_config
+ oe_runmake clean
+ oe_runmake all
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-latest.bin
+}
+
+do_stage() {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_package after do_install