aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-mkimage_1.3.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-05-24 09:20:37 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-24 09:25:25 +0200
commit7432971c5b76c42d669c245edd4acb2f390f5859 (patch)
tree01c95b83954eda18042f53e31e185e18cac8a57f /recipes/u-boot/u-boot-mkimage_1.3.2.bb
parent4c508c916ac00266ae94fb32cac3b0fddb67093e (diff)
downloadopenembedded-7432971c5b76c42d669c245edd4acb2f390f5859.tar.gz
u-boot-mkimage: fix target build
Diffstat (limited to 'recipes/u-boot/u-boot-mkimage_1.3.2.bb')
-rw-r--r--recipes/u-boot/u-boot-mkimage_1.3.2.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/u-boot/u-boot-mkimage_1.3.2.bb b/recipes/u-boot/u-boot-mkimage_1.3.2.bb
index 53240b35a1..cf20fb52af 100644
--- a/recipes/u-boot/u-boot-mkimage_1.3.2.bb
+++ b/recipes/u-boot/u-boot-mkimage_1.3.2.bb
@@ -5,15 +5,18 @@ SECTION = "bootloader"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://fix-arm920t-eabi.patch;patch=1"
-PR = "r1"
+PR = "r3"
S = "${WORKDIR}/u-boot-${PV}"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
do_compile () {
oe_runmake smdk2410_config
- oe_runmake tools STRIP='/bin/true'
+ sed -i -e 's:img2srec$(SFX) mkimage$(SFX) envcrc$(SFX) ubsha1$(SFX) gen_eth_addr$(SFX) bmp_logo$(SFX):mkimage$(SFX):' tools/Makefile
+ oe_runmake HOSTCC="${CC}" LOGO_H="" tools STRIP='/bin/true'
}
do_install () {