aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-20 09:58:55 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-20 09:59:47 -0700
commit5b0d2716839c3d6a1c4b0a6eb5e4ebc313354828 (patch)
tree6e7a9a80a86928f25258ab3a3c9b2c24abdb1275 /recipes/u-boot
parente6eda83fd66a091b0337105178c2865c95af50b1 (diff)
downloadopenembedded-5b0d2716839c3d6a1c4b0a6eb5e4ebc313354828.tar.gz
u-boot: Move the config target into do_configure
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-utils-native_1.2.0.bb3
-rw-r--r--recipes/u-boot/u-boot-utils_1.2.0.bb3
-rw-r--r--recipes/u-boot/u-boot.inc5
3 files changed, 6 insertions, 5 deletions
diff --git a/recipes/u-boot/u-boot-utils-native_1.2.0.bb b/recipes/u-boot/u-boot-utils-native_1.2.0.bb
index adc7ce3e1f..771f31b46f 100644
--- a/recipes/u-boot/u-boot-utils-native_1.2.0.bb
+++ b/recipes/u-boot/u-boot-utils-native_1.2.0.bb
@@ -12,11 +12,10 @@ S = "${WORKDIR}/u-boot-${PV}"
inherit native
do_configure() {
- :
+ oe_runmake Sandpoint8240_config
}
do_compile () {
- oe_runmake Sandpoint8240_config
oe_runmake tools
}
diff --git a/recipes/u-boot/u-boot-utils_1.2.0.bb b/recipes/u-boot/u-boot-utils_1.2.0.bb
index 7cf77b8416..013de890b0 100644
--- a/recipes/u-boot/u-boot-utils_1.2.0.bb
+++ b/recipes/u-boot/u-boot-utils_1.2.0.bb
@@ -18,11 +18,10 @@ TARGET_LDFLAGS = ""
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-${PV}"
do_configure() {
- :
+ oe_runmake Sandpoint8240_config
}
do_compile () {
- oe_runmake Sandpoint8240_config
oe_runmake tools
}
diff --git a/recipes/u-boot/u-boot.inc b/recipes/u-boot/u-boot.inc
index 323eaef318..661bf3645d 100644
--- a/recipes/u-boot/u-boot.inc
+++ b/recipes/u-boot/u-boot.inc
@@ -17,11 +17,14 @@ UBOOT_BINARY ?= "u-boot.bin"
UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
+do_configure () {
+ oe_runmake ${UBOOT_MACHINE}
+}
+
do_compile () {
unset LDFLAGS
unset CFLAGS
unset CPPFLAGS
- oe_runmake ${UBOOT_MACHINE}
oe_runmake all
oe_runmake tools env
}