aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorAdrian Alonso <aalonso00@gmail.com>2010-08-03 06:23:18 +0000
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-04 19:47:03 +0200
commitb59c60e5fc171bc5577d11cd4159c7975e4d703f (patch)
tree762d25ee615b11d5d1c7263d84dd352fe3cd8ffe /recipes/u-boot
parent77de950be036d6e91b26e872f4848e3c339e2399 (diff)
downloadopenembedded-b59c60e5fc171bc5577d11cd4159c7975e4d703f.tar.gz
u-boot-xilinx: uboot for xilinx virtex4 virtex5 targets
* u-boot for xilinx platforms virtex4, virtex5 based * Inherits xilinx-bsp.bbclass for passing xparameters header file from hardware reference design project to match hardware/software model * v2 reorder patch set Signed-off-by: Adrian Alonso <aalonso00@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-xilinx_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-xilinx_git.bb b/recipes/u-boot/u-boot-xilinx_git.bb
new file mode 100644
index 0000000000..57677fb581
--- /dev/null
+++ b/recipes/u-boot/u-boot-xilinx_git.bb
@@ -0,0 +1,17 @@
+require u-boot.inc
+PR = "r0"
+
+# Prefered u-boot from mainstream since has generic support for
+# ppc405, ppc440 and microblaze
+# SRC_URI = "git://git.denx.de/u-boot.git;protocol=git"
+# SRCREV = "8bd9dbdfa3a19f322810e2ad9e6d6551602d8afe"
+SRC_URI = "git://git.xilinx.com/u-boot-xlnx.git;protocol=git"
+SRCREV = "26e999650cf77c16f33c580abaadab2532f5e8b2"
+
+inherit xilinx-bsp
+
+TARGET_BOARD = "${@map_target(bb.data.getVar('TARGET_ARCH', d, 1), d)}"
+UBOOT_TARGET = "${@uboot_target(bb.data.getVar('TARGET_ARCH', d, 1), d)}"
+export UBOOT_MACHINE = "${@uboot_machine(bb.data.getVar('TARGET_ARCH', d, 1), d)}"
+
+S = "${WORKDIR}/git"