aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-06-04 22:51:30 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-06-04 22:51:30 +0200
commit5b113a7dd9b00f8a511feb219ea165634343bb17 (patch)
treeb41d2d39371756d9b915e3db9ebfe61cdf09a4dc /recipes/u-boot
parent078c08db474fe569d806e5df79ccf74bfd706f50 (diff)
downloadopenembedded-5b113a7dd9b00f8a511feb219ea165634343bb17.tar.gz
u-boot: Add support for micro2440
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 48fc84e228..1cf4b2c426 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -58,6 +58,9 @@ SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git;tag=cf3b41e0c11
SRC_URI_mini2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
SRCREV_mini2440 = "3516c35fb777ca959e5cadf2156a792ca10e1cff"
+SRC_URI_micro2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
+SRCREV_micro2440 = "3516c35fb777ca959e5cadf2156a792ca10e1cff"
+
SRC_URI_neuros-osd2 += "file://Makefile-fix.patch;patch=1"
SRC_URI_append_akita = "file://pdaXrom-u-boot.patch;patch=1 \
file://uboot-eabi-fix-HACK2.patch;patch=1 \
@@ -90,3 +93,8 @@ do_configure_prepend_c7x0() {
do_deploy_prepend_mini2440() {
cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin
}
+
+do_deploy_prepend_micro2440() {
+ cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin
+}
+