summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-06-04 16:44:25 +0200
committerKoen Kooi <koen@openembedded.org>2010-06-04 16:48:51 +0200
commitc3d41d503c5439e6043bb0b17a4adb038a4a7b3a (patch)
tree5f4b1d5a31295bd779122e561f9f071ee8984388 /recipes/u-boot
parent1b3d1b48d2552ed94b88611cc3ef2e8636e9de17 (diff)
downloadopenembedded-c3d41d503c5439e6043bb0b17a4adb038a4a7b3a.tar.gz
u-boot git: update beagleboard patches
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0039-OMAP3-beagle-setenv-beaglerev-for-AxBx-Cx-xMA-for-be.patch42
-rw-r--r--recipes/u-boot/u-boot_git.bb3
2 files changed, 44 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0039-OMAP3-beagle-setenv-beaglerev-for-AxBx-Cx-xMA-for-be.patch b/recipes/u-boot/u-boot-git/beagleboard/0039-OMAP3-beagle-setenv-beaglerev-for-AxBx-Cx-xMA-for-be.patch
new file mode 100644
index 0000000000..9b64327d3a
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0039-OMAP3-beagle-setenv-beaglerev-for-AxBx-Cx-xMA-for-be.patch
@@ -0,0 +1,42 @@
+From c48581ecc0b060e4c1b5fa973d053e81e18f676b Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 3 Jun 2010 19:50:57 +0200
+Subject: [PATCH 39/39] OMAP3: beagle: setenv beaglerev for AxBx/Cx/xMA for better bootscripts
+
+---
+ board/ti/beagle/beagle.c | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
+index 556e995..cdba3dd 100644
+--- a/board/ti/beagle/beagle.c
++++ b/board/ti/beagle/beagle.c
+@@ -221,14 +221,17 @@ int misc_init_r(void)
+ case REVISION_AXBX:
+ printf("Beagle Rev Ax/Bx\n");
+ setenv("mpurate", "600");
++ setenv("beaglerev", "AxBx");
+ break;
+ case REVISION_CX:
+ printf("Beagle Rev C1/C2/C3\n");
+ MUX_BEAGLE_C();
+ setenv("mpurate", "600");
++ setenv("beaglerev", "Cx");
+ break;
+ case REVISION_C4:
+ printf("Beagle Rev C4\n");
++ setenv("beaglerev", "Cx");
+ MUX_BEAGLE_C();
+ /* Set VAUX2 to 1.8V for EHCI PHY */
+ twl4030_pmrecv_vsel_cfg(TWL4030_PM_RECEIVER_VAUX2_DEDICATED,
+@@ -239,6 +242,7 @@ int misc_init_r(void)
+ break;
+ case REVISION_XM:
+ printf("Beagle xM Rev A\n");
++ setenv("beaglerev", "xMA");
+ MUX_BEAGLE_XM();
+ /* Set VAUX2 to 1.8V for EHCI PHY */
+ twl4030_pmrecv_vsel_cfg(TWL4030_PM_RECEIVER_VAUX2_DEDICATED,
+--
+1.6.6.1
+
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index cc0c5327ef..be39354b05 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r51"
+PR ="r52"
FILESPATHPKG =. "u-boot-git:"
@@ -59,6 +59,7 @@ SRC_URI_beagleboard = "git://www.denx.de/git/u-boot.git;protocol=git \
file://0036-OMAP3-Beagle-decrease-bootdelay-to-3-use-VGA-for-def.patch \
file://0037-OMAP3-beagle-pass-expansionboard-name-in-bootargs.patch \
file://0038-Added-configurations-for-xM-Rev-A-board.patch \
+ file://0039-OMAP3-beagle-setenv-beaglerev-for-AxBx-Cx-xMA-for-be.patch \
file://fw_env.config \
"
SRCREV_beagleboard = "ca6e1c136ddb720c3bb2cc043b99f7f06bc46c55"