summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-20 10:10:14 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-20 10:10:14 -0700
commitd420df7cf6a4bf18b434ebd6783bb97eb5753deb (patch)
treea166dacb00e40a883c41a8f1c91e89749cbf5bd9 /recipes/u-boot
parent5b0d2716839c3d6a1c4b0a6eb5e4ebc313354828 (diff)
downloadopenembedded-d420df7cf6a4bf18b434ebd6783bb97eb5753deb.tar.gz
u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-bug_svn.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes/u-boot/u-boot-bug_svn.bb b/recipes/u-boot/u-boot-bug_svn.bb
index dffeea1fc5..f104023be5 100644
--- a/recipes/u-boot/u-boot-bug_svn.bb
+++ b/recipes/u-boot/u-boot-bug_svn.bb
@@ -4,7 +4,7 @@ SECTION = "bootloader"
PRIORITY = "optional"
PV = "1.3.2+svnr${SRCPV}"
SRCREV = "8674"
-PR = "r6"
+PR = "r7"
SRC_URI = "\
svn://svn.buglabs.net/bug/branches/R1.4/qa;module=u-boot;proto=svn \
@@ -26,11 +26,9 @@ do_compile () {
do_deploy () {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0644 ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin
ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-latest.bin
-}
-
-do_stage() {
- install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/uboot-latest.bin
}
do_deploy[dirs] = "${S}"