aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uclibc/uclibc_0.9.30.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-20 12:28:27 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-20 12:28:27 -0700
commit8d0b0994a86b2800363b7d1ab4384bd87fb94f6a (patch)
treeea45aabd41a00c38565bb10340f2fc60bc4414be /recipes/uclibc/uclibc_0.9.30.bb
parenta7b83866a10c1487125720d7583b9f6935ea9e61 (diff)
downloadopenembedded-8d0b0994a86b2800363b7d1ab4384bd87fb94f6a.tar.gz
uclibc: Get uclibc working in thumb mode.
* WARNING!! Do not use bintils 2.19 or 2.19.1 when compiling in thumb mode. The veneer generation does not work as expected. Use binutils 2.18 or binutils_cvs * Move LEAD_SONAME into uclibc.inc * Use no optimizations while compiling ldso.c to over come a gcc ICE * Use ARM mode resolver for thumb mode. The resolver depends on ip register and if we use thumb function for _dl_linux_resolve then it adds a veneer which corrupts ip.
Diffstat (limited to 'recipes/uclibc/uclibc_0.9.30.bb')
-rw-r--r--recipes/uclibc/uclibc_0.9.30.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes/uclibc/uclibc_0.9.30.bb b/recipes/uclibc/uclibc_0.9.30.bb
index b3e3c15c0f..bbe809f0c5 100644
--- a/recipes/uclibc/uclibc_0.9.30.bb
+++ b/recipes/uclibc/uclibc_0.9.30.bb
@@ -7,7 +7,7 @@
# on whether the base patches apply to the selected (SRCDATE) svn release.
#
UCLIBC_BASE ?= "0.9.30"
-PR = "r5"
+PR = "r6"
DEFAULT_PREFERENCE = "1"
require uclibc.inc
@@ -18,6 +18,8 @@ SRC_URI += "file://uClibc.machine file://uClibc.distro \
file://arm-linuxthreads.patch;patch=1 \
file://linuxthreads-changes.patch;patch=1 \
file://pthread_atfork.patch;patch=1 \
+ file://uclibc_ldso_use_O0.patch;patch=1 \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;patch=1 \
"
#recent versions uclibc require real kernel headers
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -29,5 +31,3 @@ KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"
-
-LEAD_SONAME = "libc.so"