aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uml-utilities
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/uml-utilities
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/uml-utilities')
-rw-r--r--recipes/uml-utilities/uml-utilities-20040406/fix-ldflags.patch16
-rw-r--r--recipes/uml-utilities/uml-utilities_20040406.bb16
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes/uml-utilities/uml-utilities-20040406/fix-ldflags.patch b/recipes/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
new file mode 100644
index 0000000000..05cc5371f7
--- /dev/null
+++ b/recipes/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tools/mconsole/Makefile~fix-ldflags 2003-02-08 05:10:08.000000000 +0100
++++ tools/mconsole/Makefile 2004-04-01 15:37:37.000000000 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS) -lreadline -lncurses
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS) -lreadline -lncurses
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
diff --git a/recipes/uml-utilities/uml-utilities_20040406.bb b/recipes/uml-utilities/uml-utilities_20040406.bb
new file mode 100644
index 0000000000..eeb5899589
--- /dev/null
+++ b/recipes/uml-utilities/uml-utilities_20040406.bb
@@ -0,0 +1,16 @@
+SECTION = "console/utils"
+DESCRIPTION = "Utilities for User-Mode-Linux"
+LICENSE = "GPL"
+DEPENDS = "zlib ncurses readline"
+
+SRC_URI = "http://mirror.usermodelinux.org/uml/uml_utilities_${PV}.tar.bz2 \
+ file://fix-ldflags.patch;patch=1"
+S = "${WORKDIR}/tools"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}