aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/update-alternatives
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/update-alternatives
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/update-alternatives')
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth-native_0.99.154.bb11
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth.inc7
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb11
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch26
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg-1.13.25/paths.patch26
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb14
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg-native_1.13.25.bb14
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg.inc14
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg_1.13.22.bb12
-rw-r--r--recipes/update-alternatives/update-alternatives-dpkg_1.13.25.bb12
10 files changed, 147 insertions, 0 deletions
diff --git a/recipes/update-alternatives/update-alternatives-cworth-native_0.99.154.bb b/recipes/update-alternatives/update-alternatives-cworth-native_0.99.154.bb
new file mode 100644
index 0000000000..40534b4bb4
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-cworth-native_0.99.154.bb
@@ -0,0 +1,11 @@
+require update-alternatives-cworth.inc
+inherit native
+
+PROVIDES += "virtual/update-alternatives-native"
+
+do_stage () {
+ install -d ${sbindir} \
+ ${libdir}/opkg/alternatives
+
+ install -m 0755 update-alternatives ${sbindir}/update-alternatives
+}
diff --git a/recipes/update-alternatives/update-alternatives-cworth.inc b/recipes/update-alternatives/update-alternatives-cworth.inc
new file mode 100644
index 0000000000..f23bfe8bb4
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-cworth.inc
@@ -0,0 +1,7 @@
+LICENSE = "GPL"
+SECTION = "base"
+SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+S = "${WORKDIR}/ipkg/C"
+PACKAGE_ARCH = "all"
+
+PR = "r1"
diff --git a/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb b/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb
new file mode 100644
index 0000000000..6cab1e55ec
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb
@@ -0,0 +1,11 @@
+require update-alternatives-cworth.inc
+
+RPROVIDES_${PN} = "update-alternatives"
+
+do_install () {
+ install -d ${D}${sbindir} \
+ ${D}${sysconfdir}/alternatives \
+ ${D}${libdir}/opkg/alternatives
+
+ install -m 0755 update-alternatives ${D}${sbindir}/update-alternatives
+}
diff --git a/recipes/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch b/recipes/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch
new file mode 100644
index 0000000000..a23bf9a99d
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch
@@ -0,0 +1,26 @@
+diff -ruN dpkg-1.13.22.orig/scripts/update-alternatives.pl dpkg-1.13.22/scripts/update-alternatives.pl
+--- dpkg-1.13.22.orig/scripts/update-alternatives.pl 2006-06-21 01:46:12.000000000 -0300
++++ dpkg-1.13.22/scripts/update-alternatives.pl 2007-08-02 19:36:47.000000000 -0300
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl --
+
+ $admindir= "/var/lib/dpkg"; # This line modified by Makefile
+-$dpkglibdir= "../utils"; # This line modified by Makefile
++$dpkglibdir= "/usr/lib/dpkg"; # This line modified by Makefile
+ $version= '0.93.80'; # This line modified by Makefile
+ push (@INC, $dpkglibdir);
+ require 'dpkg-gettext.pl';
+@@ -129,6 +129,12 @@
+ &checkmanymodes;
+ @ARGV >= 4 || &badusage(_g("--install needs <link> <name> <path> <priority>"));
+ ($alink,$name,$apath,$apriority,@ARGV) = @ARGV;
++ if (! -e $apath) {
++ $apath = substr($alink,0,rindex($alink,"/")+1).$apath;
++ }
++ if (! -e $apath) {
++ &quit(sprintf(_g("Error: file not found: %s"), $apath));
++ }
+ $apriority =~ m/^[-+]?\d+/ || &badusage(_g("priority must be an integer"));
+ $mode= 'install';
+ } elsif (m/^--(remove|set)$/) {
+
diff --git a/recipes/update-alternatives/update-alternatives-dpkg-1.13.25/paths.patch b/recipes/update-alternatives/update-alternatives-dpkg-1.13.25/paths.patch
new file mode 100644
index 0000000000..a23bf9a99d
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg-1.13.25/paths.patch
@@ -0,0 +1,26 @@
+diff -ruN dpkg-1.13.22.orig/scripts/update-alternatives.pl dpkg-1.13.22/scripts/update-alternatives.pl
+--- dpkg-1.13.22.orig/scripts/update-alternatives.pl 2006-06-21 01:46:12.000000000 -0300
++++ dpkg-1.13.22/scripts/update-alternatives.pl 2007-08-02 19:36:47.000000000 -0300
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl --
+
+ $admindir= "/var/lib/dpkg"; # This line modified by Makefile
+-$dpkglibdir= "../utils"; # This line modified by Makefile
++$dpkglibdir= "/usr/lib/dpkg"; # This line modified by Makefile
+ $version= '0.93.80'; # This line modified by Makefile
+ push (@INC, $dpkglibdir);
+ require 'dpkg-gettext.pl';
+@@ -129,6 +129,12 @@
+ &checkmanymodes;
+ @ARGV >= 4 || &badusage(_g("--install needs <link> <name> <path> <priority>"));
+ ($alink,$name,$apath,$apriority,@ARGV) = @ARGV;
++ if (! -e $apath) {
++ $apath = substr($alink,0,rindex($alink,"/")+1).$apath;
++ }
++ if (! -e $apath) {
++ &quit(sprintf(_g("Error: file not found: %s"), $apath));
++ }
+ $apriority =~ m/^[-+]?\d+/ || &badusage(_g("priority must be an integer"));
+ $mode= 'install';
+ } elsif (m/^--(remove|set)$/) {
+
diff --git a/recipes/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb b/recipes/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb
new file mode 100644
index 0000000000..d0af4eac7b
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb
@@ -0,0 +1,14 @@
+require update-alternatives-dpkg.inc
+inherit native
+
+PROVIDES += "virtual/update-alternatives-native"
+DEPENDS = "perl-native"
+DEFAULT_PREFERENCE = "-1"
+
+do_stage () {
+ install -d ${sbindir} \
+ ${localstatedir}/dpkg/alternatives \
+ ${sysconfdir}/alternatives
+
+ install -m 0755 scripts/update-alternatives ${sbindir}/update-alternatives
+}
diff --git a/recipes/update-alternatives/update-alternatives-dpkg-native_1.13.25.bb b/recipes/update-alternatives/update-alternatives-dpkg-native_1.13.25.bb
new file mode 100644
index 0000000000..d0af4eac7b
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg-native_1.13.25.bb
@@ -0,0 +1,14 @@
+require update-alternatives-dpkg.inc
+inherit native
+
+PROVIDES += "virtual/update-alternatives-native"
+DEPENDS = "perl-native"
+DEFAULT_PREFERENCE = "-1"
+
+do_stage () {
+ install -d ${sbindir} \
+ ${localstatedir}/dpkg/alternatives \
+ ${sysconfdir}/alternatives
+
+ install -m 0755 scripts/update-alternatives ${sbindir}/update-alternatives
+}
diff --git a/recipes/update-alternatives/update-alternatives-dpkg.inc b/recipes/update-alternatives/update-alternatives-dpkg.inc
new file mode 100644
index 0000000000..e3cdb53257
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg.inc
@@ -0,0 +1,14 @@
+LICENSE = "GPL"
+SECTION = "base"
+SRC_URI += "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz"
+S = "${WORKDIR}/dpkg-${PV}"
+PACKAGE_ARCH = "all"
+
+SRC_URI += "file://paths.patch;patch=1"
+
+do_patch_append () {
+ import shutil
+ update_alternatives_src = bb.data.getVar('S', d, 1)
+ shutil.move("%s/scripts/update-alternatives.pl" % (update_alternatives_src,),
+ "%s/scripts/update-alternatives" % (update_alternatives_src,))
+}
diff --git a/recipes/update-alternatives/update-alternatives-dpkg_1.13.22.bb b/recipes/update-alternatives/update-alternatives-dpkg_1.13.22.bb
new file mode 100644
index 0000000000..a07d5e36d4
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg_1.13.22.bb
@@ -0,0 +1,12 @@
+require update-alternatives-dpkg.inc
+
+RPROVIDES_${PN} = "update-alternatives"
+RDEPENDS_${PN} = "perl dpkg"
+
+do_install () {
+ install -d ${D}${sbindir} \
+ ${D}${localstatedir}/dpkg/alternatives \
+ ${D}${sysconfdir}/alternatives
+
+ install -m 0755 scripts/update-alternatives ${D}${sbindir}/update-alternatives
+}
diff --git a/recipes/update-alternatives/update-alternatives-dpkg_1.13.25.bb b/recipes/update-alternatives/update-alternatives-dpkg_1.13.25.bb
new file mode 100644
index 0000000000..a07d5e36d4
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-dpkg_1.13.25.bb
@@ -0,0 +1,12 @@
+require update-alternatives-dpkg.inc
+
+RPROVIDES_${PN} = "update-alternatives"
+RDEPENDS_${PN} = "perl dpkg"
+
+do_install () {
+ install -d ${D}${sbindir} \
+ ${D}${localstatedir}/dpkg/alternatives \
+ ${D}${sysconfdir}/alternatives
+
+ install -m 0755 scripts/update-alternatives ${D}${sbindir}/update-alternatives
+}