aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/update-alternatives
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-08 16:14:46 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-13 12:36:03 +0100
commitd6eb5340067ae02d3289ce6311d80a9752dbb8bc (patch)
tree72ef1ede624b1ecd1be4cc5e6df3108513308947 /recipes/update-alternatives
parent2153070fc51bbb6006c022e8836a46e2a511306f (diff)
downloadopenembedded-d6eb5340067ae02d3289ce6311d80a9752dbb8bc.tar.gz
opkg, update-alternatives-cworth: use /usr/lib/opkg/alternatives directory instead of /usr/lib/ipkg/alternatives
* It's usefull to make it compatible with u-a script in opkg package * Old entries are merged to new directory in quite verbose postinst script * If entry exists only in old it's moved * If entry exists in both the one with more lines is used * The one with less lines is not used and warning is shown * If they have the same number of lines diff is checked * If they are the same, old one is ignored * If they are different, old one is ignored and warning is shown Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/update-alternatives')
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth.inc5
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth/use-opkg-dir-instead-of-ipkg.patch11
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb2
3 files changed, 16 insertions, 2 deletions
diff --git a/recipes/update-alternatives/update-alternatives-cworth.inc b/recipes/update-alternatives/update-alternatives-cworth.inc
index 2d8fd42c0c..2d8ebb49b0 100644
--- a/recipes/update-alternatives/update-alternatives-cworth.inc
+++ b/recipes/update-alternatives/update-alternatives-cworth.inc
@@ -1,8 +1,9 @@
LICENSE = "GPL"
SECTION = "base"
SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \
- file://update-alternatives.use.last.patch;patch=1"
+ file://update-alternatives.use.last.patch;patch=1 \
+ file://use-opkg-dir-instead-of-ipkg.patch;patch=1 "
S = "${WORKDIR}/ipkg/C"
PACKAGE_ARCH = "all"
-INC_PR = "r3"
+INC_PR = "r4"
diff --git a/recipes/update-alternatives/update-alternatives-cworth/use-opkg-dir-instead-of-ipkg.patch b/recipes/update-alternatives/update-alternatives-cworth/use-opkg-dir-instead-of-ipkg.patch
new file mode 100644
index 0000000000..4355556200
--- /dev/null
+++ b/recipes/update-alternatives/update-alternatives-cworth/use-opkg-dir-instead-of-ipkg.patch
@@ -0,0 +1,11 @@
+--- C.orig/update-alternatives 2010-01-08 15:40:20.000000000 +0100
++++ C/update-alternatives 2010-01-08 15:40:47.000000000 +0100
+@@ -21,7 +21,7 @@
+ set -e
+
+ # admin dir
+-ad="$IPKG_OFFLINE_ROOT/usr/lib/ipkg/alternatives"
++ad="$IPKG_OFFLINE_ROOT/usr/lib/opkg/alternatives"
+
+ usage() {
+ echo "update-alternatives: $*
diff --git a/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb b/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb
index b95d6d5ff2..111d8c6592 100644
--- a/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb
+++ b/recipes/update-alternatives/update-alternatives-cworth_0.99.154.bb
@@ -11,3 +11,5 @@ do_install () {
install -m 0755 update-alternatives ${D}${sbindir}/update-alternatives
}
+
+require ../opkg/update-alternatives-merge.inc