aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/upnp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/upnp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/upnp')
-rw-r--r--recipes/upnp/gssdp_0.6.3.bb14
-rw-r--r--recipes/upnp/gupnp-av_0.2.bb14
-rw-r--r--recipes/upnp/gupnp-tools_0.7.bb6
-rw-r--r--recipes/upnp/gupnp-vala_0.4.bb22
-rw-r--r--recipes/upnp/gupnp_0.12.4.bb14
-rw-r--r--recipes/upnp/libupnp_1.3.1.bb15
-rw-r--r--recipes/upnp/libupnp_1.6.5.bb16
7 files changed, 101 insertions, 0 deletions
diff --git a/recipes/upnp/gssdp_0.6.3.bb b/recipes/upnp/gssdp_0.6.3.bb
new file mode 100644
index 0000000000..034d2f5fe3
--- /dev/null
+++ b/recipes/upnp/gssdp_0.6.3.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+DEPENDS = "glib-2.0 libsoup-2.4 libglade"
+
+SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ "gssdp-tools"
+
+FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/upnp/gupnp-av_0.2.bb b/recipes/upnp/gupnp-av_0.2.bb
new file mode 100644
index 0000000000..0dcf5e5808
--- /dev/null
+++ b/recipes/upnp/gupnp-av_0.2.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+DEPENDS = "gnupnp gstreamer"
+
+SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
+
+inherit autotools
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+
+FILES_${PN} = "${libdir}/*.so.*"
diff --git a/recipes/upnp/gupnp-tools_0.7.bb b/recipes/upnp/gupnp-tools_0.7.bb
new file mode 100644
index 0000000000..be4f3510b6
--- /dev/null
+++ b/recipes/upnp/gupnp-tools_0.7.bb
@@ -0,0 +1,6 @@
+LICENSE = "GPL"
+DEPENDS = "gupnp gtk+ libglade gnome-icon-theme"
+
+SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/upnp/gupnp-vala_0.4.bb b/recipes/upnp/gupnp-vala_0.4.bb
new file mode 100644
index 0000000000..d5544cb8b3
--- /dev/null
+++ b/recipes/upnp/gupnp-vala_0.4.bb
@@ -0,0 +1,22 @@
+LICENSE = "LGPL"
+DEPENDS = "gupnp vala-native"
+
+PR = "r1"
+
+SRC_URI = "http://gupnp.org/sources/bindings/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ mv ${D}${STAGING_DIR_NATIVE}/* ${D}
+}
+
+FILES_${PN}-dev += "${datadir}/vala"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/vala/vapi
+ install -m 0644 ${S}/*.deps ${S}/*.vapi ${STAGING_DATADIR}/vala/vapi
+}
+
+
diff --git a/recipes/upnp/gupnp_0.12.4.bb b/recipes/upnp/gupnp_0.12.4.bb
new file mode 100644
index 0000000000..e1a0206d90
--- /dev/null
+++ b/recipes/upnp/gupnp_0.12.4.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2"
+
+SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
diff --git a/recipes/upnp/libupnp_1.3.1.bb b/recipes/upnp/libupnp_1.3.1.bb
new file mode 100644
index 0000000000..14d1b9d263
--- /dev/null
+++ b/recipes/upnp/libupnp_1.3.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "The Linux* SDK for UPnP* Devices (libupnp) provides developers with an API and open source code for building control points, devices, and bridges that are compliant with Version 1.0 of the Universal Plug and Play Device Architecture Specification."
+HOMEPAGE = "http://upnp.sourceforge.net/"
+LICENSE = "BSD"
+
+LEAD_SONAME = "libupnp"
+SRC_URI = "${SOURCEFORGE_MIRROR}/upnp/${P}.tar.gz"
+inherit autotools pkgconfig
+
+
+
+do_stage() {
+autotools_stage_all
+}
+
+
diff --git a/recipes/upnp/libupnp_1.6.5.bb b/recipes/upnp/libupnp_1.6.5.bb
new file mode 100644
index 0000000000..245575ed28
--- /dev/null
+++ b/recipes/upnp/libupnp_1.6.5.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The portable SDK for UPnP* Devices (libupnp) provides developers with an API and open source code for building control points, devices, and bridges that are compliant with Version 1.0 of the Universal Plug and Play Device Architecture Specification."
+HOMEPAGE = "http://pupnp.sourceforge.net/"
+LICENSE = "BSD"
+
+PR = "r1"
+
+LEAD_SONAME = "libupnp"
+SRC_URI = "${SOURCEFORGE_MIRROR}/pupnp/${P}.tar.bz2"
+
+inherit autotools
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}