aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/upnp
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-18 20:44:58 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-18 20:48:40 +0100
commit331054c3af13da07330d1ea7f33042f6a9a25469 (patch)
treea9ece17fcf819a2fbb5400bec74856b677573eb5 /recipes/upnp
parentc82529d1b965189ac4d60d0302dd1644f7bc2c8e (diff)
downloadopenembedded-331054c3af13da07330d1ea7f33042f6a9a25469.tar.gz
gupnp: added 0.13.1
Diffstat (limited to 'recipes/upnp')
-rw-r--r--recipes/upnp/gupnp-0.13.1/nodoc.patch37
-rw-r--r--recipes/upnp/gupnp_0.13.1.bb16
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes/upnp/gupnp-0.13.1/nodoc.patch b/recipes/upnp/gupnp-0.13.1/nodoc.patch
new file mode 100644
index 0000000000..0d080e38d7
--- /dev/null
+++ b/recipes/upnp/gupnp-0.13.1/nodoc.patch
@@ -0,0 +1,37 @@
+---
+ Makefile.am | 2 +-
+ configure.ac | 5 -----
+ 2 files changed, 1 insertion(+), 6 deletions(-)
+
+--- gupnp-0.13.1.orig/Makefile.am
++++ gupnp-0.13.1/Makefile.am
+@@ -1,6 +1,6 @@
+-SUBDIRS = libgupnp tools examples tests doc
++SUBDIRS = libgupnp tools
+
+ pkgconfig_DATA= gupnp-1.0.pc
+ pkgconfigdir = $(libdir)/pkgconfig
+
+ EXTRA_DIST = gupnp-1.0.pc.in gupnp-1.0-uninstalled.pc.in
+--- gupnp-0.13.1.orig/configure.ac
++++ gupnp-0.13.1/configure.ac
+@@ -47,19 +47,14 @@ AC_ARG_ENABLE(debug,
+ enable_debug=no)
+ if test "x$enable_debug" = "xyes"; then
+ CFLAGS="$CFLAGS -g -Wall -Werror"
+ fi
+
+-# Gtk-doc
+-GTK_DOC_CHECK([1.0])
+-
+ AC_OUTPUT([
+ Makefile
+ libgupnp/Makefile
+ examples/Makefile
+ tools/Makefile
+ tests/Makefile
+-doc/Makefile
+-doc/version.xml
+ gupnp-1.0.pc
+ gupnp-1.0-uninstalled.pc
+ ])
diff --git a/recipes/upnp/gupnp_0.13.1.bb b/recipes/upnp/gupnp_0.13.1.bb
new file mode 100644
index 0000000000..6de14b9b16
--- /dev/null
+++ b/recipes/upnp/gupnp_0.13.1.bb
@@ -0,0 +1,16 @@
+LICENSE = "LGPL"
+DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2 gtk-doc-native libgee"
+
+SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz \
+ file://nodoc.patch;patch=1"
+
+inherit autotools_stage pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
+
+do_stage_append () {
+ install ${S}/tools/gupnp-binding-tool ${STAGING_BINDIR_NATIVE}
+}