aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/upstart
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/upstart
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/upstart')
-rw-r--r--recipes/upstart/files/autoconf_version.patch12
-rw-r--r--recipes/upstart/upstart.inc26
-rw-r--r--recipes/upstart/upstart_0.3.8.bb7
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes/upstart/files/autoconf_version.patch b/recipes/upstart/files/autoconf_version.patch
new file mode 100644
index 0000000000..73b19879fb
--- /dev/null
+++ b/recipes/upstart/files/autoconf_version.patch
@@ -0,0 +1,12 @@
+Index: upstart-0.3.8/configure.ac
+===================================================================
+--- upstart-0.3.8.orig/configure.ac 2007-05-09 22:02:14.000000000 +0200
++++ upstart-0.3.8/configure.ac 2007-05-09 22:02:24.000000000 +0200
+@@ -1,6 +1,6 @@
+ # Process this file with autoconf to produce a configure script.
+
+-AC_PREREQ(2.60)
++AC_PREREQ(2.59)
+ AC_INIT([upstart], [0.3.8], [upstart-devel@lists.ubuntu.com])
+ AC_COPYRIGHT([[Copyright © 2007 Canonical Ltd.]])
+ AC_CONFIG_SRCDIR([init/main.c])
diff --git a/recipes/upstart/upstart.inc b/recipes/upstart/upstart.inc
new file mode 100644
index 0000000000..59f21c9ed5
--- /dev/null
+++ b/recipes/upstart/upstart.inc
@@ -0,0 +1,26 @@
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = ""
+DESCRIPTION = "Event driven system init"
+LICENSE = "GPL"
+
+inherit autotools pkgconfig
+
+# --enable-compat builds halt, reboot, shutdown tools
+EXTRA_OECONF += "--enable-compat"
+
+do_stage () {
+ autotools_stage_all
+}
+
+# libupstart can be used for upstart event generation from other programs.
+# However it is not used by upstart itself, so package it seperately.
+PACKAGES =+ "libupstart libupstart-dev"
+FILES_libupstart += "${libdir}/libupstart.so.*"
+FILES_libupstart-dev += "${libdir}/libupstart.* ${includedir}/upstart/"
+
+# upstart-sysvcompat provides Sys V Init compatible tools: halt, reboot,
+# shutdown, telinit. These might be needed by other scripts.
+PACKAGES =+ "upstart-sysvcompat upstart-sysvtools-doc"
+FILES_upstart-sysvcompat += "${sbindir}/reboot ${sbindir}/halt ${sbindir}/shutdown ${sbindir}/telinit"
+FILES_upstart-sysvcompat-doc += "${mandir}/*/reboot.* ${mandir}/*/halt.* ${mandir}/*/shutdown.* ${mandir}/*/telinit.*"
diff --git a/recipes/upstart/upstart_0.3.8.bb b/recipes/upstart/upstart_0.3.8.bb
new file mode 100644
index 0000000000..5a4cf872a8
--- /dev/null
+++ b/recipes/upstart/upstart_0.3.8.bb
@@ -0,0 +1,7 @@
+require upstart.inc
+
+SRC_URI = "http://upstart.ubuntu.com/download/0.3/upstart-${PV}.tar.bz2 \
+file://autoconf_version.patch;patch=1"
+
+PR = "r1"
+