aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/usbutils
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-01-21 15:47:47 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-28 14:58:18 +0100
commit2628ab23175444877220a6f3b3673aa3c4fccb11 (patch)
treed79df5c89a451418384a6d6e54fe6c316babd64e /recipes/usbutils
parentb9fb49af6c3f3f9b1a202a2a0f17aafac93628cf (diff)
downloadopenembedded-2628ab23175444877220a6f3b3673aa3c4fccb11.tar.gz
usbmodeswitch: add 1.0.7
Diffstat (limited to 'recipes/usbutils')
-rw-r--r--recipes/usbutils/usbmodeswitch_1.0.7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/usbutils/usbmodeswitch_1.0.7.bb b/recipes/usbutils/usbmodeswitch_1.0.7.bb
new file mode 100644
index 0000000000..bbae1a05b0
--- /dev/null
+++ b/recipes/usbutils/usbmodeswitch_1.0.7.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "tool to switch multidevice usb modes"
+LICENSE = "GPL"
+
+DEPENDS = "virtual/libusb"
+
+SRC_URI = "http://www.draisberghof.de/usb_modeswitch/usb_modeswitch-${PV}.tar.bz2"
+
+S = "${WORKDIR}/usb_modeswitch-${PV}"
+
+do_compile() {
+ oe_runmake clean
+ oe_runmake -e
+}
+
+do_install() {
+ install -d ${D}$bindir}
+ install -m 0755 ${S}/usb_modeswitch ${D}${bindir}
+}
+