aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/v86d/v86d_0.1.9.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-07-01 15:51:26 -0700
committerKhem Raj <raj.khem@gmail.com>2010-07-01 15:52:23 -0700
commit9151533a2783cd9a235fb9684166ca8ca80c56b1 (patch)
tree6ed366aca61e7be4268ab51d5b3d14aa4b1180f7 /recipes/v86d/v86d_0.1.9.bb
parentd3c1b02dd6e4d5a128477ea594eb2d0c03d66b08 (diff)
downloadopenembedded-9151533a2783cd9a235fb9684166ca8ca80c56b1.tar.gz
v86d: Add recipe for 0.1.9
* Drop 0.1.8 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/v86d/v86d_0.1.9.bb')
-rw-r--r--recipes/v86d/v86d_0.1.9.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/v86d/v86d_0.1.9.bb b/recipes/v86d/v86d_0.1.9.bb
new file mode 100644
index 0000000000..cf5cbab5db
--- /dev/null
+++ b/recipes/v86d/v86d_0.1.9.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "User support binary for the uvesafb kernel module"
+SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-${PV}.tar.bz2 \
+ file://fbsetup"
+DEPENDS = "virtual/kernel klibc"
+LICENSE = "GPLv2"
+PR = "r0"
+
+RRECOMMENDS_${PN} = "kernel-module-uvesafb"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_HOST = 'i.86.*-linux'
+
+INITSCRIPT_NAME = "fbsetup"
+INITSCRIPT_PARAMS = "start 0 S ."
+
+export CC=${TARGET_PREFIX}klcc
+
+# klcc doesn't work with -isystem
+export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
+
+do_configure () {
+ ./configure --default
+}
+
+do_compile () {
+ KDIR="${STAGING_KERNEL_DIR}" make
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install v86d ${D}${base_sbindir}/
+
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
+}
+
+inherit update-rc.d
+SRC_URI[md5sum] = "ebbbc8e7013c9544b6ba6981add43831"
+SRC_URI[sha256sum] = "8167dec4ff919cfd73f854bbd3244f05c2b867e014fa8298044ea7cfd66d18a8"
+