aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/v86d
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/v86d
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/v86d')
-rwxr-xr-xrecipes/v86d/v86d/fbsetup3
-rw-r--r--recipes/v86d/v86d_0.1.8.bb37
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/v86d/v86d/fbsetup b/recipes/v86d/v86d/fbsetup
new file mode 100755
index 0000000000..2a409cc529
--- /dev/null
+++ b/recipes/v86d/v86d/fbsetup
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/sbin/modprobe uvesafb
diff --git a/recipes/v86d/v86d_0.1.8.bb b/recipes/v86d/v86d_0.1.8.bb
new file mode 100644
index 0000000000..2601c64abe
--- /dev/null
+++ b/recipes/v86d/v86d_0.1.8.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "User support binary for the uvesafb kernel module"
+SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-${PV}.tar.bz2 \
+ file://fbsetup"
+DEPENDS = "virtual/kernel klibc"
+LICENSE = "GPLv2"
+PR = "r0"
+
+RRECOMMENDS_${PN} = "kernel-module-uvesafb"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_HOST = 'i.86.*-linux'
+
+INITSCRIPT_NAME = "fbsetup"
+INITSCRIPT_PARAMS = "start 0 S ."
+
+export CC=${TARGET_PREFIX}klcc
+
+# klcc doesn't work with -isystem
+export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
+
+do_configure () {
+ ./configure --default
+}
+
+do_compile () {
+ KDIR="${STAGING_KERNEL_DIR}" make
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install v86d ${D}${base_sbindir}/
+
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
+}
+
+inherit update-rc.d