aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vdr/vdr_1.7.10.bb
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-01-24 08:02:55 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-25 17:09:10 +0800
commitccffb0d58e3b36b3be440b9ceadb05ebabe0d847 (patch)
tree2e44f945d93799667df9ec32d893cc5e988c740b /recipes/vdr/vdr_1.7.10.bb
parent325b6a4b8a8c92fd5c50dfc0f965edca9eb1a4a2 (diff)
downloadopenembedded-ccffb0d58e3b36b3be440b9ceadb05ebabe0d847.tar.gz
vdr: Put common information in separate file and require it in the recipe.
• Some information in a recipe apply to all versions of a program. Factor them out into an extra file and include/require this in each recipe as seen in a lot of other programs/packages/recipes in OE. • VDR’s plugins often change and therefore put patches to them in version dependent folder. This hopefully lessens the effort to add new versions. Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Holger Hans Peter Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/vdr/vdr_1.7.10.bb')
-rw-r--r--recipes/vdr/vdr_1.7.10.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/recipes/vdr/vdr_1.7.10.bb b/recipes/vdr/vdr_1.7.10.bb
index a8fa82c13b..69ca012c7b 100644
--- a/recipes/vdr/vdr_1.7.10.bb
+++ b/recipes/vdr/vdr_1.7.10.bb
@@ -1,13 +1,7 @@
-DESCRIPTION = "Video Disk Recorder (VDR) is a digital sat-receiver program using Linux and DVB technologies. It allows one to record MPEG2 streams, as well as output the stream to TV. It is also possible to watch DVDs (hardware accelerated) with some comfort and use an IR remote control."
-AUTHOR = "Klaus Schmidinger"
-LICENSE = "GPLv2"
-HOMEPAGE = "http://www.tvdr.de"
+require vdr.inc
PR = "r2"
-DEPENDS = "fontconfig freetype gettext libcap jpeg virtual/libintl"
-
-SRC_URI = "ftp://ftp.tvdr.de/vdr/Developer/${P}.tar.bz2 \
- file://fixpaths.patch;patch=1 \
+SRC_URI += " file://fixpaths.patch;patch=1 \
file://cplusplus.patch;patch=1 \
file://disable_plugin.patch;patch=1 \
file://linkerflags.patch;patch=1 \
@@ -27,7 +21,7 @@ do_install () {
'VIDEODIR=/var/lib/vdr/video' \
'PLUGINLIBDIR=${PLUGINDIR}' \
'LOCDIR=${datadir}/locale' \
- install
+ install
}
PACKAGES_DYNAMIC += "vdr-plugin-*"
@@ -39,4 +33,3 @@ python populate_packages_prepend () {
FILES_${PN} = "${bindir}/* /var/lib/vdr/conf/* ${sysconfdir}/*"
FILES_${PN}-dbg += "${PLUGINDIR}/.debug/*"
-