aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vectoroids
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vectoroids
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vectoroids')
-rw-r--r--recipes/vectoroids/vectoroids_1.1.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/vectoroids/vectoroids_1.1.0.bb b/recipes/vectoroids/vectoroids_1.1.0.bb
new file mode 100644
index 0000000000..bc3883390a
--- /dev/null
+++ b/recipes/vectoroids/vectoroids_1.1.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Clone of the classic arcade game Asteroids - SDL edition."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+APPIMAGE = "data/images/icon.png"
+APPNAME = "vectoroids-${PV}"
+
+SRC_URI = "ftp://ftp.billsgames.com/unix/x/vectoroids/src/vectoroids-${PV}.tar.gz"
+
+inherit qmake sdl
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/SDL CONFIG-=qt \
+ LIBS+=-lSDL \
+ LIBS+=-lSDL_mixer \
+ LIBS+=-lSDL_image \
+ LIBS+=-lpthread \
+ DEFINES+=DATA_PREFIX=\\"\"${datadir}/vectoroids/\\"\""
+
+do_configure_prepend() {
+ qmake -project vectoroids.pro
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${APPNAME} ${D}${bindir}
+ install -d ${D}${datadir}/vectoroids/
+ cp -pPR data/* ${D}${datadir}/vectoroids/
+}