aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vim
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2010-10-19 13:46:08 -0400
committerPhilip Balister <philip@opensdr.com>2010-10-19 13:47:41 -0400
commit4dbe8edc6375b1856dd512349c58d936e4ab446b (patch)
treefba331b0d6610cd5eb1561f722ea9063222984aa /recipes/vim
parentd875046057cb33f0910bd7b6973985a2f9656467 (diff)
downloadopenembedded-4dbe8edc6375b1856dd512349c58d936e4ab446b.tar.gz
vim: Add new package vim-vimrc that installs a vimrc that makes me happy.
Diffstat (limited to 'recipes/vim')
-rw-r--r--recipes/vim/files/vimrc96
-rw-r--r--recipes/vim/vim_7.2.bb9
2 files changed, 105 insertions, 0 deletions
diff --git a/recipes/vim/files/vimrc b/recipes/vim/files/vimrc
new file mode 100644
index 0000000000..df65555af8
--- /dev/null
+++ b/recipes/vim/files/vimrc
@@ -0,0 +1,96 @@
+" An example for a vimrc file.
+"
+" Maintainer: Bram Moolenaar <Bram@vim.org>
+" Last change: 2008 Jul 02
+"
+" To use it, copy it to
+" for Unix and OS/2: ~/.vimrc
+" for Amiga: s:.vimrc
+" for MS-DOS and Win32: $VIM\_vimrc
+" for OpenVMS: sys$login:.vimrc
+
+" When started as "evim", evim.vim will already have done these settings.
+if v:progname =~? "evim"
+ finish
+endif
+
+" Use Vim settings, rather then Vi settings (much better!).
+" This must be first, because it changes other options as a side effect.
+set nocompatible
+
+" allow backspacing over everything in insert mode
+set backspace=indent,eol,start
+
+if has("vms")
+ set nobackup " do not keep a backup file, use versions instead
+else
+ set backup " keep a backup file
+endif
+set history=50 " keep 50 lines of command line history
+set ruler " show the cursor position all the time
+set showcmd " display incomplete commands
+set incsearch " do incremental searching
+
+" For Win32 GUI: remove 't' flag from 'guioptions': no tearoff menu entries
+" let &guioptions = substitute(&guioptions, "t", "", "g")
+
+" Don't use Ex mode, use Q for formatting
+map Q gq
+
+" CTRL-U in insert mode deletes a lot. Use CTRL-G u to first break undo,
+" so that you can undo CTRL-U after inserting a line break.
+inoremap <C-U> <C-G>u<C-U>
+
+" In many terminal emulators the mouse works just fine, thus enable it.
+if has('mouse')
+ set mouse=a
+endif
+
+" Switch syntax highlighting on, when the terminal has colors
+" Also switch on highlighting the last used search pattern.
+"if &t_Co > 2 || has("gui_running")
+" syntax on
+" set hlsearch
+"endif
+
+" Only do this part when compiled with support for autocommands.
+if has("autocmd")
+
+ " Enable file type detection.
+ " Use the default filetype settings, so that mail gets 'tw' set to 72,
+ " 'cindent' is on in C files, etc.
+ " Also load indent files, to automatically do language-dependent indenting.
+ filetype plugin indent on
+
+ " Put these in an autocmd group, so that we can delete them easily.
+ augroup vimrcEx
+ au!
+
+ " For all text files set 'textwidth' to 78 characters.
+ autocmd FileType text setlocal textwidth=78
+
+ " When editing a file, always jump to the last known cursor position.
+ " Don't do it when the position is invalid or when inside an event handler
+ " (happens when dropping a file on gvim).
+ " Also don't do it when the mark is in the first line, that is the default
+ " position when opening a file.
+ autocmd BufReadPost *
+ \ if line("'\"") > 1 && line("'\"") <= line("$") |
+ \ exe "normal! g`\"" |
+ \ endif
+
+ augroup END
+
+else
+
+ set autoindent " always set autoindenting on
+
+endif " has("autocmd")
+
+" Convenient command to see the difference between the current buffer and the
+" file it was loaded from, thus the changes you made.
+" Only define it when not defined already.
+if !exists(":DiffOrig")
+ command DiffOrig vert new | set bt=nofile | r # | 0d_ | diffthis
+ \ | wincmd p | diffthis
+endif
diff --git a/recipes/vim/vim_7.2.bb b/recipes/vim/vim_7.2.bb
index 7d74d08256..b887ce4cd8 100644
--- a/recipes/vim/vim_7.2.bb
+++ b/recipes/vim/vim_7.2.bb
@@ -16,6 +16,7 @@ PR = "${INC_PR}.2"
# 001-411.diff contains 411 patches fetched from upstream
SRC_URI += "file://001-411.diff;apply=no"
SRC_URI += "file://configure.in_remove_CC_quotes.patch;apply=no"
+SRC_URI += "file://vimrc"
# we need to apply patches in other dir then ${S}
do_applypatch() {
@@ -26,4 +27,12 @@ do_applypatch() {
addtask applypatch after do_unpack before do_patch
+do_install_append() {
+ install -m 0644 ${FILESDIR}/vimrc ${D}/${datadir}/vim
+}
+
RCONFLICTS_${PN} = "gvim vim-tiny"
+PACKAGES =+ "${PN}-vimrc"
+
+FILES_${PN}-vimrc = "${datadir}/vim/vimrc"
+