aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/visiscript
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/visiscript
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/visiscript')
-rw-r--r--recipes/visiscript/files/compilefix.patch16
-rw-r--r--recipes/visiscript/files/qcleanuphandler.h127
-rw-r--r--recipes/visiscript/files/qptrlist.h9
-rw-r--r--recipes/visiscript/visiscript_0.3.2.bb33
-rw-r--r--recipes/visiscript/visiscript_0.4.3.bb35
5 files changed, 220 insertions, 0 deletions
diff --git a/recipes/visiscript/files/compilefix.patch b/recipes/visiscript/files/compilefix.patch
new file mode 100644
index 0000000000..3e3fb3458c
--- /dev/null
+++ b/recipes/visiscript/files/compilefix.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- visiscript/main.cpp~compilefix
++++ visiscript/main.cpp
+@@ -66,7 +66,7 @@
+ QApplication aAppl( argc, argv );
+
+ // ** prepare application for different languages...**
+- QTranslator * pTranslator = new QTranslator();
++ QTranslator * pTranslator = new QTranslator( 0, "translator" );
+ QString sLanguage;
+ QString sLanguageTemp = ProcessLanguage( pTranslator, sLanguage, &aAppl );
+
diff --git a/recipes/visiscript/files/qcleanuphandler.h b/recipes/visiscript/files/qcleanuphandler.h
new file mode 100644
index 0000000000..90f65b0cb7
--- /dev/null
+++ b/recipes/visiscript/files/qcleanuphandler.h
@@ -0,0 +1,127 @@
+/****************************************************************************
+** $Id: qt/qcleanuphandler.h 3.3.3 edited May 27 2003 $
+**
+** ...
+**
+** Copyright (C) 2001-2002 Trolltech AS. All rights reserved.
+**
+** This file is part of the tools module of the Qt GUI Toolkit.
+**
+** This file may be distributed under the terms of the Q Public License
+** as defined by Trolltech AS of Norway and appearing in the file
+** LICENSE.QPL included in the packaging of this file.
+**
+** This file may be distributed and/or modified under the terms of the
+** GNU General Public License version 2 as published by the Free Software
+** Foundation and appearing in the file LICENSE.GPL included in the
+** packaging of this file.
+**
+** Licensees holding valid Qt Enterprise Edition or Qt Professional Edition
+** licenses may use this file in accordance with the Qt Commercial License
+** Agreement provided with the Software.
+**
+** This file is provided AS IS with NO WARRANTY OF ANY KIND, INCLUDING THE
+** WARRANTY OF DESIGN, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
+**
+** See http://www.trolltech.com/pricing.html or email sales@trolltech.com for
+** information about Qt Commercial License Agreements.
+** See http://www.trolltech.com/qpl/ for QPL licensing information.
+** See http://www.trolltech.com/gpl/ for GPL licensing information.
+**
+** Contact info@trolltech.com if any conditions of this licensing are
+** not clear to you.
+**
+**********************************************************************/
+
+#ifndef QCLEANUPHANDLER_H
+#define QCLEANUPHANDLER_H
+
+#ifndef QT_H
+#include "qptrlist.h"
+#endif // QT_H
+
+template<class Type>
+class QCleanupHandler
+{
+public:
+ QCleanupHandler() : cleanupObjects( 0 ) {}
+ ~QCleanupHandler() { clear(); }
+
+ Type* add( Type **object ) {
+ if ( !cleanupObjects )
+ cleanupObjects = new QPtrList<Type*>;
+ cleanupObjects->insert( 0, object );
+ return *object;
+ }
+
+ void remove( Type **object ) {
+ if ( !cleanupObjects )
+ return;
+ if ( cleanupObjects->findRef( object ) >= 0 )
+ (void) cleanupObjects->take();
+ }
+
+ bool isEmpty() const {
+ return cleanupObjects ? cleanupObjects->isEmpty() : TRUE;
+ }
+
+ void clear() {
+ if ( !cleanupObjects )
+ return;
+ QPtrListIterator<Type*> it( *cleanupObjects );
+ Type **object;
+ while ( ( object = it.current() ) ) {
+ delete *object;
+ *object = 0;
+ cleanupObjects->remove( object );
+ }
+ delete cleanupObjects;
+ cleanupObjects = 0;
+ }
+
+private:
+ QPtrList<Type*> *cleanupObjects;
+};
+
+template<class Type>
+class QSingleCleanupHandler
+{
+public:
+ QSingleCleanupHandler() : object( 0 ) {}
+ ~QSingleCleanupHandler() {
+ if ( object ) {
+ delete *object;
+ *object = 0;
+ }
+ }
+ Type* set( Type **o ) {
+ object = o;
+ return *object;
+ }
+ void reset() { object = 0; }
+private:
+ Type **object;
+};
+
+template<class Type>
+class QSharedCleanupHandler
+{
+public:
+ QSharedCleanupHandler() : object( 0 ) {}
+ ~QSharedCleanupHandler() {
+ if ( object ) {
+ if ( (*object)->deref() )
+ delete *object;
+ *object = 0;
+ }
+ }
+ Type* set( Type **o ) {
+ object = o;
+ return *object;
+ }
+ void reset() { object = 0; }
+private:
+ Type **object;
+};
+
+#endif //QCLEANUPHANDLER_H
diff --git a/recipes/visiscript/files/qptrlist.h b/recipes/visiscript/files/qptrlist.h
new file mode 100644
index 0000000000..9a07e1eda6
--- /dev/null
+++ b/recipes/visiscript/files/qptrlist.h
@@ -0,0 +1,9 @@
+#ifndef QTCOMPAT_QPTRLIST_H
+#define QTCOMPAT_QPTRLIST_H
+
+#include <qlist.h>
+
+#define QPtrList QList
+#define QPtrListIterator QListIterator
+
+#endif
diff --git a/recipes/visiscript/visiscript_0.3.2.bb b/recipes/visiscript/visiscript_0.3.2.bb
new file mode 100644
index 0000000000..5f4e5d500a
--- /dev/null
+++ b/recipes/visiscript/visiscript_0.3.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+PR = "r1"
+
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+ file://qptrlist.h file://qcleanuphandler.h"
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+
+EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.60-gpl-1.3/qt/lib/libqscintilla_arm.a LIBS+=-lqscintilla"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
+}
+
+#FIXME: package help and translation
diff --git a/recipes/visiscript/visiscript_0.4.3.bb b/recipes/visiscript/visiscript_0.4.3.bb
new file mode 100644
index 0000000000..c50da04249
--- /dev/null
+++ b/recipes/visiscript/visiscript_0.4.3.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+BROKEN = "1"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+ file://qptrlist.h file://qcleanuphandler.h"
+
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+PARALLEL_MAKE = ""
+
+EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.65-gpl-1.6/qt/libqscintilla.a LIBS+=-lqscintilla LIBS+=-ldl"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
+}
+
+#FIXME: package help and translation