aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-29 13:08:59 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-29 13:08:59 +0200
commit331fb40cd2e75c4e48bd380d93d191d71faaf5e8 (patch)
treead4c3b33248f238e272f7ef9e950fcda2f228a44 /recipes/vlc
parent53e7eb0ef3106cf5c9c12a4834f77b6a2119a193 (diff)
downloadopenembedded-331fb40cd2e75c4e48bd380d93d191d71faaf5e8.tar.gz
vlc: update to 1.0.2
Diffstat (limited to 'recipes/vlc')
-rw-r--r--recipes/vlc/vlc_1.0.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/vlc/vlc_1.0.2.bb b/recipes/vlc/vlc_1.0.2.bb
new file mode 100644
index 0000000000..bd967cff44
--- /dev/null
+++ b/recipes/vlc/vlc_1.0.2.bb
@@ -0,0 +1,44 @@
+# This recipe packages vlc as a library as well, so qt4 dependencies
+# can be avoided when ony the library is installed.
+# Would be cool if when newer vlc is added to OE and older ones are phased
+# out that could be made the default.
+
+require vlc.inc
+
+# ffmpeg from git (library version => 52) is required
+# libtool-native must be >= 2.2.4
+DEPENDS += "libdvdcss libdvdread"
+
+EXTRA_OECONF += "\
+ --enable-dvdread \
+"
+
+LEAD_SONAME = "libvlc.so.2"
+
+PACKAGES =+ "libvlc-dbg libvlc-dev libvlc"
+
+FILES_libvlc-dev = "${libdir}/lib*.so"
+
+FILES_libvlc-dbg = "\
+ ${libdir}/.debug \
+ ${libdir}/vlc/meta_engine/.debug \
+ ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \
+ ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \
+ ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \
+ ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \
+ ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \
+ ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \
+ ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \
+ ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \
+ ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \
+ ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \
+ "
+
+FILES_libvlc = "${libdir}/lib*.so.*"
+
+FILES_${PN} += "${bindir}/vlc \
+ ${datadir}/applications \
+ ${datadir}/vlc/ \
+ "
+
+FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"