aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vnc/fbvncserver_0.9.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vnc/fbvncserver_0.9.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vnc/fbvncserver_0.9.4.bb')
-rw-r--r--recipes/vnc/fbvncserver_0.9.4.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/vnc/fbvncserver_0.9.4.bb b/recipes/vnc/fbvncserver_0.9.4.bb
new file mode 100644
index 0000000000..4e6ee15a86
--- /dev/null
+++ b/recipes/vnc/fbvncserver_0.9.4.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "Framebuffer VNC server"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libvncserver jpeg zlib"
+RDEPENDS = "fbvncserver-kmodule libvncserver-storepasswd libvncserver-javaapplet"
+PR = "r3"
+
+SRC_URI = "http://sdgsystems.com/download/fbvncserver-${PV}.tar.gz \
+ file://libvncs0.6.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://kernelinclude.patch;patch=1 \
+ file://buildfix.patch;patch=1 \
+ file://ipaq.patch;patch=1 \
+ file://init"
+
+S = "${WORKDIR}/fbvncserver-${PV}"
+
+export INCLUDES = "-I${STAGING_INCDIR}"
+export LIBS = "-L${STAGING_LIBDIR} -lpthread"
+export VNCSERVER_DIR = "${STAGING_LIBDIR}"
+export ZAURUS_ZLIB_LIBS = "${STAGING_LIBDIR}"
+export ZAURUS_JPEG_LIBS = "${STAGING_LIBDIR}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "fbvncinput"
+INITSCRIPT_PARAMS = "defaults 97"
+
+FBVNCSERVER_SYSTEM = "zaurus"
+FBVNCSERVER_SYSTEM_h3600 = "ipaq"
+FBVNCSERVER_SYSTEM_h3900 = "ipaq"
+
+do_compile () {
+ oe_runmake ${FBVNCSERVER_SYSTEM}_fbvncserver ${FBVNCSERVER_SYSTEM}_tssimd
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${FBVNCSERVER_SYSTEM}_fbvncserver ${D}${bindir}/fbvncserver
+ install -m 0755 ${FBVNCSERVER_SYSTEM}_tssimd ${D}${bindir}/tssimd
+
+ install -d ${D}${datadir}/fbvncserver
+ install -m 0644 ${FBVNCSERVER_SYSTEM}_panel.jpg ${D}${datadir}/fbvncserver/
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/fbvncinput
+}
+
+FILES_${PN} += " /usr/share/fbvncserver/*.jpg"
+