aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vtun/vtun_2.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vtun/vtun_2.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vtun/vtun_2.6.bb')
-rw-r--r--recipes/vtun/vtun_2.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/vtun/vtun_2.6.bb b/recipes/vtun/vtun_2.6.bb
new file mode 100644
index 0000000000..72dd3a4b9f
--- /dev/null
+++ b/recipes/vtun/vtun_2.6.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Virtual Tunnels over TCP/IP networks with traffic shaping, compression and encryption."
+HOMEPAGE = "http://vtun.sourceforge.net/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "zlib lzo"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vtun/vtun-${PV}.tar.gz \
+ file://init \
+ file://makefile.in-ldflags.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/vtun"
+
+inherit autotools
+
+do_configure() {
+ export BLOWFISH_HDR_DIR=${STAGING_INCDIR}/openssl
+ oe_runconf --with-lzo-headers=${STAGING_INCDIR} --with-ssl-headers=${STAGING_INCDIR}/openssl
+}
+
+do_install() {
+ oe_runmake INSTALL_OWNER="" DESTDIR=${D} install
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vtund
+ install ${S}/scripts/vtund-start.conf ${D}${sysconfdir}
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/vtund-start.conf ${sysconfdir}/vtund.conf"