aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-07 19:43:40 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-07 19:43:40 +0200
commitb760ad5d6c04c3a49385f41edb45d8dcd5d3a6b9 (patch)
tree0f05f29e2b152c43d9b8238a39342ee5cf2593ed /recipes/webkit
parent3b600acec73d6c2790a02ba105d384ae68f1de62 (diff)
downloadopenembedded-b760ad5d6c04c3a49385f41edb45d8dcd5d3a6b9.tar.gz
webkit-git: bump SRCREV
Diffstat (limited to 'recipes/webkit')
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac25
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb1
2 files changed, 22 insertions, 4 deletions
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index 2ee8210695..6375788dd3 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -548,10 +548,23 @@ else
CFLAGS="$CFLAGS -O0"
fi
-PKG_CHECK_MODULES([LIBSOUP],
- [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
-AC_SUBST([LIBSOUP_CFLAGS])
-AC_SUBST([LIBSOUP_LIBS])
+# check whether to use libsoup-gnome
+AC_MSG_CHECKING([whether to use GNOME-specific features of libsoup])
+AC_ARG_WITH(libsoup_gnome,
+ AC_HELP_STRING([--with-libsoup-gnome],
+ [using GNOME-specific features of libsoup [default=no]]),
+ [],[with_libsoup_gnome="no"])
+AC_MSG_RESULT([$with_libsoup_gnome])
+
+if test "$with_libsoup_gnome" = "yes"; then
+ PKG_CHECK_MODULES([LIBSOUP],
+ [libsoup-gnome-2.4 >= $LIBSOUP_REQUIRED_VERSION])
+else
+ PKG_CHECK_MODULES([LIBSOUP],
+ [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
+fi
+AC_SUBST(LIBSOUP_CFLAGS)
+AC_SUBST(LIBSOUP_LIBS)
if test "$enable_gnomekeyring" = "yes"; then
PKG_CHECK_MODULES([GNOMEKEYRING],
@@ -650,6 +663,9 @@ AM_CONDITIONAL([USE_GNOMEKEYRING], [test "$enable_gnomekeyring" = "yes"])
AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
+# libsoup-gnome conditionals
+AM_CONDITIONAL([USE_SOUP_GNOME], [test "$with_libsoup_gnome" = "yes"])
+
# WebKit feature conditionals
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
AM_CONDITIONAL([ENABLE_DASHBOARD_SUPPORT],[test "$enable_dashboard_support" = "yes"])
@@ -699,6 +715,7 @@ Build configuration:
Unicode backend : $with_unicode_backend
Font backend : $with_font_backend
Optimized memory allocator : $enable_fast_malloc
+ Using GNOME-specific features of libsoup : $with_libsoup_gnome
Features:
3D Transforms : $enable_3D_transforms
JIT compilation : $enable_jit
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index db0838630c..f36671c494 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -35,6 +35,7 @@ EXTRA_OECONF = "\
--enable-icon-database=yes \
--with-http-backend=soup \
# --with-unicode-backend=glib \
+ --with-libsoup-gnome=yes \
"
EXTRA_AUTORECONF = " -I autotools "