aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit
diff options
context:
space:
mode:
authorSteve Sakoman <sakoman@quadra.(none)>2009-09-29 20:57:39 -0700
committerKoen Kooi <koen@openembedded.org>2009-09-30 12:04:14 +0200
commitf08b66e282e107df7da73d0b1b129ab82beb9c7d (patch)
treec1f0f0a58ef728e33d3e4dcde919cf3930396798 /recipes/webkit
parent87a9e6b4f556808aef42bf8f89d2740379e97727 (diff)
downloadopenembedded-f08b66e282e107df7da73d0b1b129ab82beb9c7d.tar.gz
webkit: bump SRCREV
Diffstat (limited to 'recipes/webkit')
-rw-r--r--recipes/webkit/webkit-gtk/GNUmakefile.am106
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac75
-rwxr-xr-x[-rw-r--r--]recipes/webkit/webkit-gtk/update-webkit.sh0
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb2
4 files changed, 120 insertions, 63 deletions
diff --git a/recipes/webkit/webkit-gtk/GNUmakefile.am b/recipes/webkit/webkit-gtk/GNUmakefile.am
index c80d6493fa..23cd7eabc1 100644
--- a/recipes/webkit/webkit-gtk/GNUmakefile.am
+++ b/recipes/webkit/webkit-gtk/GNUmakefile.am
@@ -87,7 +87,6 @@ corekit_cflags += \
$(GAIL_CFLAGS) \
$(GEOCLUE_CFLAGS) \
$(GLIB_CFLAGS) \
- $(GNOMEKEYRING_CFLAGS) \
$(GSTREAMER_CFLAGS) \
$(GTK_CFLAGS) \
$(HILDON_CFLAGS) \
@@ -107,7 +106,8 @@ corekit_cppflags += \
$(webcoregtk_cppflags) \
$(javascriptcore_cppflags)
-if TARGET_X11
+# For the Gtk port we want to use XP_UNIX both in X11 and Mac
+if !TARGET_WIN32
corekit_cppflags += -DXP_UNIX
endif
@@ -247,7 +247,6 @@ libwebkit_1_0_la_LIBADD = \
$(GAIL_LIBS) \
$(GEOCLUE_LIBS) \
$(GLIB_LIBS) \
- $(GNOMEKEYRING_LIBS) \
$(GSTREAMER_LIBS) \
$(GTK_LIBS) \
$(HILDON_LIBS) \
@@ -315,22 +314,28 @@ global_cppflags += \
endif
webkitgtk_h_api += \
- WebKit/gtk/webkit/webkit.h \
- WebKit/gtk/webkit/webkitdefines.h \
- WebKit/gtk/webkit/webkitdownload.h \
- WebKit/gtk/webkit/webkiterror.h \
- WebKit/gtk/webkit/webkitnetworkrequest.h \
- WebKit/gtk/webkit/webkitsoupauthdialog.h \
- WebKit/gtk/webkit/webkitversion.h \
- WebKit/gtk/webkit/webkitwebbackforwardlist.h \
- WebKit/gtk/webkit/webkitwebframe.h \
- WebKit/gtk/webkit/webkitwebhistoryitem.h \
- WebKit/gtk/webkit/webkitwebinspector.h \
- WebKit/gtk/webkit/webkitwebnavigationaction.h \
- WebKit/gtk/webkit/webkitwebpolicydecision.h \
- WebKit/gtk/webkit/webkitwebsettings.h \
- WebKit/gtk/webkit/webkitwebwindowfeatures.h \
- WebKit/gtk/webkit/webkitwebview.h
+ $(srcdir)/WebKit/gtk/webkit/webkit.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitdefines.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitdownload.h \
+ $(srcdir)/WebKit/gtk/webkit/webkiterror.h \
+ $(srcdir)/WebKit/gtk/webkit/webkithittestresult.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitnetworkrequest.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitnetworkresponse.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitsoupauthdialog.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebbackforwardlist.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebdatasource.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebframe.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebhistoryitem.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebinspector.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebnavigationaction.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebpolicydecision.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebresource.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebsettings.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebwindowfeatures.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebview.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitwebdatabase.h \
+ $(srcdir)/WebKit/gtk/webkit/webkitsecurityorigin.h \
+ $(top_builddir)/WebKit/gtk/webkit/webkitversion.h
webkitgtk_built_sources += \
DerivedSources/webkitenumtypes.cpp \
@@ -343,6 +348,8 @@ webkitgtk_sources += \
WebKit/gtk/WebCoreSupport/ChromeClientGtk.h \
WebKit/gtk/WebCoreSupport/ContextMenuClientGtk.cpp \
WebKit/gtk/WebCoreSupport/ContextMenuClientGtk.h \
+ WebKit/gtk/WebCoreSupport/DocumentLoaderGtk.cpp \
+ WebKit/gtk/WebCoreSupport/DocumentLoaderGtk.h \
WebKit/gtk/WebCoreSupport/DragClientGtk.cpp \
WebKit/gtk/WebCoreSupport/DragClientGtk.h \
WebKit/gtk/WebCoreSupport/EditorClientGtk.cpp \
@@ -353,22 +360,30 @@ webkitgtk_sources += \
WebKit/gtk/WebCoreSupport/InspectorClientGtk.h \
WebKit/gtk/WebCoreSupport/PasteboardHelperGtk.cpp \
WebKit/gtk/WebCoreSupport/PasteboardHelperGtk.h \
+ WebKit/gtk/webkit/webkitapplicationcache.cpp \
WebKit/gtk/webkit/webkitdownload.cpp \
WebKit/gtk/webkit/webkiterror.cpp \
+ WebKit/gtk/webkit/webkithittestresult.cpp \
WebKit/gtk/webkit/webkitnetworkrequest.cpp \
+ WebKit/gtk/webkit/webkitnetworkresponse.cpp \
WebKit/gtk/webkit/webkitprivate.cpp \
WebKit/gtk/webkit/webkitprivate.h \
WebKit/gtk/webkit/webkitsoupauthdialog.c \
WebKit/gtk/webkit/webkitversion.cpp \
WebKit/gtk/webkit/webkitwebbackforwardlist.cpp \
+ WebKit/gtk/webkit/webkitwebdatasource.cpp \
WebKit/gtk/webkit/webkitwebframe.cpp \
WebKit/gtk/webkit/webkitwebhistoryitem.cpp \
WebKit/gtk/webkit/webkitwebinspector.cpp \
WebKit/gtk/webkit/webkitwebnavigationaction.cpp \
WebKit/gtk/webkit/webkitwebpolicydecision.cpp \
+ WebKit/gtk/webkit/webkitwebresource.cpp \
+ WebKit/gtk/webkit/webkitwebdatabase.cpp \
+ WebKit/gtk/webkit/webkitsecurityorigin.cpp \
WebKit/gtk/webkit/webkitwebsettings.cpp \
WebKit/gtk/webkit/webkitwebview.cpp \
- WebKit/gtk/webkit/webkitwebwindowfeatures.cpp
+ WebKit/gtk/webkit/webkitwebwindowfeatures.cpp \
+ WebKit/gtk/webkit/webkitworkers.cpp
webkitgtk_cppflags += \
-DBUILDING_WEBKIT \
@@ -379,11 +394,6 @@ webkitgtk_cppflags += \
-I$(srcdir)/WebKit/gtk/webkit \
-I$(top_builddir)/WebKit/gtk/webkit
-if USE_GNOMEKEYRING
-webkitgtk_cppflags += \
- -DWTF_USE_GNOMEKEYRING=1
-endif
-
webkitgtk_cleanfiles += \
$(top_builddir)/WebKit/gtk/docs/version.xml \
$(top_builddir)/WebKit/gtk/docs/GNUmakefile \
@@ -411,19 +421,18 @@ $(WEBKIT_MARSHAL).h: stamp-webkitmarshal.h
@true
stamp-webkitmarshal.cpp: $(WEBKIT_MARSHAL_LIST)
- echo "extern \"C\" {" > $(WEBKIT_MARSHAL).cpp && \
+ $(AM_V_GEN) echo "extern \"C\" {" > $(WEBKIT_MARSHAL).cpp && \
$(GLIB_GENMARSHAL) --prefix=webkit_marshal $(WEBKIT_MARSHAL_LIST) --body >> $(WEBKIT_MARSHAL).cpp && echo '}' >> $(WEBKIT_MARSHAL).cpp && \
echo timestamp > $(@F)
stamp-webkitmarshal.h: $(WEBKIT_MARSHAL_LIST)
- $(GLIB_GENMARSHAL) --prefix=webkit_marshal $(WEBKIT_MARSHAL_LIST) --header > $(WEBKIT_MARSHAL).h && \
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --prefix=webkit_marshal $(WEBKIT_MARSHAL_LIST) --header > $(WEBKIT_MARSHAL).h && \
echo timestamp > $(@F)
WebKit/gtk/webkit/webkitenumtypes.h: stamp-webkitenumtypes.h
@true
stamp-webkitenumtypes.h: $(webkitgtk_h_api) GNUmakefile
- (cd $(srcdir) \
- && glib-mkenums \
+ $(AM_V_GEN)glib-mkenums \
--fhead "#ifndef WEBKIT_ENUM_TYPES_H\n" \
--fhead "#define WEBKIT_ENUM_TYPES_H\n\n" \
--fhead "#include <glib-object.h>\n\n" \
@@ -431,21 +440,19 @@ stamp-webkitenumtypes.h: $(webkitgtk_h_api) GNUmakefile
--fhead "G_BEGIN_DECLS\n\n" \
--ftail "G_END_DECLS\n\n" \
--ftail "#endif\n" \
- --fprod "#include <@filename@>\n\n" \
+ --fprod "#include <webkit/@basename@>\n\n" \
--eprod "#define WEBKIT_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n\n" \
--eprod "WEBKIT_API GType\n@enum_name@_get_type(void);\n\n" \
$(webkitgtk_h_api) | \
- sed 's,WebKit/gtk/,,' | \
sed 's,web_kit,webkit,' | \
sed 's,WEBKIT_TYPE_KIT,WEBKIT_TYPE,' \
- ) > xgen-gth \
+ > xgen-gth \
&& (cmp -s xgen-gth WebKit/gtk/webkit/webkitenumtypes.h || cp xgen-gth WebKit/gtk/webkit/webkitenumtypes.h) \
&& rm -f xgen-gth \
&& echo timestamp > $(@F)
DerivedSources/webkitenumtypes.cpp: $(webkitgtk_h_api) GNUmakefile
- (cd $(srcdir) \
- && glib-mkenums \
+ $(AM_V_GEN)glib-mkenums \
--fhead "#include <config.h>\n" \
--fhead "#include <glib-object.h>\n" \
--fhead "#include \"$(top_builddir)/WebKit/gtk/webkit/webkitenumtypes.h\"\n\n" \
@@ -462,7 +469,7 @@ DerivedSources/webkitenumtypes.cpp: $(webkitgtk_h_api) GNUmakefile
--ftail "}\n" \
$(webkitgtk_h_api) | \
sed 's,web_kit,webkit,' \
- ) > xgen-gtc \
+ > xgen-gtc \
&& cp xgen-gtc $@ \
&& rm -f xgen-gtc
@@ -528,12 +535,17 @@ webkit_tests_ldflags = \
TEST_PROGS += Programs/unittests/testhttpbackend \
Programs/unittests/testloading \
Programs/unittests/testnetworkrequest \
+ Programs/unittests/testnetworkresponse \
Programs/unittests/testwebframe \
Programs/unittests/testwebbackforwardlist \
Programs/unittests/testwebhistoryitem \
+ Programs/unittests/testwindow \
Programs/unittests/testdownload \
Programs/unittests/testatk \
- Programs/unittests/testwebsettings
+ Programs/unittests/testhittestresult \
+ Programs/unittests/testwebsettings \
+ Programs/unittests/testwebresource \
+ Programs/unittests/testwebdatasource
# Add additional tests here
Programs_unittests_testhttpbackend_SOURCES = WebKit/gtk/tests/testhttpbackend.c
@@ -551,6 +563,11 @@ Programs_unittests_testnetworkrequest_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testnetworkrequest_LDADD = $(webkit_tests_ldadd)
Programs_unittests_testnetworkrequest_LDFLAGS = $(webkit_tests_ldflags)
+Programs_unittests_testnetworkresponse_SOURCES = WebKit/gtk/tests/testnetworkresponse.c
+Programs_unittests_testnetworkresponse_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testnetworkresponse_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testnetworkresponse_LDFLAGS = $(webkit_tests_ldflags)
+
Programs_unittests_testwebframe_SOURCES = WebKit/gtk/tests/testwebframe.c
Programs_unittests_testwebframe_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebframe_LDADD = $(webkit_tests_ldadd)
@@ -566,6 +583,11 @@ Programs_unittests_testwebhistoryitem_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebhistoryitem_LDADD = $(webkit_tests_ldadd)
Programs_unittests_testwebhistoryitem_LDFLAGS = $(webkit_tests_ldflags)
+Programs_unittests_testwindow_SOURCES = WebKit/gtk/tests/testwindow.c
+Programs_unittests_testwindow_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwindow_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testwindow_LDFLAGS = $(webkit_tests_ldflags)
+
Programs_unittests_testdownload_SOURCES = WebKit/gtk/tests/testdownload.c
Programs_unittests_testdownload_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testdownload_LDADD = $(webkit_tests_ldadd)
@@ -581,6 +603,18 @@ Programs_unittests_testwebsettings_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebsettings_LDADD = $(webkit_tests_ldadd)
Programs_unittests_testwebsettings_LDFLAGS = $(webkit_tests_ldflags)
+Programs_unittests_testwebresource_SOURCES = WebKit/gtk/tests/testwebresource.c
+Programs_unittests_testwebresource_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwebresource_LDADD = $(webkit_tests_ldadd)
+
+Programs_unittests_testwebdatasource_SOURCES = WebKit/gtk/tests/testwebdatasource.c
+Programs_unittests_testwebdatasource_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwebdatasource_LDADD = $(webkit_tests_ldadd)
+
+Programs_unittests_testhittestresult_SOURCES = WebKit/gtk/tests/testhittestresult.c
+Programs_unittests_testhittestresult_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testhittestresult_LDADD = $(webkit_tests_ldadd)
+
# Autogenerated sources
BUILT_SOURCES := \
$(javascriptcore_built_sources) \
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index 4793e68b24..fb932213b4 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -2,7 +2,7 @@ AC_PREREQ(2.59)
m4_define([webkit_major_version], [1])
m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [11])
+m4_define([webkit_micro_version], [15])
# This is the version we'll be using as part of our User-Agent string
# e.g., AppleWebKit/$(webkit_user_agent_version) ...
@@ -35,11 +35,14 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
dnl # Libtool library version, not to confuse with API version
dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=10:0:8
+LIBWEBKITGTK_VERSION=13:0:11
AC_SUBST([LIBWEBKITGTK_VERSION])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
+# Use AM_SILENT_RULES if present
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
# host checking - inspired by the GTK+ configure.in
# TODO: move these to webkit.m4?
AC_MSG_CHECKING([for native Win32])
@@ -187,21 +190,20 @@ if test "$with_hildon" = "yes"; then
fi
# minimum base dependencies
-LIBSOUP_REQUIRED_VERSION=2.27.4
+LIBSOUP_REQUIRED_VERSION=2.27.91
CAIRO_REQUIRED_VERSION=1.2
FONTCONFIG_REQUIRED_VERSION=2.4
FREETYPE2_REQUIRED_VERSION=9.0
LIBXML_REQUIRED_VERSION=2.6
# minimum GTK+ base dependencies
-PANGO_REQUIRED_VERSION=1.0
+PANGO_REQUIRED_VERSION=1.12
GTK_REQUIRED_VERSION=2.10
# optional modules
LIBXSLT_REQUIRED_VERSION=1.1.7
SQLITE_REQUIRED_VERSION=3.0
GSTREAMER_REQUIRED_VERSION=0.10
-GNOME_KEYRING_REQUIRED_VERSION=2.26.0
ENCHANT_REQUIRED_VERSION=0.22
GAIL_REQUIRED_VERSION=1.8
@@ -345,6 +347,14 @@ AC_ARG_ENABLE(database,
[],[enable_database="yes"])
AC_MSG_RESULT([$enable_database])
+# check whether to build with server-sent events support
+AC_MSG_CHECKING([whether to enable HTML5 server-sent events support])
+AC_ARG_ENABLE(eventsource,
+ AC_HELP_STRING([--enable-eventsource],
+ [enable HTML5 server-sent events support [default=yes]]),
+ [],[enable_eventsource="yes"])
+AC_MSG_RESULT([$enable_eventsource])
+
# check whether to build with icon database support
AC_MSG_CHECKING([whether to enable icon database support])
AC_ARG_ENABLE(icon_database,
@@ -353,6 +363,22 @@ AC_ARG_ENABLE(icon_database,
[],[enable_icon_database="yes"])
AC_MSG_RESULT([$enable_icon_database])
+# check whether to enable HTML5 datalist support
+AC_MSG_CHECKING([whether to enable HTML5 datalist support])
+AC_ARG_ENABLE(datalist,
+ AC_HELP_STRING([--enable-datalist],
+ [enable HTML5 datalist support [default=yes]]),
+ [],[enable_datalist="yes"])
+AC_MSG_RESULT([$enable_datalist])
+
+# check whether to enable HTML5 ruby support
+AC_MSG_CHECKING([whether to enable HTML5 ruby support])
+AC_ARG_ENABLE(ruby,
+ AC_HELP_STRING([--enable-ruby],
+ [enable HTML5 ruby support [default=yes]]),
+ [],[enable_ruby="yes"])
+AC_MSG_RESULT([$enable_ruby])
+
# check whether to enable HTML5 audio/video support
AC_MSG_CHECKING([whether to enable HTML5 video support])
AC_ARG_ENABLE(video,
@@ -385,14 +411,6 @@ AC_ARG_ENABLE(geolocation,
[],[enable_geolocation="no"])
AC_MSG_RESULT([$enable_geolocation])
-# check whether to enable gnomekeyring support
-AC_MSG_CHECKING([whether to enable gnomekeyring support])
-AC_ARG_ENABLE(gnomekeyring,
- AC_HELP_STRING([--enable-gnomekeyring],
- [enable support for gnomekeyring [default=no]]),
- [],[enable_gnomekeyring="no"])
-AC_MSG_RESULT([$enable_gnomekeyring])
-
# check whether to enable SVG support
AC_MSG_CHECKING([whether to enable SVG support])
AC_ARG_ENABLE(svg,
@@ -495,6 +513,14 @@ if test "$enable_svg_animation" = "yes" || \
fi
fi
+# check whether to enable Web Socket support
+AC_MSG_CHECKING([whether to enable Web Sockets support])
+AC_ARG_ENABLE(web_sockets,
+ AC_HELP_STRING([--enable-web-sockets],
+ [enable support for Web Sockets [default=yes]]),
+ [],[enable_web_sockets="no"])
+AC_MSG_RESULT([$enable_web_sockets])
+
# check whether to enable code coverage
AC_MSG_CHECKING([whether to enable code coverage support])
AC_ARG_ENABLE(coverage,
@@ -577,13 +603,6 @@ PKG_CHECK_MODULES([LIBSOUP],
AC_SUBST([LIBSOUP_CFLAGS])
AC_SUBST([LIBSOUP_LIBS])
-if test "$enable_gnomekeyring" = "yes"; then
- PKG_CHECK_MODULES([GNOMEKEYRING],
- [gnome-keyring-1 >= $GNOME_KEYRING_REQUIRED_VERSION])
- AC_SUBST([GNOMEKEYRING_CFLAGS])
- AC_SUBST([GNOMEKEYRING_LIBS])
-fi
-
# check if FreeType/FontConfig are available
if test "$with_font_backend" = "freetype"; then
if test "$with_target" = "directfb"; then
@@ -628,8 +647,8 @@ fi
if test "$enable_video" = "yes"; then
PKG_CHECK_MODULES([GSTREAMER],
[gstreamer-0.10 >= $GSTREAMER_REQUIRED_VERSION
- gstreamer-base-0.10,
- gstreamer-plugins-base-0.10,
+ gstreamer-base-0.10
+ gstreamer-plugins-base-0.10
gstreamer-video-0.10])
AC_SUBST([GSTREAMER_CFLAGS])
AC_SUBST([GSTREAMER_LIBS])
@@ -667,9 +686,6 @@ AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"])
AM_CONDITIONAL([USE_ICU_UNICODE], [test "$with_unicode_backend" = "icu"])
AM_CONDITIONAL([USE_GLIB_UNICODE], [test "$with_unicode_backend" = "glib"])
-# Auth backend conditionals
-AM_CONDITIONAL([USE_GNOMEKEYRING], [test "$enable_gnomekeyring" = "yes"])
-
# Font backend conditionals
AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
@@ -683,12 +699,16 @@ AM_CONDITIONAL([ENABLE_JAVASCRIPT_DEBUGGER],[test "$enable_javascript_debugger"
AM_CONDITIONAL([ENABLE_OFFLINE_WEB_APPLICATIONS],[test "$enable_offline_web_applications" = "yes"])
AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
+AM_CONDITIONAL([ENABLE_DATALIST],[test "$enable_datalist" = "yes"])
+AM_CONDITIONAL([ENABLE_EVENTSOURCE],[test "$enable_eventsource" = "yes"])
AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
+AM_CONDITIONAL([ENABLE_RUBY],[test "$enable_ruby" = "yes"])
AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"])
+AM_CONDITIONAL([ENABLE_NOTIFICATIONS],[test "$enable_notifications" = "yes"])
AM_CONDITIONAL([ENABLE_SVG],[test "$enable_svg" = "yes"])
AM_CONDITIONAL([ENABLE_SVG_ANIMATION],[test "$enable_svg_animation" = "yes"])
AM_CONDITIONAL([ENABLE_SVG_FONTS],[test "$enable_svg_fonts" = "yes"])
@@ -702,6 +722,7 @@ AM_CONDITIONAL([ENABLE_WORKERS],[test "$enable_workers" = "yes"])
AM_CONDITIONAL([ENABLE_SHARED_WORKERS],[test "$enable_shared_workers" = "yes"])
AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"])
AM_CONDITIONAL([HTML_FLAGS],[test "$html_flags" = "yes"])
+AM_CONDITIONAL([ENABLE_WEB_SOCKETS],[test "$enable_web_sockets" = "yes"])
AC_CONFIG_FILES([
GNUmakefile
@@ -730,12 +751,13 @@ Features:
Dashboard support : $enable_dashboard_support
Filters support : $enable_filters
Geolocation support : $enable_geolocation
- GNOME Keyring support : $enable_gnomekeyring
JavaScript debugger/profiler support : $enable_javascript_debugger
HTML5 offline web applications support : $enable_offline_web_applications
HTML5 channel messaging support : $enable_channel_messaging
HTML5 client-side session and persistent storage support : $enable_dom_storage
HTML5 client-side database storage support : $enable_database
+ HTML5 ruby support : $enable_ruby
+ HTML5 server-sent events support : $enable_eventsource
HTML5 video element support : $enable_video
Icon database support : $enable_icon_database
SharedWorkers support : $enable_shared_workers
@@ -746,6 +768,7 @@ Features:
SVG as image support : $enable_svg_as_image
SVG use element support : $enable_svg_use
WML support : $enable_wml
+ Web Sockets support : $enable_web_sockets
Web Workers support : $enable_workers
XPATH support : $enable_xpath
XSLT support : $enable_xslt
diff --git a/recipes/webkit/webkit-gtk/update-webkit.sh b/recipes/webkit/webkit-gtk/update-webkit.sh
index 723c45a4fb..723c45a4fb 100644..100755
--- a/recipes/webkit/webkit-gtk/update-webkit.sh
+++ b/recipes/webkit/webkit-gtk/update-webkit.sh
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index fcf7ccfa97..64c031df0a 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu lib
SRCREV_FORMAT = "webcore-rwebkit"
-PV = "1.1.11+svnr${SRCREV}"
+PV = "1.1.15+svnr${SRCREV}"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \