aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/whois
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-01-21 16:20:25 -0800
committerKhem Raj <raj.khem@gmail.com>2010-01-21 16:20:25 -0800
commit310b2cd8919a13280b445537893c109b66c5275c (patch)
tree344b8dd2f301494b3ce78d22b350731cf99a7cfa /recipes/whois
parent8ec8982add5c95bef4f18f60ef80b29bf6bf1145 (diff)
downloadopenembedded-310b2cd8919a13280b445537893c109b66c5275c.tar.gz
whois: Add recipe for version 5.0.0.
* Move to using INC_PR * Add md5 and sha checksums to recipe. * Move more common parts like SRC_URI to whois.inc. * Thanks Paul Menzel for reporting the pending upgrade. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/whois')
-rw-r--r--recipes/whois/whois.inc8
-rw-r--r--recipes/whois/whois_4.5.25.bb6
-rw-r--r--recipes/whois/whois_5.0.0.bb6
3 files changed, 15 insertions, 5 deletions
diff --git a/recipes/whois/whois.inc b/recipes/whois/whois.inc
index 15af5e8454..f7fc93861d 100644
--- a/recipes/whois/whois.inc
+++ b/recipes/whois/whois.inc
@@ -4,6 +4,14 @@ LICENSE = "GPL"
HOMEPAGE = "http://www.linux.it/~md/software/"
SECTION = "network"
+INC_PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/w/whois/whois_${PV}.tar.gz;name=whois"
+
+S = "${WORKDIR}/whois-${PV}"
+
+inherit gettext
+
def whois_intl(bb, d):
# FIXME: This is ugly.. we already have the virtual for this,
# but there's no way to ask bb who the current selected provider of
diff --git a/recipes/whois/whois_4.5.25.bb b/recipes/whois/whois_4.5.25.bb
index 22952b0d8c..2a574678df 100644
--- a/recipes/whois/whois_4.5.25.bb
+++ b/recipes/whois/whois_4.5.25.bb
@@ -1,6 +1,2 @@
+PR = "${INC_PR}.0"
require whois.inc
-
-SRC_URI = "${DEBIAN_MIRROR}/main/w/whois/whois_${PV}.tar.gz"
-S = "${WORKDIR}/whois-${PV}"
-
-inherit gettext
diff --git a/recipes/whois/whois_5.0.0.bb b/recipes/whois/whois_5.0.0.bb
new file mode 100644
index 0000000000..a595ec5565
--- /dev/null
+++ b/recipes/whois/whois_5.0.0.bb
@@ -0,0 +1,6 @@
+require whois.inc
+PR = "${INC_PR}.0"
+
+SRC_URI[whois.md5sum] = "18d74a07d711262b75f04a1c319bc833"
+SRC_URI[whois.sha256sum] = "fb13316c09ff9f98bd9af659d0789c9a09b97757f5c6c3dbfbc790250d5c5abc"
+