aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wireshark
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wireshark
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wireshark')
-rw-r--r--recipes/wireshark/files/acinclude-net-snmp-fix.patch13
-rw-r--r--recipes/wireshark/files/ieee80215.4.patch9
-rw-r--r--recipes/wireshark/files/libtool-fix.patch14
-rw-r--r--recipes/wireshark/files/no-host-includes.patch546
-rw-r--r--recipes/wireshark/files/use-our-lemon.patch16
-rw-r--r--recipes/wireshark/tshark_0.99.4.bb5
-rw-r--r--recipes/wireshark/wireshark.inc20
-rw-r--r--recipes/wireshark/wireshark_0.99.4.bb10
-rw-r--r--recipes/wireshark/wireshark_1.0.5.bb70
9 files changed, 703 insertions, 0 deletions
diff --git a/recipes/wireshark/files/acinclude-net-snmp-fix.patch b/recipes/wireshark/files/acinclude-net-snmp-fix.patch
new file mode 100644
index 0000000000..3f6dbf3b05
--- /dev/null
+++ b/recipes/wireshark/files/acinclude-net-snmp-fix.patch
@@ -0,0 +1,13 @@
+Index: wireshark-0.99.4/acinclude.m4
+===================================================================
+--- wireshark-0.99.4.orig/acinclude.m4 2009-01-03 22:57:54.106829288 +0300
++++ wireshark-0.99.4/acinclude.m4 2009-01-03 22:57:59.806420438 +0300
+@@ -1117,7 +1117,7 @@ AC_DEFUN([AC_WIRESHARK_NETSNMP_CHECK],
+ #
+ AC_PATH_PROG(NETSNMPCONFIG, net-snmp-config)
+ else
+- NETSNMPCNFIG=$netsnmpconfig
++ NETSNMPCONFIG=$netsnmpconfig
+ if test ! -x $NETSNMPCONFIG -o ! -f $NETSNMPCONFIG ; then
+ NETSNMPCONFIG=$netsnmpconfig/bin/net-snmp-config
+ if test ! -x $NETSNMPCONFIG -o ! -f $NETSNMPCONFIG ; then
diff --git a/recipes/wireshark/files/ieee80215.4.patch b/recipes/wireshark/files/ieee80215.4.patch
new file mode 100644
index 0000000000..8bcdd93d97
--- /dev/null
+++ b/recipes/wireshark/files/ieee80215.4.patch
@@ -0,0 +1,9 @@
+--- wireshark-1.0.5.orig/epan/dissectors/packet-ieee802154.c
++++ wireshark-1.0.5/epan/dissectors/packet-ieee802154.c
+@@ -1696,7 +1696,7 @@
+ dissector_handle_t ieee802154_handle;
+
+ /* Get the dissector handles. */
+- ieee802154_handle = find_dissector("wpan");
++ ieee802154_handle = find_dissector("wpan_nofcs");
+ data_handle = find_dissector("data");
diff --git a/recipes/wireshark/files/libtool-fix.patch b/recipes/wireshark/files/libtool-fix.patch
new file mode 100644
index 0000000000..4a978bad92
--- /dev/null
+++ b/recipes/wireshark/files/libtool-fix.patch
@@ -0,0 +1,14 @@
+Index: wireshark-0.99.4/configure.in
+===================================================================
+--- wireshark-0.99.4.orig/configure.in 2009-01-05 01:23:50.887336868 +0300
++++ wireshark-0.99.4/configure.in 2009-01-05 01:24:03.136385630 +0300
+@@ -16,8 +16,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CPP
+ dnl Work around libtool bug (fixed in the version 1.5a?)
+-AC_DEFUN([AC_PROVIDE_AC_LIBTOOL_DLOPEN], )
+-AC_LIBTOOL_DLOPEN
++LT_INIT([dlopen])
+ AC_PROG_LIBTOOL
+ AC_PROG_YACC
+ AM_PROG_LEX
diff --git a/recipes/wireshark/files/no-host-includes.patch b/recipes/wireshark/files/no-host-includes.patch
new file mode 100644
index 0000000000..4a9493d607
--- /dev/null
+++ b/recipes/wireshark/files/no-host-includes.patch
@@ -0,0 +1,546 @@
+Index: wireshark-0.99.4/plugins/acn/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/acn/Makefile.am 2006-12-14 14:47:13.322227000 +0100
++++ wireshark-0.99.4/plugins/acn/Makefile.am 2006-12-14 14:47:38.862227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/acn/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/acn/Makefile.in 2006-12-14 14:47:13.352227000 +0100
++++ wireshark-0.99.4/plugins/acn/Makefile.in 2006-12-14 14:48:09.612227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = acn
+Index: wireshark-0.99.4/plugins/agentx/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/agentx/Makefile.am 2006-12-14 14:47:13.372227000 +0100
++++ wireshark-0.99.4/plugins/agentx/Makefile.am 2006-12-14 14:48:30.252227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/agentx/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/agentx/Makefile.in 2006-12-14 14:47:13.402227000 +0100
++++ wireshark-0.99.4/plugins/agentx/Makefile.in 2006-12-14 14:48:37.612227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = agentx
+Index: wireshark-0.99.4/plugins/artnet/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/artnet/Makefile.am 2006-12-14 14:47:13.422227000 +0100
++++ wireshark-0.99.4/plugins/artnet/Makefile.am 2006-12-14 14:48:42.422227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/artnet/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/artnet/Makefile.in 2006-12-14 14:47:13.452227000 +0100
++++ wireshark-0.99.4/plugins/artnet/Makefile.in 2006-12-14 14:48:46.142227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = artnet
+Index: wireshark-0.99.4/plugins/asn1/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/asn1/Makefile.am 2006-12-14 14:47:13.482227000 +0100
++++ wireshark-0.99.4/plugins/asn1/Makefile.am 2006-12-14 14:48:50.352227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/asn1/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/asn1/Makefile.in 2006-12-14 14:47:13.502227000 +0100
++++ wireshark-0.99.4/plugins/asn1/Makefile.in 2006-12-14 14:48:54.772227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = asn1
+Index: wireshark-0.99.4/plugins/ciscosm/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/ciscosm/Makefile.am 2006-12-14 14:47:13.532227000 +0100
++++ wireshark-0.99.4/plugins/ciscosm/Makefile.am 2006-12-14 14:49:01.482227000 +0100
+@@ -23,7 +23,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/ciscosm/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/ciscosm/Makefile.in 2006-12-14 14:47:13.552227000 +0100
++++ wireshark-0.99.4/plugins/ciscosm/Makefile.in 2006-12-14 14:49:18.302227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = ciscosm
+Index: wireshark-0.99.4/plugins/docsis/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/docsis/Makefile.am 2006-12-14 14:47:13.582227000 +0100
++++ wireshark-0.99.4/plugins/docsis/Makefile.am 2006-12-14 14:49:18.302227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/docsis/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/docsis/Makefile.in 2006-12-14 14:47:13.602227000 +0100
++++ wireshark-0.99.4/plugins/docsis/Makefile.in 2006-12-14 14:49:18.312227000 +0100
+@@ -380,7 +380,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = docsis
+Index: wireshark-0.99.4/plugins/enttec/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/enttec/Makefile.am 2006-12-14 14:47:13.632227000 +0100
++++ wireshark-0.99.4/plugins/enttec/Makefile.am 2006-12-14 14:49:18.322227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/enttec/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/enttec/Makefile.in 2006-12-14 14:47:13.662227000 +0100
++++ wireshark-0.99.4/plugins/enttec/Makefile.in 2006-12-14 14:49:18.332227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = enttec
+Index: wireshark-0.99.4/plugins/gryphon/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/gryphon/Makefile.am 2006-12-14 14:47:13.712227000 +0100
++++ wireshark-0.99.4/plugins/gryphon/Makefile.am 2006-12-14 14:49:18.342227000 +0100
+@@ -24,7 +24,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/gryphon/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/gryphon/Makefile.in 2006-12-14 14:47:13.732227000 +0100
++++ wireshark-0.99.4/plugins/gryphon/Makefile.in 2006-12-14 14:49:18.342227000 +0100
+@@ -373,7 +373,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = gryphon
+Index: wireshark-0.99.4/plugins/h223/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/h223/Makefile.am 2006-12-14 14:47:13.762227000 +0100
++++ wireshark-0.99.4/plugins/h223/Makefile.am 2006-12-14 14:49:18.352227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/h223/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/h223/Makefile.in 2006-12-14 14:47:13.792227000 +0100
++++ wireshark-0.99.4/plugins/h223/Makefile.in 2006-12-14 14:49:18.362227000 +0100
+@@ -373,7 +373,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = h223
+Index: wireshark-0.99.4/plugins/irda/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/irda/Makefile.am 2006-12-14 14:47:13.812227000 +0100
++++ wireshark-0.99.4/plugins/irda/Makefile.am 2006-12-14 14:49:18.362227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/irda/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/irda/Makefile.in 2006-12-14 14:47:13.842227000 +0100
++++ wireshark-0.99.4/plugins/irda/Makefile.in 2006-12-14 14:49:18.372227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = irda
+Index: wireshark-0.99.4/plugins/lwres/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/lwres/Makefile.am 2006-12-14 14:47:13.862227000 +0100
++++ wireshark-0.99.4/plugins/lwres/Makefile.am 2006-12-14 14:49:18.382227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/lwres/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/lwres/Makefile.in 2006-12-14 14:47:13.892227000 +0100
++++ wireshark-0.99.4/plugins/lwres/Makefile.in 2006-12-14 14:49:19.432227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = lwres
+Index: wireshark-0.99.4/plugins/megaco/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/megaco/Makefile.am 2006-12-14 14:47:13.942227000 +0100
++++ wireshark-0.99.4/plugins/megaco/Makefile.am 2006-12-14 14:49:19.442227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/megaco/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/megaco/Makefile.in 2006-12-14 14:47:13.972227000 +0100
++++ wireshark-0.99.4/plugins/megaco/Makefile.in 2006-12-14 14:49:19.452227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = megaco
+Index: wireshark-0.99.4/plugins/mgcp/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/mgcp/Makefile.am 2006-12-14 14:47:13.992227000 +0100
++++ wireshark-0.99.4/plugins/mgcp/Makefile.am 2006-12-14 14:49:19.462227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/mgcp/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/mgcp/Makefile.in 2006-12-14 14:47:14.022227000 +0100
++++ wireshark-0.99.4/plugins/mgcp/Makefile.in 2006-12-14 14:49:19.462227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = mgcp
+Index: wireshark-0.99.4/plugins/opsi/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/opsi/Makefile.am 2006-12-14 14:47:14.042227000 +0100
++++ wireshark-0.99.4/plugins/opsi/Makefile.am 2006-12-14 14:49:19.472227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/opsi/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/opsi/Makefile.in 2006-12-14 14:47:14.072227000 +0100
++++ wireshark-0.99.4/plugins/opsi/Makefile.in 2006-12-14 14:49:19.482227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = opsi
+Index: wireshark-0.99.4/plugins/pcli/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/pcli/Makefile.am 2006-12-14 14:47:14.102227000 +0100
++++ wireshark-0.99.4/plugins/pcli/Makefile.am 2006-12-14 14:49:19.492227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/pcli/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/pcli/Makefile.in 2006-12-14 14:47:14.122227000 +0100
++++ wireshark-0.99.4/plugins/pcli/Makefile.in 2006-12-14 14:49:19.492227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = pcli
+Index: wireshark-0.99.4/plugins/profinet/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/profinet/Makefile.am 2006-12-14 14:47:14.152227000 +0100
++++ wireshark-0.99.4/plugins/profinet/Makefile.am 2006-12-14 14:49:19.502227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/profinet/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/profinet/Makefile.in 2006-12-14 14:47:14.182227000 +0100
++++ wireshark-0.99.4/plugins/profinet/Makefile.in 2006-12-14 14:49:19.512227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = profinet
+Index: wireshark-0.99.4/plugins/rlm/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/rlm/Makefile.am 2006-12-14 14:47:14.202227000 +0100
++++ wireshark-0.99.4/plugins/rlm/Makefile.am 2006-12-14 14:49:19.522227000 +0100
+@@ -23,7 +23,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/rlm/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/rlm/Makefile.in 2006-12-14 14:47:14.232227000 +0100
++++ wireshark-0.99.4/plugins/rlm/Makefile.in 2006-12-14 14:49:19.542227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = rlm
+Index: wireshark-0.99.4/plugins/rtnet/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/rtnet/Makefile.am 2006-12-14 14:47:14.252227000 +0100
++++ wireshark-0.99.4/plugins/rtnet/Makefile.am 2006-12-14 14:49:19.562227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/rtnet/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/rtnet/Makefile.in 2006-12-14 14:47:14.282227000 +0100
++++ wireshark-0.99.4/plugins/rtnet/Makefile.in 2006-12-14 14:49:19.572227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = rtnet
+Index: wireshark-0.99.4/plugins/rudp/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/rudp/Makefile.am 2006-12-14 14:47:14.312227000 +0100
++++ wireshark-0.99.4/plugins/rudp/Makefile.am 2006-12-14 14:49:19.582227000 +0100
+@@ -23,7 +23,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/rudp/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/rudp/Makefile.in 2006-12-14 14:47:14.342227000 +0100
++++ wireshark-0.99.4/plugins/rudp/Makefile.in 2006-12-14 14:49:20.202227000 +0100
+@@ -371,7 +371,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = rudp
+Index: wireshark-0.99.4/plugins/sbus/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/sbus/Makefile.am 2006-12-14 14:47:14.362227000 +0100
++++ wireshark-0.99.4/plugins/sbus/Makefile.am 2006-12-14 14:49:20.212227000 +0100
+@@ -21,7 +21,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/sbus/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/sbus/Makefile.in 2006-12-14 14:47:14.392227000 +0100
++++ wireshark-0.99.4/plugins/sbus/Makefile.in 2006-12-14 14:49:20.222227000 +0100
+@@ -369,7 +369,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = sbus
+Index: wireshark-0.99.4/plugins/v5ua/Makefile.am
+===================================================================
+--- wireshark-0.99.4.orig/plugins/v5ua/Makefile.am 2006-12-14 14:47:14.442227000 +0100
++++ wireshark-0.99.4/plugins/v5ua/Makefile.am 2006-12-14 14:49:20.232227000 +0100
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ include Makefile.common
+
+Index: wireshark-0.99.4/plugins/v5ua/Makefile.in
+===================================================================
+--- wireshark-0.99.4.orig/plugins/v5ua/Makefile.in 2006-12-14 14:47:14.472227000 +0100
++++ wireshark-0.99.4/plugins/v5ua/Makefile.in 2006-12-14 14:49:20.232227000 +0100
+@@ -370,7 +370,7 @@
+ wireshark_bin = @wireshark_bin@
+ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ # the name of the plugin
+ PLUGIN_NAME = v5ua
diff --git a/recipes/wireshark/files/use-our-lemon.patch b/recipes/wireshark/files/use-our-lemon.patch
new file mode 100644
index 0000000000..c2850807db
--- /dev/null
+++ b/recipes/wireshark/files/use-our-lemon.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ethereal-0.99.0/tools/Makefile.am~use-our-lemon
++++ ethereal-0.99.0/tools/Makefile.am
+@@ -21,7 +21,7 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-SUBDIRS = lemon
++SUBDIRS =
+
+ PIDL_FILES= \
+ pidl/MANIFEST \
diff --git a/recipes/wireshark/tshark_0.99.4.bb b/recipes/wireshark/tshark_0.99.4.bb
new file mode 100644
index 0000000000..b7fe2afeed
--- /dev/null
+++ b/recipes/wireshark/tshark_0.99.4.bb
@@ -0,0 +1,5 @@
+DESCRIPTION = "tshark is the text based verion of wireshark - a popular network protocol analyzer"
+require wireshark.inc
+
+EXTRA_OECONF = "--disable-wireshark --with-net-snmp=${STAGING_DIR_HOST}${layout_bindir}/net-snmp-config"
+
diff --git a/recipes/wireshark/wireshark.inc b/recipes/wireshark/wireshark.inc
new file mode 100644
index 0000000000..13715ea273
--- /dev/null
+++ b/recipes/wireshark/wireshark.inc
@@ -0,0 +1,20 @@
+HOMEPAGE = "http://www.wireshark.org"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
+ file://use-our-lemon.patch;patch=1 \
+ file://acinclude-net-snmp-fix.patch;patch=1 \
+ file://libtool-fix.patch;patch=1 \
+ file://no-host-includes.patch;patch=1"
+
+S=${WORKDIR}/wireshark-${PV}
+
+inherit autotools
+
+do_compile_prepend() {
+ ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
+ oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
+}
+
diff --git a/recipes/wireshark/wireshark_0.99.4.bb b/recipes/wireshark/wireshark_0.99.4.bb
new file mode 100644
index 0000000000..f4c90fce48
--- /dev/null
+++ b/recipes/wireshark/wireshark_0.99.4.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Wireshark is the world's most popular network protocol analyzer"
+require wireshark.inc
+DEPENDS += "gtk+"
+
+PR = "r1"
+
+
+FILES_${PN}-dbg += "${libdir}/wireshark/plugins/${PV}/.debug"
+
+
diff --git a/recipes/wireshark/wireshark_1.0.5.bb b/recipes/wireshark/wireshark_1.0.5.bb
new file mode 100644
index 0000000000..aa8e66c2f4
--- /dev/null
+++ b/recipes/wireshark/wireshark_1.0.5.bb
@@ -0,0 +1,70 @@
+DESCRIPTION = "wireshark - a popular network protocol analyzer"
+HOMEPAGE = "http://www.wireshark.org"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 libsmi gtk+"
+EXTRA_OECONF = "--disable-usrlocal --with-pcap=${STAGING_DIR_HOST}${layout_prefix} \
+ --with-libsmi=${STAGING_DIR_HOST}${layout_prefix} --enable-tshark --enable-wireshark"
+
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
+ file://ieee80215.4.patch;patch=1"
+
+ARM_INSTRUCTION_SET = "arm"
+
+PACKAGES += "libwireshark1-dev libwireshark1 libwireshark1-dbg"
+FILES_libwireshark1 = "${libdir}/*.so*"
+FILES_libwireshark1-dev += "${libdir}/*.la ${libdir}/*.a ${libdir}/*.so ${includedir}"
+FILES_libwireshark1-dbg += "${libdir}/.debug"
+LEAD_SONAME_libwireshark1 = "libwireshark.so.0"
+
+PACKAGES += "${PN}-wireshark ${PN}-wireshark-dbg ${PN}-tshark ${PN}-tshark-dbg"
+FILES_${PN}-wireshark = "${bindir}/wireshark"
+FILES_${PN}-wireshark-dbg = "${bindir}/.debug/wireshark"
+FILES_${PN}-tshark = "${bindir}/tshark"
+FILES_${PN}-tshark-dbg = "${bindir}/.debug/tshark"
+RDEPENDS_${PN}-tshark += "libsmi-mibs libsmi-pibs ${PN}-data"
+RDEPENDS_${PN}-wireshark += "libsmi-mibs libsmi-pibs ${PN}-data"
+RCONFLICTS_${PN}-tshark = "tshark wireshark (<1.0.5)"
+RREPLACES_${PN}-tshark = "tshark wireshark (<1.0.5)"
+RCONFLICTS_${PN}-wireshark = "tshark wireshark (<1.0.5)"
+RREPLACES_${PN}-wireshark = "tshark wireshark (<1.0.5)"
+
+PACKAGES += "${PN}-plugins-dbg ${PN}-plugins"
+FILES_${PN}-plugins = "${libdir}/wireshark/plugins/${PV}/*.so ${libdir}/wireshark/plugins/${PV}/*.la"
+FILES_${PN}-plugins-dbg += "${libdir}/wireshark/plugins/${PV}/.debug"
+
+PACKAGES += "${PN}-data"
+FILES_${PN}-data = "${datadir}/wireshark"
+
+PACKAGES += "${PN}-utils ${PN}-utils-dbg"
+FILES_${PN}-utils = "${bindir}/text2pcap ${bindir}/dumpcap \
+ ${bindir}/rawshark ${bindir}/editcap \
+ ${bindir}/mergecap ${bindir}/idl2wrs \
+ ${bindir}/dftest ${bindir}/capinfos \
+ ${bindir}/randpkt"
+FILES_${PN}-utils-dbg = "${bindir}/.debug"
+
+FILES_${PN} = ""
+FILES_${PN}-dev = ""
+FILES_${PN}-dbg = ""
+ALLOW_EMPTY_${PN} = "1"
+RDEPENDS_${PN} = "${PN}-tshark ${PN}-wireshark ${PN}-plugins ${PN}-data"
+RCONFLICTS_${PN} = "tshark wireshark (<1.0.5)"
+RREPLACES_${PN} = "tshark wireshark (<1.0.5)"
+
+inherit autotools
+
+do_compile_prepend() {
+ find . -type f -name Makefile \
+ -exec sed -e 's@-I/usr/include @@g' \
+ -e 's@-I$(includedir)@@g' \
+ -e 's@-I/usr/local/include @@g' \
+ -e "s@-I${includedir} @@g" -i '{}' ';'
+
+ ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
+ oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" \
+ CC_FOR_BUILD="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
+}
+