aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wireshark
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-02-28 22:28:41 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-02 00:25:23 +0100
commita68d07365b49d352b775eef410026eccfc71029b (patch)
tree29fa0588378e9db61fe58a8cf3670b7eb0afd5a6 /recipes/wireshark
parent8f81a0fcffb7012e16fd160f56a69b0fcddde6bb (diff)
downloadopenembedded-a68d07365b49d352b775eef410026eccfc71029b.tar.gz
wireshark: Upgrade from 1.0.5 to 1.2.6
Update the ieee80215.patch. The original commit message is so weak it is not saying why the wpan_nofcs variant is to be used. I'm respecting the original patch author here but it would be better to have nice commit messages. My feeling tells me that we should drop this patch as there is no indication why this patch is a good idea.
Diffstat (limited to 'recipes/wireshark')
-rw-r--r--recipes/wireshark/files/fix-configure.patch72
-rw-r--r--recipes/wireshark/files/ieee80215.4.patch20
-rw-r--r--recipes/wireshark/wireshark_1.2.6.bb (renamed from recipes/wireshark/wireshark_1.0.5.bb)10
3 files changed, 90 insertions, 12 deletions
diff --git a/recipes/wireshark/files/fix-configure.patch b/recipes/wireshark/files/fix-configure.patch
new file mode 100644
index 0000000000..860edcc832
--- /dev/null
+++ b/recipes/wireshark/files/fix-configure.patch
@@ -0,0 +1,72 @@
+* Make sure to not include -I/usr/include and such
+* Claim that our inet_pton is working...
+
+Index: wireshark-1.2.6/acinclude.m4
+===================================================================
+--- wireshark-1.2.6.orig/acinclude.m4 2010-01-27 17:12:51.000000000 +0100
++++ wireshark-1.2.6/acinclude.m4 2010-02-28 23:46:12.000000000 +0100
+@@ -343,9 +343,9 @@
+ #
+ AC_MSG_CHECKING(for extraneous pcap header directories)
+ found_pcap_dir=""
+- pcap_dir_list="/usr/include/pcap $prefix/include/pcap $prefix/include"
++ pcap_dir_list="$prefix/include/pcap $prefix/include"
+ if test "x$ac_cv_enable_usr_local" = "xyes" ; then
+- pcap_dir_list="$pcap_dir_list /usr/local/include/pcap"
++ pcap_dir_list="$pcap_dir_list"
+ fi
+ for pcap_dir in $pcap_dir_list
+ do
+Index: wireshark-1.2.6/configure.in
+===================================================================
+--- wireshark-1.2.6.orig/configure.in 2010-01-27 17:12:50.000000000 +0100
++++ wireshark-1.2.6/configure.in 2010-03-01 00:28:21.000000000 +0100
+@@ -451,22 +451,22 @@
+ #
+ if test "x$prefix" != "x" ; then
+ AC_MSG_CHECKING(whether to use $prefix for headers and libraries)
+- if test -d $prefix/include ; then
+- AC_MSG_RESULT(yes)
+- #
+- # Arrange that we search for header files in "$prefix/include", as
+- # various packages we use may have been installed under "$prefix/include".
+- #
+- CFLAGS="$CFLAGS -I$prefix/include"
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"
+-
+- #
+- # Arrange that we search for libraries in "$prefix/lib".
+- #
+- AC_WIRESHARK_ADD_DASH_L(LDFLAGS, $prefix/lib)
+- else
++ #if test -d $prefix/include ; then
++ # AC_MSG_RESULT(yes)
++ # #
++ # # Arrange that we search for header files in "$prefix/include", as
++ # # various packages we use may have been installed under "$prefix/include".
++ # #
++ # CFLAGS="$CFLAGS -I$prefix/include"
++ # CPPFLAGS="$CPPFLAGS -I$prefix/include"
++ #
++ # #
++ # # Arrange that we search for libraries in "$prefix/lib".
++ # #
++ # AC_WIRESHARK_ADD_DASH_L(LDFLAGS, $prefix/lib)
++ #else
+ AC_MSG_RESULT(no)
+- fi
++ #fi
+ fi
+
+ dnl Look in /usr/local for header files and libraries ?
+@@ -1469,8 +1469,8 @@
+ #endif
+ }], [AC_MSG_RESULT(ok);
+ have_inet_pton=yes], [AC_MSG_RESULT(broken);
+-have_inet_pton=no], [AC_MSG_RESULT(cross compiling, assume it is broken);
+-have_inet_pton=no])],
++have_inet_pton=no], [AC_MSG_RESULT(cross compiling, assume it is broken... no here);
++have_inet_pton=yes])],
+ have_inet_pton=no)
+ if test "$have_inet_pton" = no; then
+ INET_PTON_C="inet_pton.c"
diff --git a/recipes/wireshark/files/ieee80215.4.patch b/recipes/wireshark/files/ieee80215.4.patch
index 8bcdd93d97..d17b60640f 100644
--- a/recipes/wireshark/files/ieee80215.4.patch
+++ b/recipes/wireshark/files/ieee80215.4.patch
@@ -1,9 +1,13 @@
---- wireshark-1.0.5.orig/epan/dissectors/packet-ieee802154.c
-+++ wireshark-1.0.5/epan/dissectors/packet-ieee802154.c
-@@ -1696,7 +1696,7 @@
- dissector_handle_t ieee802154_handle;
+Index: wireshark-1.2.6/epan/dissectors/packet-ieee802154.c
+===================================================================
+--- wireshark-1.2.6.orig/epan/dissectors/packet-ieee802154.c 2010-01-27 17:12:34.000000000 +0100
++++ wireshark-1.2.6/epan/dissectors/packet-ieee802154.c 2010-02-28 22:25:50.000000000 +0100
+@@ -1821,7 +1821,7 @@
+
+ if (!prefs_initialized){
+ /* Get the dissector handles. */
+- ieee802154_handle = find_dissector("wpan");
++ ieee802154_handle = find_dissector("wpan_nofcs");
+ ieee802154_nonask_phy_handle = find_dissector("wpan-nonask-phy");
+ data_handle = find_dissector("data");
- /* Get the dissector handles. */
-- ieee802154_handle = find_dissector("wpan");
-+ ieee802154_handle = find_dissector("wpan_nofcs");
- data_handle = find_dissector("data");
diff --git a/recipes/wireshark/wireshark_1.0.5.bb b/recipes/wireshark/wireshark_1.2.6.bb
index aa8e66c2f4..1af48e8577 100644
--- a/recipes/wireshark/wireshark_1.0.5.bb
+++ b/recipes/wireshark/wireshark_1.2.6.bb
@@ -3,13 +3,16 @@ HOMEPAGE = "http://www.wireshark.org"
SECTION = "network"
LICENSE = "GPL"
DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 libsmi gtk+"
-EXTRA_OECONF = "--disable-usrlocal --with-pcap=${STAGING_DIR_HOST}${layout_prefix} \
+EXTRA_OECONF = "--enable-usr-local=no --with-pcap=${STAGING_DIR_HOST}${layout_prefix} \
--with-libsmi=${STAGING_DIR_HOST}${layout_prefix} --enable-tshark --enable-wireshark"
PR = "r5"
-SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
- file://ieee80215.4.patch;patch=1"
+SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2;name=src \
+ file://ieee80215.4.patch;patch=1 \
+ file://fix-configure.patch;patch=1 "
+SRC_URI[src.md5sum] = "f3e0917ed393366bbf96c53b58cb0931"
+SRC_URI[src.sha256sum]= "72c8178dd0614d963173d667d5ecb39bc7102453ea09da7ef3302daee7733f3c"
ARM_INSTRUCTION_SET = "arm"
@@ -63,7 +66,6 @@ do_compile_prepend() {
-e 's@-I/usr/local/include @@g' \
-e "s@-I${includedir} @@g" -i '{}' ';'
- ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" \
CC_FOR_BUILD="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
}