aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wolf3d
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wolf3d
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wolf3d')
-rw-r--r--recipes/wolf3d/wolf4sdl_1.6.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/wolf3d/wolf4sdl_1.6.bb b/recipes/wolf3d/wolf4sdl_1.6.bb
new file mode 100644
index 0000000000..2e3483b164
--- /dev/null
+++ b/recipes/wolf3d/wolf4sdl_1.6.bb
@@ -0,0 +1,17 @@
+LICENSE = "Various"
+DESCRIPTION = "Wolfenstein3d game engine"
+DEPENDS = "virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://www.stud.uni-karlsruhe.de/~uvaue/chaos/bins/Wolf4SDL-${PV}-src.zip"
+
+S = "${WORKDIR}/Wolf4SDL-1.6-src"
+
+TARGET_CFLAGS_append = " -lSDL -lSDL_mixer -I${STAGING_INCDIR} -I${STAGING_INCDIR}/SDL"
+
+do_compile() {
+ oe_runmake -e Q= PREFIX=${prefix}
+}
+
+do_install() {
+ oe_runmake -e Q= PREFIX=${D}/${prefix} install
+}