aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wt/wt3-3.1.0a
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-12 19:39:15 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-12 19:39:15 +0100
commit6adbcf3963b0d9784442c5b7aa77bf0b88635500 (patch)
tree269c448195e0ccc01580d393bb064298ba2006e2 /recipes/wt/wt3-3.1.0a
parent3e5ac9a9cbeb39714fbb9d25f8d1d3da27c6ff43 (diff)
downloadopenembedded-6adbcf3963b0d9784442c5b7aa77bf0b88635500.tar.gz
wt3: added recipe for 3.1.0a
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wt/wt3-3.1.0a')
-rw-r--r--recipes/wt/wt3-3.1.0a/noqt.patch19
-rw-r--r--recipes/wt/wt3-3.1.0a/wgooglemap.patch17
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/wt/wt3-3.1.0a/noqt.patch b/recipes/wt/wt3-3.1.0a/noqt.patch
new file mode 100644
index 0000000000..48231246d3
--- /dev/null
+++ b/recipes/wt/wt3-3.1.0a/noqt.patch
@@ -0,0 +1,19 @@
+Index: wt-3.0.0/CMakeLists.txt
+===================================================================
+--- wt-3.0.0.orig/CMakeLists.txt 2009-11-12 18:50:12.087842114 +0100
++++ wt-3.0.0/CMakeLists.txt 2009-11-12 18:50:42.023261611 +0100
+@@ -111,10 +111,10 @@
+ INCLUDE(cmake/WtFindSsl.txt)
+ INCLUDE(cmake/WtFindMysqlpp.txt)
+
+-FIND_PACKAGE(Qt4)
+-IF(QT_FOUND)
+- INCLUDE(${QT_USE_FILE})
+-ENDIF(QT_FOUND)
++#FIND_PACKAGE(Qt4)
++#IF(QT_FOUND)
++# INCLUDE(${QT_USE_FILE})
++#ENDIF(QT_FOUND)
+
+ # Boost is used nearly everywhere, so we can put these here
+ INCLUDE_DIRECTORIES(${BOOST_INCLUDE_DIRS})
diff --git a/recipes/wt/wt3-3.1.0a/wgooglemap.patch b/recipes/wt/wt3-3.1.0a/wgooglemap.patch
new file mode 100644
index 0000000000..6827afbbe7
--- /dev/null
+++ b/recipes/wt/wt3-3.1.0a/wgooglemap.patch
@@ -0,0 +1,17 @@
+Index: wt-3.0.0/src/Wt/WGoogleMap.C
+===================================================================
+--- wt-3.0.0.orig/src/Wt/WGoogleMap.C 2009-09-01 17:46:54.000000000 +0200
++++ wt-3.0.0/src/Wt/WGoogleMap.C 2009-11-12 16:23:39.614976154 +0100
+@@ -26,6 +26,12 @@
+ using std::min;
+ using std::max;
+
++#if not defined(_GLIBCXX_HAVE__SINL) && not defined(acosl)
++#define cosl cos
++#define acosl acos
++#define sinl sin
++#endif
++
+ #ifndef M_PI
+ #define M_PI 3.14159265358979323846
+ #endif