aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wt/wt3_2.99.0.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-12 19:09:03 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-12 19:22:48 +0100
commitc29c0219c02010493d241113f8c9718eee6fc269 (patch)
tree65e8c287ee0f8dbb8d244e58edb3633d4ac0f1ca /recipes/wt/wt3_2.99.0.bb
parent58b64b531900ef438a2d4b90cc1c10550d30862b (diff)
downloadopenembedded-c29c0219c02010493d241113f8c9718eee6fc269.tar.gz
wt3: update to version 3.0.0
* spilt up with .inc-file and switch to INC_PR * disable qt explicit in CMakeLists.txt
Diffstat (limited to 'recipes/wt/wt3_2.99.0.bb')
-rw-r--r--recipes/wt/wt3_2.99.0.bb41
1 files changed, 5 insertions, 36 deletions
diff --git a/recipes/wt/wt3_2.99.0.bb b/recipes/wt/wt3_2.99.0.bb
index fea28494ca..ccfbc31dd8 100644
--- a/recipes/wt/wt3_2.99.0.bb
+++ b/recipes/wt/wt3_2.99.0.bb
@@ -1,41 +1,10 @@
-DESCRIPTION = "A C++ Web Toolkit"
-PRIORITY = "optional"
-SECTION = "devel"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.webtoolkit.eu/wt"
-DEPENDS = "boost zlib openssl"
-PR = "r0"
+require wt3.inc
-# package wt3 is for wt 2.99 and wt 3.*
-# the api of these versions is incompatible with 2.*
+PR = "${INC_PR}.1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
- file://src.patch;patch=1 \
- file://ext.patch;patch=1 \
- file://wgooglemap.patch;patch=1"
-
-CXXFLAGS += "-Dsinl=sin -Dcosl=cos -Dasinl=asin"
-
-FILES_${PN} += "${datadir}/Wt"
-FILES_${PN}-dev += "${datadir}/cmake-2.*"
-
-S = "${WORKDIR}/wt-${PV}"
-
-inherit cmake
-
-STAGE_TEMP = "${WORKDIR}/temp-staging"
+SRC_URI += "file://src.patch;patch=1 \
+ "
do_configure_append() {
- ${BUILD_CXX} ${BUILD_CXXFLAGS} -o src/filetostring src/web/skeleton/FileToString.C
-}
-
-do_stage() {
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake DESTDIR="${STAGE_TEMP}" install
- cp -pPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
- cp -pPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
- cp -pPR ${STAGE_TEMP}/${datadir}/cmake-2.* ${STAGING_DATADIR}
- rm -rf ${STAGE_TEMP}
+ ${BUILD_CXX} ${BUILD_CXXFLAGS} -o src/filetostring src/web/skeleton/FileToString.C
}
-