aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wt
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/wt
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/wt')
-rw-r--r--recipes/wt/wt3.inc4
-rw-r--r--recipes/wt/wt3_2.99.0.bb2
-rw-r--r--recipes/wt/wt3_3.0.0.bb2
-rw-r--r--recipes/wt/wt3_3.1.0a.bb2
-rw-r--r--recipes/wt/wt_2.2.0.bb2
-rw-r--r--recipes/wt/wt_2.2.3.bb2
6 files changed, 7 insertions, 7 deletions
diff --git a/recipes/wt/wt3.inc b/recipes/wt/wt3.inc
index e8a54e11f2..9cda6aee7f 100644
--- a/recipes/wt/wt3.inc
+++ b/recipes/wt/wt3.inc
@@ -11,8 +11,8 @@ INC_PR = "r1"
# the api of these versions is incompatible with 2.*
SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz;name=tarball \
- file://ext.patch;apply=yes \
- file://wgooglemap.patch;apply=yes"
+ file://ext.patch \
+ file://wgooglemap.patch"
CXXFLAGS += "-Dsinl=sin -Dcosl=cos -Dasinl=asin"
diff --git a/recipes/wt/wt3_2.99.0.bb b/recipes/wt/wt3_2.99.0.bb
index 07c75926c7..0f4e7a6cb5 100644
--- a/recipes/wt/wt3_2.99.0.bb
+++ b/recipes/wt/wt3_2.99.0.bb
@@ -2,7 +2,7 @@ require wt3.inc
PR = "${INC_PR}.1"
-SRC_URI += "file://src.patch;apply=yes \
+SRC_URI += "file://src.patch \
"
do_configure_append() {
diff --git a/recipes/wt/wt3_3.0.0.bb b/recipes/wt/wt3_3.0.0.bb
index 9d15341681..50027d2bd3 100644
--- a/recipes/wt/wt3_3.0.0.bb
+++ b/recipes/wt/wt3_3.0.0.bb
@@ -2,7 +2,7 @@ require wt3.inc
PR = "${INC_PR}.2"
-SRC_URI += "file://noqt.patch;apply=yes"
+SRC_URI += "file://noqt.patch"
SRC_URI[tarball.md5sum] = "ba03acf8089dff38e106661aa1ecdcb9"
SRC_URI[tarball.sha256sum] = "d439e96d2de8c22f682b5d3d5894974d50b3a36057a002bda1ad1cb858cd3b28"
diff --git a/recipes/wt/wt3_3.1.0a.bb b/recipes/wt/wt3_3.1.0a.bb
index ecabbaa896..43a113226e 100644
--- a/recipes/wt/wt3_3.1.0a.bb
+++ b/recipes/wt/wt3_3.1.0a.bb
@@ -2,7 +2,7 @@ require wt3.inc
PR = "${INC_PR}.0"
-SRC_URI += "file://noqt.patch;apply=yes"
+SRC_URI += "file://noqt.patch"
SRC_URI[tarball.md5sum] = "9b2f4abc2e50d1fa15648834f5830d87"
SRC_URI[tarball.sha256sum] = "97c8ddcd690381c4cd787b0099e753954c11016321fa991268c92276351fbc4c"
diff --git a/recipes/wt/wt_2.2.0.bb b/recipes/wt/wt_2.2.0.bb
index b4a49e48df..3fb2d18f6f 100644
--- a/recipes/wt/wt_2.2.0.bb
+++ b/recipes/wt/wt_2.2.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "boost"
PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
- file://cmakelist.patch;apply=yes"
+ file://cmakelist.patch"
FILES_${PN} += "${datadir}/Wt"
FILES_${PN}-dev += "${datadir}/cmake-2.*"
diff --git a/recipes/wt/wt_2.2.3.bb b/recipes/wt/wt_2.2.3.bb
index 3bbfe9b8ca..c25864ae29 100644
--- a/recipes/wt/wt_2.2.3.bb
+++ b/recipes/wt/wt_2.2.3.bb
@@ -7,7 +7,7 @@ DEPENDS = "boost zlib openssl"
PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
- file://cmakelist.patch;apply=yes"
+ file://cmakelist.patch"
FILES_${PN} += "${datadir}/Wt"
FILES_${PN}-dev += "${datadir}/cmake-2.*"