aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wt')
-rw-r--r--recipes/wt/files/cmakelist.patch26
-rw-r--r--recipes/wt/wt3-2.99.0/ext.patch7
-rw-r--r--recipes/wt/wt3-2.99.0/src.patch18
-rw-r--r--recipes/wt/wt3-2.99.0/wgooglemap.patch15
-rw-r--r--recipes/wt/wt3_2.99.0.bb41
-rw-r--r--recipes/wt/wt_2.2.0.bb31
-rw-r--r--recipes/wt/wt_2.2.3.bb32
7 files changed, 170 insertions, 0 deletions
diff --git a/recipes/wt/files/cmakelist.patch b/recipes/wt/files/cmakelist.patch
new file mode 100644
index 0000000000..9e1eab1835
--- /dev/null
+++ b/recipes/wt/files/cmakelist.patch
@@ -0,0 +1,26 @@
+diff -urN wt-2.2.0.orig/src/CMakeLists.txt wt-2.2.0/src/CMakeLists.txt
+--- wt-2.2.0.orig/src/CMakeLists.txt 2008-09-10 15:58:34.000000000 +0200
++++ wt-2.2.0/src/CMakeLists.txt 2008-10-18 11:12:20.000000000 +0200
+@@ -33,8 +33,12 @@
+
+ LINK_DIRECTORIES(${BOOST_LIB_DIRS})
+
+-ADD_EXECUTABLE(filetostring web/skeleton/FileToString.C)
+-GET_TARGET_PROPERTY(FILE_TO_STRING_EXE filetostring LOCATION)
++IF(CMAKE_CROSSCOMPILING)
++ ADD_EXECUTABLE(filetostring web/skeleton/FileToString.C)
++ GET_TARGET_PROPERTY(FILE_TO_STRING_EXE filetostring LOCATION)
++ELSE(CMAKE_CROSSCOMPILING)
++ SET(FILE_TO_STRING_EXE ${CMAKE_CURRENT_SOURCE_DIR}/filetostring)
++ENDIF(CMAKE_CROSSCOMPILING)
+
+ MACRO (FILE_TO_STRING infile outfile var)
+ ADD_CUSTOM_COMMAND(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${outfile}
+diff -urN wt-2.2.0.orig/src/Wt/Ext/CMakeLists.txt wt-2.2.0/src/Wt/Ext/CMakeLists.txt
+--- wt-2.2.0.orig/src/Wt/Ext/CMakeLists.txt 2008-07-15 08:25:54.000000000 +0200
++++ wt-2.2.0/src/Wt/Ext/CMakeLists.txt 2008-10-17 22:37:38.000000000 +0200
+@@ -1,2 +1,3 @@
+-INSTALL_FILES(/include/Wt/Ext "...+[^Ch~]$")
++# avoid CMake* getting included
++INSTALL_FILES(/include/Wt/Ext "^[A-Z][a-z].*[^Ch~]$")
+ INSTALL_FILES(/include/Wt/Ext ExtDllDefs.h)
diff --git a/recipes/wt/wt3-2.99.0/ext.patch b/recipes/wt/wt3-2.99.0/ext.patch
new file mode 100644
index 0000000000..89246ebbf6
--- /dev/null
+++ b/recipes/wt/wt3-2.99.0/ext.patch
@@ -0,0 +1,7 @@
+--- wt-2.99.0/src/Wt/Ext/CMakeLists.txt 2009-03-11 21:30:10.000000000 +0100
++++ wt-2.99.0/src/Wt/Ext/CMakeLists.txt.new 2009-03-11 21:31:33.000000000 +0100
+@@ -1,2 +1,3 @@
+-INSTALL_FILES(/include/Wt/Ext "...+[^Ch~]$")
++# avoid CMake* getting included
++INSTALL_FILES(/include/Wt/Ext "^[A-Z][a-z].*[^Ch~]$")
+ INSTALL_FILES(/include/Wt/Ext ExtDllDefs.h)
diff --git a/recipes/wt/wt3-2.99.0/src.patch b/recipes/wt/wt3-2.99.0/src.patch
new file mode 100644
index 0000000000..a3ac249af0
--- /dev/null
+++ b/recipes/wt/wt3-2.99.0/src.patch
@@ -0,0 +1,18 @@
+--- wt-2.99.0/src/CMakeLists.txt 2009-03-06 16:36:30.000000000 +0100
++++ wt-2.99.0/src/CMakeLists.txt.new 2009-03-11 21:39:06.000000000 +0100
+@@ -33,8 +33,13 @@
+
+ LINK_DIRECTORIES(${BOOST_LIB_DIRS})
+
+-ADD_EXECUTABLE(filetostring web/skeleton/FileToString.C)
+-GET_TARGET_PROPERTY(FILE_TO_STRING_EXE filetostring LOCATION)
++IF(CMAKE_CROSSCOMPILING)
++ ADD_EXECUTABLE(filetostring web/skeleton/FileToString.C)
++ GET_TARGET_PROPERTY(FILE_TO_STRING_EXE filetostring LOCATION)
++ELSE(CMAKE_CROSSCOMPILING)
++ SET(FILE_TO_STRING_EXE ${CMAKE_CURRENT_SOURCE_DIR}/filetostring)
++ENDIF(CMAKE_CROSSCOMPILING)
++
+
+ MACRO (FILE_TO_STRING infile outfile var)
+ ADD_CUSTOM_COMMAND(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${outfile}
diff --git a/recipes/wt/wt3-2.99.0/wgooglemap.patch b/recipes/wt/wt3-2.99.0/wgooglemap.patch
new file mode 100644
index 0000000000..071597fba6
--- /dev/null
+++ b/recipes/wt/wt3-2.99.0/wgooglemap.patch
@@ -0,0 +1,15 @@
+--- wt-2.99.0/src/Wt/WGoogleMap.C.orig 2009-03-12 09:52:56.000000000 +0100
++++ wt-2.99.0/src/Wt/WGoogleMap.C 2009-03-12 10:13:21.000000000 +0100
+@@ -18,6 +18,12 @@
+ #include <sstream>
+ #include <utility>
+ #include <iostream>
++
++#if not defined(_GLIBCXX_HAVE__SINL) && not defined(acosl)
++#define cosl cos
++#define acosl acos
++#define sinl sin
++#endif
+
+ using std::string;
+ using std::vector;
diff --git a/recipes/wt/wt3_2.99.0.bb b/recipes/wt/wt3_2.99.0.bb
new file mode 100644
index 0000000000..fea28494ca
--- /dev/null
+++ b/recipes/wt/wt3_2.99.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "A C++ Web Toolkit"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.webtoolkit.eu/wt"
+DEPENDS = "boost zlib openssl"
+PR = "r0"
+
+# package wt3 is for wt 2.99 and wt 3.*
+# the api of these versions is incompatible with 2.*
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
+ file://src.patch;patch=1 \
+ file://ext.patch;patch=1 \
+ file://wgooglemap.patch;patch=1"
+
+CXXFLAGS += "-Dsinl=sin -Dcosl=cos -Dasinl=asin"
+
+FILES_${PN} += "${datadir}/Wt"
+FILES_${PN}-dev += "${datadir}/cmake-2.*"
+
+S = "${WORKDIR}/wt-${PV}"
+
+inherit cmake
+
+STAGE_TEMP = "${WORKDIR}/temp-staging"
+
+do_configure_append() {
+ ${BUILD_CXX} ${BUILD_CXXFLAGS} -o src/filetostring src/web/skeleton/FileToString.C
+}
+
+do_stage() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ cp -pPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ cp -pPR ${STAGE_TEMP}/${datadir}/cmake-2.* ${STAGING_DATADIR}
+ rm -rf ${STAGE_TEMP}
+}
+
diff --git a/recipes/wt/wt_2.2.0.bb b/recipes/wt/wt_2.2.0.bb
new file mode 100644
index 0000000000..564d4b2552
--- /dev/null
+++ b/recipes/wt/wt_2.2.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A C++ Web Toolkit"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "GPL"
+DEPENDS = "boost"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
+ file://cmakelist.patch;patch=1"
+
+FILES_${PN} += "${datadir}/Wt"
+FILES_${PN}-dev += "${datadir}/cmake-2.*"
+
+inherit cmake
+
+STAGE_TEMP = "${WORKDIR}/temp-staging"
+
+do_configure_append() {
+ ${BUILD_CXX} ${BUILD_CXXFLAGS} -o src/filetostring src/web/skeleton/FileToString.C
+}
+
+do_stage() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ cp -pPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ cp -pPR ${STAGE_TEMP}/${datadir}/cmake-2.* ${STAGING_DATADIR}
+ rm -rf ${STAGE_TEMP}
+}
+
diff --git a/recipes/wt/wt_2.2.3.bb b/recipes/wt/wt_2.2.3.bb
new file mode 100644
index 0000000000..b9ab7580f8
--- /dev/null
+++ b/recipes/wt/wt_2.2.3.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A C++ Web Toolkit"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.webtoolkit.eu/wt"
+DEPENDS = "boost zlib openssl"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
+ file://cmakelist.patch;patch=1"
+
+FILES_${PN} += "${datadir}/Wt"
+FILES_${PN}-dev += "${datadir}/cmake-2.*"
+
+inherit cmake
+
+STAGE_TEMP = "${WORKDIR}/temp-staging"
+
+do_configure_append() {
+ ${BUILD_CXX} ${BUILD_CXXFLAGS} -o src/filetostring src/web/skeleton/FileToString.C
+}
+
+do_stage() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ cp -pPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ cp -pPR ${STAGE_TEMP}/${datadir}/cmake-2.* ${STAGING_DATADIR}
+ rm -rf ${STAGE_TEMP}
+}
+