aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wvstreams
diff options
context:
space:
mode:
authorThilo Fromm <t.fromm@dresearch.de>2010-09-27 23:34:36 +0000
committerSteffen Sledz <sledz@dresearch.de>2010-09-29 11:12:27 +0200
commitd318d0667d184aa2308652c4bb0887039fa98451 (patch)
treeb451bca50815b5467f5904b0afeaa355b5e5c2ff /recipes/wvstreams
parentda451d4d552488e6ce6dad0a7fa4815a9c29459d (diff)
downloadopenembedded-d318d0667d184aa2308652c4bb0887039fa98451.tar.gz
wvstreams-4.6: Remove dbus support (breaks build)
If wvstreams is configured with DBus support enabled (by not providing --without-dbus) the the build fails at link time as libdbus cannot be found: | ./CXX -c dbus/wvdbusconn | ./CXX -c dbus/wvdbusmarshal | ./CXX -c dbus/wvdbusmsg | ./CXX -c dbus/wvdbusserver | linking libwvdbus.so... | arm-angstrom-linux-gnueabi-g++: /libdbus-1.a: No such file or directory | make: *** [libwvdbus.so] Error 1 | FATAL: oe_runmake failed NOTE: Task failed: /SCRATCH/maniac/oe-merge-test/OE/tmp.6/work/armv5te-angstrom-linux-gnueabi/wvstreams-4.6-r0/temp/log.do_compile.6422 ERROR: TaskFailed event exception, aborting ERROR: Build of /home/maniac/work/HYP/oe/3way_merge/recipes/wvstreams/wvstreams_4.6.bb do_compile failed ERROR: Task 2024 (/home/maniac/work/HYP/oe/3way_merge/recipes/wvstreams/wvstreams_4.6.bb, do_compile) failed The root cause for this behaviour is in wvstreams' configure.ac; the weird dbus detection and library path handling breaks successive builds. This patch, however, does not fix the configure.ac file but disables DBus support for wvstreams at configure time. This at least fixes the broken build. Signed-off-by: Thilo Fromm <t.fromm@dresearch.de> Acked-by: Paul Menzel <paulepanter@users.sourceforge.net> Acked-by: Steffen Sledz <sledz@dresearch.de>
Diffstat (limited to 'recipes/wvstreams')
-rw-r--r--recipes/wvstreams/wvstreams_4.6.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/wvstreams/wvstreams_4.6.bb b/recipes/wvstreams/wvstreams_4.6.bb
index 91abc7ddc9..1c1126847f 100644
--- a/recipes/wvstreams/wvstreams_4.6.bb
+++ b/recipes/wvstreams/wvstreams_4.6.bb
@@ -3,6 +3,8 @@ LICENSE = "LGPL"
DESCRIPTION = "WvStreams is a network programming library in C++"
DEPENDS = "zlib openssl (>= 0.9.8)"
+PR = "r1"
+
SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
"
@@ -10,7 +12,8 @@ inherit autotools pkgconfig
LDFLAGS_append = " -Wl,-rpath-link,${TOOLCHAIN_PATH}/${TARGET_SYS}/lib"
-EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
+# dbus detection currently broken in configure.ac; remember to add "dbus (>= 1.2.14)" to DEPENDS when fixed
+EXTRA_OECONF = " --without-tcl --without-qt --without-pam --without-dbus"
PACKAGES_prepend = "libuniconf libuniconf-dbg "
PACKAGES_prepend = "uniconfd uniconfd-dbg "