aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wvstreams
diff options
context:
space:
mode:
authorKirtika Ruchandani <kirtibr@gmail.com>2009-08-07 20:32:18 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-07 20:32:18 -0700
commitedf9505ccc3f9cad77a5660ed60eb35b20bb9a2f (patch)
tree8662db77314f8a838897e6ccd140bee5d5aacbd9 /recipes/wvstreams
parent02772d7a0d41f1c7c0574692ac8cec8129ac0c99 (diff)
downloadopenembedded-edf9505ccc3f9cad77a5660ed60eb35b20bb9a2f.tar.gz
wvstreams_4.4.1.bb: Make it compilable with gcc 4.3
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/wvstreams')
-rw-r--r--recipes/wvstreams/files/dont-forget-header.patch13
-rw-r--r--recipes/wvstreams/files/gcc4.3.patch15
-rw-r--r--recipes/wvstreams/wvstreams_4.4.1.bb11
3 files changed, 36 insertions, 3 deletions
diff --git a/recipes/wvstreams/files/dont-forget-header.patch b/recipes/wvstreams/files/dont-forget-header.patch
new file mode 100644
index 0000000000..9befe49963
--- /dev/null
+++ b/recipes/wvstreams/files/dont-forget-header.patch
@@ -0,0 +1,13 @@
+Index: wvstreams-4.4.1/include/uniconfkey.h
+===================================================================
+--- wvstreams-4.4.1.orig/include/uniconfkey.h 2009-07-28 17:42:39.000000000 +0530
++++ wvstreams-4.4.1/include/uniconfkey.h 2009-07-28 17:42:55.000000000 +0530
+@@ -9,7 +9,7 @@
+
+ #include "wvstring.h"
+ #include "wvlinklist.h"
+-
++#include <limits.h>
+
+ // The Python headers try to #define ANY as void. If we're building Python
+ // wrappers, get rid of that.
diff --git a/recipes/wvstreams/files/gcc4.3.patch b/recipes/wvstreams/files/gcc4.3.patch
new file mode 100644
index 0000000000..f7315eeefb
--- /dev/null
+++ b/recipes/wvstreams/files/gcc4.3.patch
@@ -0,0 +1,15 @@
+Index: wvstreams-4.4.1/include/wvserialize.h
+===================================================================
+--- wvstreams-4.4.1.orig/include/wvserialize.h 2009-07-28 17:46:50.000000000 +0530
++++ wvstreams-4.4.1/include/wvserialize.h 2009-07-28 17:48:30.000000000 +0530
+@@ -348,8 +348,9 @@
+ * (zero) character. Serialized WvStrings are guaranteed not to contain nul
+ * except as the last character.
+ */
++/*No storage class allowed here as per gcc 4.3 specs*/
+ template <>
+-extern WvString _wv_deserialize<WvString>(WvBuf &buf);
++WvString _wv_deserialize<WvString>(WvBuf &buf);
+
+
+ /** Deserialize a WvBuf. */
diff --git a/recipes/wvstreams/wvstreams_4.4.1.bb b/recipes/wvstreams/wvstreams_4.4.1.bb
index 8cf1d1b5eb..6aeefc7502 100644
--- a/recipes/wvstreams/wvstreams_4.4.1.bb
+++ b/recipes/wvstreams/wvstreams_4.4.1.bb
@@ -1,12 +1,17 @@
HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
LICENSE = "LGPL"
DESCRIPTION = "WvStreams is a network programming library in C++"
-DEPENDS = "zlib openssl (>= 0.9.8)"
+#DEPENDS = "zlib openssl (>= 0.9.8)"
+DEPENDS = "zlib openssl"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
- file://build-fixes-and-sanity.patch;patch=1 "
+ file://build-fixes-and-sanity.patch;patch=1 \
+ file://dont-forget-header.patch;patch=1 \
+ file://gcc4.3.patch;patch=1 \
+ "
+
inherit autotools pkgconfig