aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xaos/xaos_3.2.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xaos/xaos_3.2.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xaos/xaos_3.2.3.bb')
-rw-r--r--recipes/xaos/xaos_3.2.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/xaos/xaos_3.2.3.bb b/recipes/xaos/xaos_3.2.3.bb
new file mode 100644
index 0000000000..22cedeb296
--- /dev/null
+++ b/recipes/xaos/xaos_3.2.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNU XaoS, a realtime fractal generator zoomer"
+HOMEPAGE = "http://wmi.math.u-szeged.hu/xaos/doku.php"
+SECTION = "graphics"
+LICENSE = "GPLv2"
+DEPENDS = "aalib libx11 zlib libpng"
+RDEPENDS += "libxxf86dga"
+PR = "r0"
+
+SRC_URI = "http://easynews.dl.sourceforge.net/sourceforge/xaos/XaoS-3.2.3.tar.gz \
+ file://fix-build.patch;patch=1 \
+ file://fix-aalib-configure.patch;patch=1"
+
+S = "${WORKDIR}/XaoS-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-nls"
+#--with-x --with-ncurses=${STAGING_INCDIR} --with-dga-driver=no --with-x11-driver=no --with-aa-driver=yes
+
+do_configure_prepend() {
+ sed -i 's~/usr/include~${STAGING_INCDIR}~' ${S}/configure.in
+ sed -i 's~/usr/local/include~${STAGING_INCDIR}~' ${S}/configure.in
+ sed -i 's~/usr/lib~${STAGING_LIBDIR}~' ${S}/configure.in
+ sed -i 's~/usr/local/lib~${STAGING_LIBDIR}~' ${S}/configure.in
+}
+
+FILES_${PN} = "${bindir} ${datadir}/XaoS/catalogs"
+
+CFLAGS = "-L${STAGING_LIBDIR}"