aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base/thunar_1.0.1.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-25 11:02:48 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-27 15:26:58 +0100
commit599bbb2eaff6f0827b04ab5b2665303a22ea072e (patch)
tree7690ca6aed080d1a4b8f816a1e300b8d3264b264 /recipes/xfce-base/thunar_1.0.1.bb
parent6de8a003f930bfade8502cf80617009a9c96c278 (diff)
downloadopenembedded-599bbb2eaff6f0827b04ab5b2665303a22ea072e.tar.gz
XFCE: Import all the 4.6.1 recipes (and a newer version of xfce-terminal).
Diffstat (limited to 'recipes/xfce-base/thunar_1.0.1.bb')
-rw-r--r--recipes/xfce-base/thunar_1.0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/xfce-base/thunar_1.0.1.bb b/recipes/xfce-base/thunar_1.0.1.bb
new file mode 100644
index 0000000000..96a494efc3
--- /dev/null
+++ b/recipes/xfce-base/thunar_1.0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "File manager for the Xfce Desktop Environment"
+HOMEPAGE="http://thunar.xfce.org"
+DEPENDS = "exo dbus-glib libexif xfce4-panel libice libsm gamin"
+RDEPENDS = "libxfcegui4 exo dbus-glib libexif xfce4-panel libice libsm gamin"
+RRECOMMENDS = "shared-mime-info"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce46
+
+XFCE_VERSION = "4.6.1"
+
+SRC_URI = "http://www.us.xfce.org/archive/xfce-${XFCE_VERSION}/src/Thunar-${PV}.tar.bz2"
+
+S = "${WORKDIR}/Thunar-${PV}/"
+
+EXTRA_OECONF += "--disable-dependency-tracking --enable-dbus"
+
+FILES_${PN} += "${libdir}/thunarx-1/*.so \
+ ${libdir}/thunarx-1/*.la \
+ ${datadir}/dbus-1 \
+ ${datadir}/thumbnailers \
+ ${datadir}/Thunar \
+ ${datadir}/xfce4"
+FILES_${PN}-dbg += "${libdir}/thunarx-1/.debug/ ${libexecdir}/xfce4/panel-plugins/.debug/"
+
+do_stage () {
+ autotools_stage_all
+}