aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base/xfce4-panel_4.6.4.bb
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2010-06-18 00:26:42 +0200
committerKhem Raj <raj.khem@gmail.com>2010-06-18 11:16:29 -0700
commit19bd6d851cdefbe6be0b9766980a7338fe6ff82d (patch)
treec1e9efe56443e15af236d8513e0301d16e231746 /recipes/xfce-base/xfce4-panel_4.6.4.bb
parent7565ef3e4a53f715f16bdf6237061bcb9d6da33b (diff)
downloadopenembedded-19bd6d851cdefbe6be0b9766980a7338fe6ff82d.tar.gz
xfce-base: Bump xfce recipes to version 4.6.2
Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/xfce-base/xfce4-panel_4.6.4.bb')
-rw-r--r--recipes/xfce-base/xfce4-panel_4.6.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/xfce-base/xfce4-panel_4.6.4.bb b/recipes/xfce-base/xfce4-panel_4.6.4.bb
new file mode 100644
index 0000000000..fe402b8690
--- /dev/null
+++ b/recipes/xfce-base/xfce4-panel_4.6.4.bb
@@ -0,0 +1,30 @@
+# xfce4-panel OE build file
+
+DESCRIPTION = "Xfce4 Panel"
+DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
+SECTION = "x11"
+PR = "r0"
+
+inherit xfce46
+
+SRC_URI[md5sum] = "82f10a42aefca4cc26a6633e7478cc65"
+SRC_URI[sha256sum] = "cc9b70bdc73ab80f46655a34cdbaf876a67cd90b50230cbf4d77a3106a5c54e7"
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+ '${PN} plugin for %s', extra_depends='', prepend=True,
+ aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
+ '${sysconfdir}/xdg/xfce/panel/%s-*',
+ '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+ '${bindir}/*%s*'])
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"