aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-03 08:00:42 +0000
committerKoen Kooi <koen@openembedded.org>2009-11-03 09:19:48 +0100
commit55331de7302867eda6b4af59907ec1ec243f099b (patch)
tree9b4bc3950384d819508f7cf18961a2ea15ec241f /recipes/xfce-base
parentab0b2217fe5aa32e68f7a7b26c820fb425f4da3c (diff)
downloadopenembedded-55331de7302867eda6b4af59907ec1ec243f099b.tar.gz
xfce4-panel: Add new upstream 4.6.2 release and checksums.
Diffstat (limited to 'recipes/xfce-base')
-rw-r--r--recipes/xfce-base/xfce4-panel_4.6.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/xfce-base/xfce4-panel_4.6.2.bb b/recipes/xfce-base/xfce4-panel_4.6.2.bb
new file mode 100644
index 0000000000..403dc71dbc
--- /dev/null
+++ b/recipes/xfce-base/xfce4-panel_4.6.2.bb
@@ -0,0 +1,31 @@
+# xfce4-panel OE build file
+
+DESCRIPTION = "Xfce4 Panel"
+DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce46
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+ '${PN} plugin for %s', extra_depends='', prepend=True,
+ aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
+ '${sysconfdir}/xdg/xfce/panel/%s-*',
+ '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+ '${bindir}/*%s*'])
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"