aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-25 10:52:51 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-27 15:26:58 +0100
commitcf508f496dae24acc1b4fd3cecb5dd191b5d69b6 (patch)
tree0138c2b6b924c7426a510404256173adca53e8e6 /recipes/xfce-base
parenteeac84ae328fa18770c3724a23ff847f954f60dc (diff)
downloadopenembedded-cf508f496dae24acc1b4fd3cecb5dd191b5d69b6.tar.gz
XFCE: Rename xfce to xfce-base to support the import of the new XFCE 4.6.1 builds.
Diffstat (limited to 'recipes/xfce-base')
-rw-r--r--recipes/xfce-base/exo/configure.patch43
-rw-r--r--recipes/xfce-base/exo/exo-no-tests.patch14
-rw-r--r--recipes/xfce-base/exo_0.3.4.bb21
-rw-r--r--recipes/xfce-base/gtk-xfce-engine_2.4.2.bb9
-rw-r--r--recipes/xfce-base/libxfce4mcs_4.4.2.bb19
-rw-r--r--recipes/xfce-base/libxfce4util_4.4.2.bb26
-rw-r--r--recipes/xfce-base/libxfcegui4_4.4.2.bb15
-rw-r--r--recipes/xfce-base/mousepad_0.2.13.bb5
-rw-r--r--recipes/xfce-base/orage_4.4.2.bb5
-rw-r--r--recipes/xfce-base/thunar_0.9.0.bb21
-rw-r--r--recipes/xfce-base/xfce-mcs-manager.inc20
-rw-r--r--recipes/xfce-base/xfce-mcs-manager_4.4.2.bb25
-rw-r--r--recipes/xfce-base/xfce-mcs-plugins_4.4.2.bb12
-rw-r--r--recipes/xfce-base/xfce-terminal/into-support.patch94
-rw-r--r--recipes/xfce-base/xfce-terminal_0.2.8.bb11
-rw-r--r--recipes/xfce-base/xfce-utils_4.4.2.bb29
-rw-r--r--recipes/xfce-base/xfce4-appfinder_4.4.2.bb8
-rw-r--r--recipes/xfce-base/xfce4-dev-tools_4.4.0.1.bb13
-rw-r--r--recipes/xfce-base/xfce4-icon-theme_4.4.2.bb6
-rw-r--r--recipes/xfce-base/xfce4-mixer_4.4.2.bb12
-rw-r--r--recipes/xfce-base/xfce4-panel_4.4.2.bb37
-rw-r--r--recipes/xfce-base/xfce4-session_4.4.2.bb4
-rw-r--r--recipes/xfce-base/xfdesktop/fix-segfault-when-removable-icons-are-disabled.patch16
-rw-r--r--recipes/xfce-base/xfdesktop/relocation-and-memleak.patch49
-rw-r--r--recipes/xfce-base/xfdesktop_4.4.2.bb22
-rw-r--r--recipes/xfce-base/xfprint_4.4.2.bb9
-rw-r--r--recipes/xfce-base/xfwm4-themes_4.4.2.bb18
-rw-r--r--recipes/xfce-base/xfwm4_4.4.2.bb31
28 files changed, 594 insertions, 0 deletions
diff --git a/recipes/xfce-base/exo/configure.patch b/recipes/xfce-base/exo/configure.patch
new file mode 100644
index 0000000000..2ccfcfc994
--- /dev/null
+++ b/recipes/xfce-base/exo/configure.patch
@@ -0,0 +1,43 @@
+--- exo-0.3.4/configure.in~ 2007-12-02 10:37:06.000000000 -0200
++++ exo-0.3.4/configure.in 2008-06-05 17:21:42.000000000 -0300
+@@ -127,22 +127,24 @@
+ dnl ***************************************
+ dnl *** Check for strftime() extensions ***
+ dnl ***************************************
+-AC_TRY_RUN([
+- #include <string.h>
+- #include <time.h>
+- int
+- main (int argc, char **argv)
+- {
+- struct tm tm;
+- char buffer[16];
+- tm.tm_year = 81;
+- if (strftime (buffer, 16, "%EY", &tm) == 4 && strcmp (buffer, "1981") == 0)
+- return 0;
+- return 1;
+- }
+-], [
+- AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
+-])
++dnl grrrr... this doesn't work for cross compiling, define it for OE
++AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
++dnl AC_TRY_RUN([
++dnl #include <string.h>
++dnl #include <time.h>
++dnl int
++dnl main (int argc, char **argv)
++dnl {
++dnl struct tm tm;
++dnl char buffer[16];
++dnl tm.tm_year = 81;
++dnl if (strftime (buffer, 16, "%EY", &tm) == 4 && strcmp (buffer, "1981") == 0)
++dnl return 0;
++dnl return 1;
++dnl }
++dnl ], [
++dnl AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
++dnl ])
+
+ dnl ******************************
+ dnl *** Check for i18n support ***
diff --git a/recipes/xfce-base/exo/exo-no-tests.patch b/recipes/xfce-base/exo/exo-no-tests.patch
new file mode 100644
index 0000000000..1cb51ab600
--- /dev/null
+++ b/recipes/xfce-base/exo/exo-no-tests.patch
@@ -0,0 +1,14 @@
+The tests/ subdir consists of stuff trying to run a generated file ('exo-csource'), which doesn't work on host systems
+
+--- /tmp/Makefile.am 2008-10-30 09:23:41.000000000 +0100
++++ exo-0.3.4/Makefile.am 2008-10-30 09:24:03.011124000 +0100
+@@ -23,8 +23,7 @@
+ pixmaps \
+ po \
+ po-doc \
+- $(PYTHON_SUBDIR) \
+- tests
++ $(PYTHON_SUBDIR)
+
+ AUTOMAKE_OPTIONS = \
+ 1.8 \
diff --git a/recipes/xfce-base/exo_0.3.4.bb b/recipes/xfce-base/exo_0.3.4.bb
new file mode 100644
index 0000000000..17ea87d3d3
--- /dev/null
+++ b/recipes/xfce-base/exo_0.3.4.bb
@@ -0,0 +1,21 @@
+DEPENDS = "libxfce4util xfce-mcs-manager hal liburi-perl-native python-native"
+
+inherit xfce
+XFCE_VERSION = 4.4.2
+
+SRC_URI += " file://configure.patch;patch=1"
+SRC_URI += " file://exo-no-tests.patch;patch=1"
+
+# Note: Python checking is broken
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.in
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/xfce4/ \
+ ${libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so"
+FILES_${PN}-dev += "${libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.*"
+FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug/exo-preferred-applications-settings.*"
diff --git a/recipes/xfce-base/gtk-xfce-engine_2.4.2.bb b/recipes/xfce-base/gtk-xfce-engine_2.4.2.bb
new file mode 100644
index 0000000000..0287f04485
--- /dev/null
+++ b/recipes/xfce-base/gtk-xfce-engine_2.4.2.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "XFCE theme for GTK"
+DEPENDS += "gtk+"
+
+inherit xfce
+XFCE_VERSION = 4.4.2
+
+FILES_${PN} += "${libdir}/gtk-2.0/*/engines/libxfce.so \
+ ${datadir}/themes/"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/*/engines/.debug"
diff --git a/recipes/xfce-base/libxfce4mcs_4.4.2.bb b/recipes/xfce-base/libxfce4mcs_4.4.2.bb
new file mode 100644
index 0000000000..20448240e2
--- /dev/null
+++ b/recipes/xfce-base/libxfce4mcs_4.4.2.bb
@@ -0,0 +1,19 @@
+# libxfce4mcs OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="Settings management library used by most XFce 4 modules"
+DEPENDS="libxfce4util"
+SECTION = "x11/libs"
+
+inherit xfce pkgconfig
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xfce4/libxfce4mcs
+
+ install -m 644 libxfce4mcs/mcs-common.h ${STAGING_INCDIR}/xfce4/libxfce4mcs
+ install -m 644 libxfce4mcs/mcs-client.h ${STAGING_INCDIR}/xfce4/libxfce4mcs
+ install -m 644 libxfce4mcs/mcs-manager.h ${STAGING_INCDIR}/xfce4/libxfce4mcs
+ oe_libinstall -C libxfce4mcs -so libxfce4mcs-manager ${STAGING_LIBDIR}
+ oe_libinstall -C libxfce4mcs -so libxfce4mcs-client ${STAGING_LIBDIR}
+}
diff --git a/recipes/xfce-base/libxfce4util_4.4.2.bb b/recipes/xfce-base/libxfce4util_4.4.2.bb
new file mode 100644
index 0000000000..3386ad57e3
--- /dev/null
+++ b/recipes/xfce-base/libxfce4util_4.4.2.bb
@@ -0,0 +1,26 @@
+# libxfce4util OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xfce4-dev-tools"
+
+inherit xfce pkgconfig
+
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
+ # The line below expands to the list of headers that native makefile
+ # would install. Complain and/or fix if it's not portable enough
+ for file in $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+
+}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"
diff --git a/recipes/xfce-base/libxfcegui4_4.4.2.bb b/recipes/xfce-base/libxfcegui4_4.4.2.bb
new file mode 100644
index 0000000000..d38269d6f8
--- /dev/null
+++ b/recipes/xfce-base/libxfcegui4_4.4.2.bb
@@ -0,0 +1,15 @@
+# libxfcegui4 OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "XFCE Widget library and X Window System interaction"
+DEPENDS = "libxfce4util dbh libxml2 gtk+"
+SECTION = "x11/libs"
+
+inherit xfce
+
+do_stage() {
+autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/xfce4/modules ${datadir}/xfce4/mime ${datadir}/icons/hicolor"
diff --git a/recipes/xfce-base/mousepad_0.2.13.bb b/recipes/xfce-base/mousepad_0.2.13.bb
new file mode 100644
index 0000000000..c55ce5a047
--- /dev/null
+++ b/recipes/xfce-base/mousepad_0.2.13.bb
@@ -0,0 +1,5 @@
+DESCRIPTION = "Text editor for Xfce based on Leafpad"
+DEPENDS = "libxfce4util xfce-mcs-manager hal liburi-perl-native python-native"
+
+inherit xfce
+XFCE_VERSION = 4.4.2
diff --git a/recipes/xfce-base/orage_4.4.2.bb b/recipes/xfce-base/orage_4.4.2.bb
new file mode 100644
index 0000000000..b8f5284454
--- /dev/null
+++ b/recipes/xfce-base/orage_4.4.2.bb
@@ -0,0 +1,5 @@
+DESCRIPTION = "Calendar application for the Xfce Desktop Environment"
+DEPENDS = "libxfcegui4 exo libxml-parser-perl-native xfce4-panel xfce-mcs-manager"
+RREPLACES = "xfcalendar"
+
+inherit xfce
diff --git a/recipes/xfce-base/thunar_0.9.0.bb b/recipes/xfce-base/thunar_0.9.0.bb
new file mode 100644
index 0000000000..44afb06774
--- /dev/null
+++ b/recipes/xfce-base/thunar_0.9.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "File manager for the Xfce Desktop Environment"
+DEPENDS = "libxfcegui4 exo dbus-glib libexif xfce4-panel libice libsm gamin"
+RRECOMMENDS = "shared-mime-info"
+
+inherit xfce pkgconfig
+
+SRC_URI = "http://www.us.xfce.org/archive/xfce-4.4.2/src/Thunar-${PV}.tar.bz2"
+PR = 'r3'
+
+S = "${WORKDIR}/Thunar-${PV}/"
+
+FILES_${PN} += "${libdir}/thunarx-1/*.so \
+ ${datadir}/dbus-1 \
+ ${datadir}/thumbnailers \
+ ${datadir}/Thunar \
+ ${datadir}/xfce4"
+FILES_${PN}-dbg += "${libdir}/thunarx-1/.debug/ ${libexecdir}/xfce4/panel-plugins/.debug/"
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/xfce-base/xfce-mcs-manager.inc b/recipes/xfce-base/xfce-mcs-manager.inc
new file mode 100644
index 0000000000..4edbf9d13b
--- /dev/null
+++ b/recipes/xfce-base/xfce-mcs-manager.inc
@@ -0,0 +1,20 @@
+# xfce-mcs-manager OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Settings manager."
+DEPENDS="libxfcegui4 libxfce4mcs intltool-native"
+SECTION = "x11"
+PR = "r2"
+
+inherit xfce
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+do_stage_append () {
+ install -d ${PKG_CONFIG_DIR}
+ sed -e 's:^includedir=.*:includedir="/usr/include":;' ${S}/xfce-mcs-manager/xfce-mcs-manager.pc >${PKG_CONFIG_DIR}/xfce-mcs-manager.pc
+}
diff --git a/recipes/xfce-base/xfce-mcs-manager_4.4.2.bb b/recipes/xfce-base/xfce-mcs-manager_4.4.2.bb
new file mode 100644
index 0000000000..0b9fc43f70
--- /dev/null
+++ b/recipes/xfce-base/xfce-mcs-manager_4.4.2.bb
@@ -0,0 +1,25 @@
+# xfce-mcs-manager OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Settings manager."
+DEPENDS="libxfcegui4 libxfce4mcs intltool-native"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xfce4
+ install -d ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+ install -m 644 xfce-mcs-manager/manager-plugin.h ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+}
+
+# xfce-mcs-manager.pc uses ${libdir} to indicate where the mcs plugins live
+# the standard pkgconfig mangling was confusing us. Mangling is not required
+# for this particular .pc, so the following will suffice:
+
+do_stage_append () {
+ install -d ${PKG_CONFIG_DIR}
+ sed -e 's:^includedir=.*:includedir="/usr/include":;' ${S}/xfce-mcs-manager/xfce-mcs-manager.pc >${PKG_CONFIG_DIR}/xfce-mcs-manager.pc
+}
diff --git a/recipes/xfce-base/xfce-mcs-plugins_4.4.2.bb b/recipes/xfce-base/xfce-mcs-plugins_4.4.2.bb
new file mode 100644
index 0000000000..80037841fa
--- /dev/null
+++ b/recipes/xfce-base/xfce-mcs-plugins_4.4.2.bb
@@ -0,0 +1,12 @@
+# xfce-mcs-plugins OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "Common XFCE4 configuration plugins."
+DEPENDS = "libxfcegui4 xfce-mcs-manager gtk+"
+SECTION = "x11"
+
+inherit xfce
+
+PACKAGES += "${PN}-mcs-plugins"
+FILES_${PN}-mcs-plugins = "${libdir}/xfce4/mcs-plugins/*.so"
diff --git a/recipes/xfce-base/xfce-terminal/into-support.patch b/recipes/xfce-base/xfce-terminal/into-support.patch
new file mode 100644
index 0000000000..30540d0558
--- /dev/null
+++ b/recipes/xfce-base/xfce-terminal/into-support.patch
@@ -0,0 +1,94 @@
+diff --git a/terminal/terminal-app.c b/terminal/terminal-app.c
+index 4b7ae6f..a581a85 100644
+--- a/terminal/terminal-app.c
++++ b/terminal/terminal-app.c
+@@ -37,6 +37,8 @@
+ #include <string.h>
+ #endif
+
++#include <gdk/gdkx.h>
++
+ #include <terminal/terminal-accel-map.h>
+ #include <terminal/terminal-app.h>
+ #include <terminal/terminal-config.h>
+@@ -565,7 +567,8 @@ terminal_app_open_window (TerminalApp *app,
+ g_free (geometry);
+
+ /* show the window */
+- gtk_widget_show (window);
++ if (!attr->embed_window)
++ gtk_widget_show (window);
+ }
+
+ terminal_screen_launch_child (TERMINAL_SCREEN (terminal));
+@@ -584,6 +587,14 @@ terminal_app_open_window (TerminalApp *app,
+ g_signal_connect (G_OBJECT (app->session_client), "save-yourself",
+ G_CALLBACK (terminal_app_save_yourself), app);
+ }
++
++ if (attr->embed_window)
++ {
++ GdkDrawable* win = GDK_DRAWABLE(window->window);
++ XReparentWindow(GDK_DRAWABLE_XDISPLAY(win), GDK_DRAWABLE_XID(win), attr->embed_window, 0, 0);
++ XMapWindow(GDK_DRAWABLE_XDISPLAY(win), GDK_DRAWABLE_XID(win));
++ gtk_widget_show(window);
++ }
+ }
+
+
+diff --git a/terminal/terminal-options.c b/terminal/terminal-options.c
+index ec6a934..ad9dace 100644
+--- a/terminal/terminal-options.c
++++ b/terminal/terminal-options.c
+@@ -30,6 +30,8 @@
+ #include <string.h>
+ #endif
+
++#include <stdlib.h>
++
+ #include <libxfce4util/libxfce4util.h>
+
+ #include <terminal/terminal-options.h>
+@@ -454,6 +456,31 @@ terminal_options_parse (gint argc,
+ g_free (default_directory);
+ default_directory = g_strdup (s);
+ }
++ else if (strncmp ("--into", argv[n], 6) == 0)
++ {
++ s = argv[n] + 6;
++
++ if (*s == '=')
++ {
++ ++s;
++ }
++ else if (n + 1 >= argc)
++ {
++ g_set_error (error, G_SHELL_ERROR, G_SHELL_ERROR_FAILED,
++ _("Option \"--into\" requires specifying "
++ "the window id as its parameter"));
++ goto failed;
++ }
++ else
++ {
++ s = argv[++n];
++ }
++
++ if (win_attr != NULL)
++ {
++ win_attr->embed_window = strtoul(s, NULL, 0);
++ }
++ }
+ else
+ {
+ g_set_error (error, G_SHELL_ERROR, G_SHELL_ERROR_FAILED,
+diff --git a/terminal/terminal-options.h b/terminal/terminal-options.h
+index b047269..4783596 100644
+--- a/terminal/terminal-options.h
++++ b/terminal/terminal-options.h
+@@ -65,5 +65,6 @@ struct _TerminalWindowAttr
+ TerminalVisibility borders;
+ TerminalVisibility toolbars;
++ guint32 embed_window;
+ };
+
+ gboolean terminal_options_parse (gint argc,
diff --git a/recipes/xfce-base/xfce-terminal_0.2.8.bb b/recipes/xfce-base/xfce-terminal_0.2.8.bb
new file mode 100644
index 0000000000..c8c4903513
--- /dev/null
+++ b/recipes/xfce-base/xfce-terminal_0.2.8.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Terminal emulator for the Xfce desktop environment"
+DEPENDS = "exo vte dbus-glib gtk+"
+RDEPENDS += "gnome-pty-helper"
+PR = "r2"
+
+inherit xfce
+
+SRC_URI = "http://www.us.xfce.org/archive/xfce-4.4.2/src/Terminal-${PV}.tar.bz2 \
+ file://into-support.patch;patch=1"
+
+S = "${WORKDIR}/Terminal-${PV}"
diff --git a/recipes/xfce-base/xfce-utils_4.4.2.bb b/recipes/xfce-base/xfce-utils_4.4.2.bb
new file mode 100644
index 0000000000..d681fd7adb
--- /dev/null
+++ b/recipes/xfce-base/xfce-utils_4.4.2.bb
@@ -0,0 +1,29 @@
+# xfce-utils OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Utilities"
+DEPENDS = "virtual/libx11 libxfcegui4 xfce-mcs-manager"
+inherit xfce
+
+FILES_${PN} += " \
+ ${bindir}/* \
+ ${datadir}/dbus-1/* \
+ ${datadir}/xfce4/AUTHORS \
+ ${datadir}/xfce4/BSD \
+ ${datadir}/xfce4/COPYING \
+ ${datadir}/xfce4/GPL \
+ ${datadir}/xfce4/INFO \
+ ${datadir}/xfce4/LGPL \
+ ${datadir}/xfce4/AUTHORS.html \
+ ${datadir}/xfce4/BSD.html \
+ ${datadir}/xfce4/COPYING.html \
+ ${datadir}/xfce4/GPL.html \
+ ${datadir}/xfce4/INFO.html \
+ ${datadir}/xfce4/LGPL.html"
+
+PACKAGES =+ "${PN}-mcs-plugins"
+FILES_${PN}-mcs-plugins = "${libdir}/xfce4/mcs-plugins/"
+
+# NOTE: This package takes a --with-browser for the default browser
+# NOTE: Works with gdm also gtkhtml
diff --git a/recipes/xfce-base/xfce4-appfinder_4.4.2.bb b/recipes/xfce-base/xfce4-appfinder_4.4.2.bb
new file mode 100644
index 0000000000..ddfa3e1e4e
--- /dev/null
+++ b/recipes/xfce-base/xfce4-appfinder_4.4.2.bb
@@ -0,0 +1,8 @@
+# xfce4-appfinder build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE Application Finder"
+SECTION = "x11"
+inherit xfce
+DEPENDS="libxfcegui4"
diff --git a/recipes/xfce-base/xfce4-dev-tools_4.4.0.1.bb b/recipes/xfce-base/xfce4-dev-tools_4.4.0.1.bb
new file mode 100644
index 0000000000..67c2d341de
--- /dev/null
+++ b/recipes/xfce-base/xfce4-dev-tools_4.4.0.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Xfce4 development tools"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+
+inherit xfce
+XFCE_VERSION = 4.4.2
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 644 m4macros/*.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/dev-tools/m4macros/*.m4"
diff --git a/recipes/xfce-base/xfce4-icon-theme_4.4.2.bb b/recipes/xfce-base/xfce4-icon-theme_4.4.2.bb
new file mode 100644
index 0000000000..69d9dacbac
--- /dev/null
+++ b/recipes/xfce-base/xfce4-icon-theme_4.4.2.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "Rodent vector icon theme used by XFCE"
+PACKAGE_ARCH = "all"
+
+inherit xfce
+
+FILES_${PN} += "${datadir}/xfce4"
diff --git a/recipes/xfce-base/xfce4-mixer_4.4.2.bb b/recipes/xfce-base/xfce4-mixer_4.4.2.bb
new file mode 100644
index 0000000000..60bb012810
--- /dev/null
+++ b/recipes/xfce-base/xfce4-mixer_4.4.2.bb
@@ -0,0 +1,12 @@
+# xfce-mixer-plugin OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE panel mixer plugin"
+SECTION = "x11"
+
+DEPENDS="xfce4-panel"
+inherit xfce
+
+FILES_${PN}-dev += "${libdir}/xfce4/modules/libxfce4mixer.so"
+FILES_${PN}-dbg += "${libexecdir}/xfce4/panel-plugins/.debug/"
diff --git a/recipes/xfce-base/xfce4-panel_4.4.2.bb b/recipes/xfce-base/xfce4-panel_4.4.2.bb
new file mode 100644
index 0000000000..2fd087733e
--- /dev/null
+++ b/recipes/xfce-base/xfce4-panel_4.4.2.bb
@@ -0,0 +1,37 @@
+# xfce4-panel OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "XFCE4 Panel"
+SECTION = "x11"
+DEPENDS = "startup-notification virtual/libx11 libxfcegui4 libxfce4mcs xfce-mcs-manager libxml2"
+
+inherit pkgconfig xfce
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+
+do_stage() {
+autotools_stage_all
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+ '${PN} plugin for %s', extra_depends='', prepend=True,
+ aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
+ '${sysconfdir}/xdg/xfce/panel/%s-*',
+ '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+ '${bindir}/*%s*'])
+}
+
+PACKAGES += "${PN}-mcs-plugins"
+PACKAGES_DYNAMIC = "${PN}-plugin-*"
+
+FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/"
+FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug"
diff --git a/recipes/xfce-base/xfce4-session_4.4.2.bb b/recipes/xfce-base/xfce4-session_4.4.2.bb
new file mode 100644
index 0000000000..a572b80f55
--- /dev/null
+++ b/recipes/xfce-base/xfce4-session_4.4.2.bb
@@ -0,0 +1,4 @@
+DESCRIPTION = "Calendar application for the Xfce Desktop Environment"
+DEPENDS = "libxfcegui4 libxfce4util xfce-mcs-manager dbus"
+
+inherit xfce
diff --git a/recipes/xfce-base/xfdesktop/fix-segfault-when-removable-icons-are-disabled.patch b/recipes/xfce-base/xfdesktop/fix-segfault-when-removable-icons-are-disabled.patch
new file mode 100644
index 0000000000..af5bc4cd96
--- /dev/null
+++ b/recipes/xfce-base/xfdesktop/fix-segfault-when-removable-icons-are-disabled.patch
@@ -0,0 +1,16 @@
+diff -Nur xfdesktop-4.4.2-BKP/src/xfdesktop-file-icon-manager.c xfdesktop-4.4.2/src/xfdesktop-file-icon-manager.c
+--- xfdesktop-4.4.2-BKP/src/xfdesktop-file-icon-manager.c 2008-11-03 16:19:46.000000000 -0200
++++ xfdesktop-4.4.2/src/xfdesktop-file-icon-manager.c 2008-11-03 16:20:45.000000000 -0200
+@@ -2046,8 +2046,10 @@
+
+ g_hash_table_foreach(fmanager->priv->icons,
+ file_icon_hash_write_icons, rcfile);
+- g_hash_table_foreach(fmanager->priv->removable_icons,
+- file_icon_hash_write_icons, rcfile);
++ if(fmanager->priv->show_removable_media) {
++ g_hash_table_foreach(fmanager->priv->removable_icons,
++ file_icon_hash_write_icons, rcfile);
++ }
+ g_hash_table_foreach(fmanager->priv->special_icons,
+ file_icon_hash_write_icons, rcfile);
+
diff --git a/recipes/xfce-base/xfdesktop/relocation-and-memleak.patch b/recipes/xfce-base/xfdesktop/relocation-and-memleak.patch
new file mode 100644
index 0000000000..df9011d8da
--- /dev/null
+++ b/recipes/xfce-base/xfdesktop/relocation-and-memleak.patch
@@ -0,0 +1,49 @@
+Patch taken from Gentoo at http://overlays.gentoo.org/svn/proj/alt/trunk/prefix-overlay/xfce-base/xfdesktop/files/
+
+Included by: Otavio Salvador <otavio@ossystems.com.br>
+
+diff -ur xfdesktop-4.4.2.orig/modules/menu/desktop-menu-dentry.c xfdesktop-4.4.2/modules/menu/desktop-menu-dentry.c
+--- xfdesktop-4.4.2.orig/modules/menu/desktop-menu-dentry.c 2007-11-17 21:31:43.000000000 +0200
++++ xfdesktop-4.4.2/modules/menu/desktop-menu-dentry.c 2008-03-21 11:18:59.000000000 +0200
+@@ -173,7 +173,8 @@
+ if(cmpname && g_ascii_strcasecmp(name, cmpname) < 0)
+ break;
+ }
+-
++ g_list_free(items);
++
+ gtk_menu_shell_insert(menu_shell, mi, i);
+
+ return i;
+diff -ur xfdesktop-4.4.2.orig/modules/menu/desktop-menuspec.c xfdesktop-4.4.2/modules/menu/desktop-menuspec.c
+--- xfdesktop-4.4.2.orig/modules/menu/desktop-menuspec.c 2007-11-17 21:31:43.000000000 +0200
++++ xfdesktop-4.4.2/modules/menu/desktop-menuspec.c 2008-03-21 11:18:59.000000000 +0200
+@@ -203,7 +203,7 @@
+ else
+ foundcat = NULL;
+ if(!foundcat) {
+- g_ptr_array_free(revpath, FALSE);
++ g_ptr_array_free(revpath, TRUE);
+ revpath = NULL;
+ break;
+ }
+@@ -220,7 +220,7 @@
+ newpath[totlen] = 0;
+
+ g_ptr_array_add(mtfpi->paths, newpath);
+- g_ptr_array_free(revpath, FALSE);
++ g_ptr_array_free(revpath, TRUE);
+ }
+ }
+ }
+diff -ur xfdesktop-4.4.2.orig/modules/menu/desktop-menuspec.h xfdesktop-4.4.2/modules/menu/desktop-menuspec.h
+--- xfdesktop-4.4.2.orig/modules/menu/desktop-menuspec.h 2007-11-17 21:31:43.000000000 +0200
++++ xfdesktop-4.4.2/modules/menu/desktop-menuspec.h 2008-03-21 11:18:56.000000000 +0200
+@@ -82,6 +82,6 @@
+ * @param paths A GPtrArray obtained from either menuspec_get_path_simple() or
+ * menuspec_get_path_multilevel().
+ */
+-G_INLINE_FUNC void desktop_menuspec_path_free(GPtrArray *paths);
++void desktop_menuspec_path_free(GPtrArray *paths);
+
+ #endif /* ifdef __MENUSPEC_H__ */
diff --git a/recipes/xfce-base/xfdesktop_4.4.2.bb b/recipes/xfce-base/xfdesktop_4.4.2.bb
new file mode 100644
index 0000000000..3129feba23
--- /dev/null
+++ b/recipes/xfce-base/xfdesktop_4.4.2.bb
@@ -0,0 +1,22 @@
+# xfdesktop OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="xfce4 Desktop Background Manager"
+SECTION = "x11/base"
+DEPENDS = "virtual/libx11 libxfcegui4 libxfce4mcs libxml2 xfce4-panel thunar"
+PR = "r2"
+
+inherit xfce
+
+SRC_URI += " file://relocation-and-memleak.patch;patch=1 \
+ file://fix-segfault-when-removable-icons-are-disabled.patch;patch=1"
+
+PACKAGES += "xfdesktop-backdrops ${PN}-mcs-plugins"
+
+FILES_xfdesktop-backdrops="${datadir}/xfce4/backdrops/*"
+FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/*.so"
+FILES_${PN} += "${libdir}/xfce4/panel-plugins/*.so \
+ ${libdir}/xfce4/panel-plugins/xfce4-menu-plugin \
+ ${datadir}/xfce4/panel-plugins/*.desktop"
+FILES_${PN}-dbg += "/usr/libexec/xfce4/panel-plugins/.debug"
diff --git a/recipes/xfce-base/xfprint_4.4.2.bb b/recipes/xfce-base/xfprint_4.4.2.bb
new file mode 100644
index 0000000000..19bfa0dde3
--- /dev/null
+++ b/recipes/xfce-base/xfprint_4.4.2.bb
@@ -0,0 +1,9 @@
+# xfprint OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Print Manager"
+SECTION = "x11/base"
+
+DEPENDS="libxfcegui4"
+inherit xfce
diff --git a/recipes/xfce-base/xfwm4-themes_4.4.2.bb b/recipes/xfce-base/xfwm4-themes_4.4.2.bb
new file mode 100644
index 0000000000..63c5ab0296
--- /dev/null
+++ b/recipes/xfce-base/xfwm4-themes_4.4.2.bb
@@ -0,0 +1,18 @@
+# xfwm4-themes OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Window Manager Themes"
+SECTION = "x11/wm"
+
+inherit xfce
+
+# No ${PN} for this one
+PACKAGES=""
+
+PACKAGES_DYNAMIC = "xfwm4-theme-*"
+
+python populate_packages_prepend () {
+ themedir = bb.data.expand('${datadir}/xfwm4/themes', d)
+ do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
+}
diff --git a/recipes/xfce-base/xfwm4_4.4.2.bb b/recipes/xfce-base/xfwm4_4.4.2.bb
new file mode 100644
index 0000000000..8d1a1835cf
--- /dev/null
+++ b/recipes/xfce-base/xfwm4_4.4.2.bb
@@ -0,0 +1,31 @@
+# xfwm4 OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Window Manager"
+SECTION = "x11/wm"
+inherit xfce update-alternatives
+
+FILES_${PN} += "${datadir}/xfwm4/defaults ${datadir}/xfwm4/themes/default.keys/*"
+
+DEPENDS = "startup-notification virtual/libx11 libxpm libxfce4util libxfcegui4 libxfce4mcs xfce-mcs-manager"
+RDEPENDS = "xfwm4-theme-default"
+
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+PACKAGES_DYNAMIC += "xfwm4-theme-*"
+
+python populate_packages_prepend () {
+ themedir = bb.data.expand('${datadir}/themes', d)
+ do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
+}
+
+PACKAGES += " ${PN}-mcs-plugins"
+
+FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/*.so"
+
+ALTERNATIVE_PATH = "${bindir}/xfce4-session"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "10"