aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2010-04-22 12:10:17 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-23 13:39:33 +0200
commite3df76459f7710af61d1b51066e0685c822dbe7b (patch)
tree67e4644b8463f67a6cbb10ce4bba80fa9e99c6c0 /recipes/xfce-base
parent28a068820bc4ef6bac5a4eb1b7438fd8628cdcf7 (diff)
downloadopenembedded-e3df76459f7710af61d1b51066e0685c822dbe7b.tar.gz
xfce4-panel: Add 4.6.3 and support new style checksums in xfce46.bbclass.
Diffstat (limited to 'recipes/xfce-base')
-rw-r--r--recipes/xfce-base/xfce4-panel_4.6.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/xfce-base/xfce4-panel_4.6.3.bb b/recipes/xfce-base/xfce4-panel_4.6.3.bb
new file mode 100644
index 0000000000..498ee32be4
--- /dev/null
+++ b/recipes/xfce-base/xfce4-panel_4.6.3.bb
@@ -0,0 +1,30 @@
+# xfce4-panel OE build file
+
+DESCRIPTION = "Xfce4 Panel"
+DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce46
+
+SRC_URI[archive.md5sum] = "0b715abb929220f136483ccd7303ff62"
+SRC_URI[archive.sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+ '${PN} plugin for %s', extra_depends='', prepend=True,
+ aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
+ '${sysconfdir}/xdg/xfce/panel/%s-*',
+ '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+ '${bindir}/*%s*'])
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"