aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xmame/xmame_0.86.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xmame/xmame_0.86.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xmame/xmame_0.86.bb')
-rw-r--r--recipes/xmame/xmame_0.86.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/xmame/xmame_0.86.bb b/recipes/xmame/xmame_0.86.bb
new file mode 100644
index 0000000000..a5801e73da
--- /dev/null
+++ b/recipes/xmame/xmame_0.86.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Multiple Arcade Machine Emulator based on SDL"
+LICENSE = "xmame"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "expat virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://x.mame.net/download/historic/${P}.tar.bz2 \
+ file://${FILESDIR}/crosscompile.patch;patch=1"
+
+inherit flow-lossage
+
+EXTRA_OEMAKE=
+
+do_compile() {
+ oe_runmake TARGET=mame JOY_SDL=1 SOUND_SDL=1 DISPLAY_METHOD=SDL \
+ CC="${CC}" CXX="${CXX}" CFLAGS="-I. -Isrc -Isrc/include -Isrc/unix ${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}" \
+ RANLIB="${RANLIB}" MY_CPU="${TARGET_ARCH}" ARCH="${TARGET_OS}" \
+ GLLIBS="" STRIP="${STRIP}" AR="${AR}"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 xmame.SDL ${D}${bindir}
+}
+